Bug 474303 - When adding virtual machine,the storage grid has no storage information.
When adding virtual machine,the storage grid has no storage information.
Status: CLOSED CURRENTRELEASE
Product: Virtualization Tools
Classification: Community
Component: ovirt-server-suite (Show other bugs)
unspecified
All Linux
high Severity medium
: ---
: ---
Assigned To: Hugh Brock
: Desktop
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-03 03:14 EST by Jia Dong
Modified: 2010-03-16 13:16 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-09 16:58:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of empty storage pool (21.42 KB, image/png)
2008-12-09 07:48 EST, Thorsten Scherf
no flags Details
storage pool state is pending (40.77 KB, image/png)
2008-12-09 08:50 EST, Thorsten Scherf
no flags Details

  None (edit)
Description Jia Dong 2008-12-03 03:14:39 EST
Description of problem:
When adding virtual machine,the storage grid has no storage information.It is disable to choose a storage for new virtual machine.

Version-Release number of selected component (if applicable):
ovirt-0.95

How reproducible:
always

Steps to Reproduce:
1.Make sure have create storages in "default" hardware pool(NFS or iSCSI)(According this to create: http://www.ovirt.org/quick-tour.html)
2.Make sure a virtual machine exist or create a new virtual machine pool in "default" hardware pool
3.Create a new virtual machine
  
Actual results:
In the dialogue of creating virtual machine,there is no storage for selecting in storage grid.  

Expected results:
It should display available storages for selecting in storage grid.

Additional info:
Comment 1 Thorsten Scherf 2008-12-09 07:38:19 EST
I see the same behaviour with 0.96 version.
Comment 2 Thorsten Scherf 2008-12-09 07:39:23 EST
increased priority
Comment 3 Thorsten Scherf 2008-12-09 07:48:58 EST
Created attachment 326298 [details]
screenshot of empty storage pool
Comment 4 Thorsten Scherf 2008-12-09 07:50:32 EST
This is from taskomatic log:

refresh_pool
Task action processing failed: RuntimeError: Could not find a host to scan storage
/usr/share/ovirt-server/task-omatic/./task_storage.rb:96:in `storage_find_suitable_host'
/usr/share/ovirt-server/task-omatic/./task_storage.rb:121:in `refresh_pool'
/usr/share/ovirt-server/task-omatic/taskomatic.rb:109
/usr/share/ovirt-server/task-omatic/taskomatic.rb:88:in `each'
/usr/share/ovirt-server/task-omatic/taskomatic.rb:88
/usr/share/ovirt-server/task-omatic/taskomatic.rb:68:in `loop'
/usr/share/ovirt-server/task-omatic/taskomatic.rb:68
done
create_vm
done

I exactly followed the setup instrutions on http://www.ovirt.org/quick-tour.html to setup virtual machine and storage pool.
Comment 5 Thorsten Scherf 2008-12-09 08:50:54 EST
Created attachment 326313 [details]
storage pool state is pending
Comment 6 Thorsten Scherf 2008-12-09 09:10:51 EST
on more info: state of node3, which has been added to the virtual machine pool, is unavailable (enabled). looks like this is the problem, now have to figure out why its state is unavailable.
Comment 7 Thorsten Scherf 2008-12-09 16:58:35 EST
using new libvirt-qpid-0.2.3-0.i386 fixed the problem

Note You need to log in before you can comment on or make changes to this bug.