Bug 474329 - Elo Touchmonitor - cursor on touch screen not working (moving)
Elo Touchmonitor - cursor on touch screen not working (moving)
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-evdev (Show other bugs)
10
i686 Linux
low Severity high
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-03 06:11 EST by Jiri Lisicky
Modified: 2018-04-11 07:03 EDT (History)
2 users (show)

See Also:
Fixed In Version: as of yesterday
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-19 18:59:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logs before workaroud (2.36 KB, text/plain)
2008-12-03 06:19 EST, Jiri Lisicky
no flags Details
workaround (428 bytes, text/plain)
2008-12-03 06:22 EST, Jiri Lisicky
no flags Details
Xorg log after workaround (866 bytes, text/plain)
2008-12-03 06:23 EST, Jiri Lisicky
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 19224 None None None Never

  None (edit)
Description Jiri Lisicky 2008-12-03 06:11:55 EST
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; cs-CZ; rv:1.8.1.14) Gecko/20080416 Fedora/2.0.0.14-1.fc7 Firefox/2.0.0.14

System is seeing this hardware thru hal-device but in xorg not working.

evdev not merge this driver because 10-x11-input.fdi want 
<match key="info.capabilities" contains="input.mouse"> 
and Elo Touch have:
info.capabilities = { 'input', 'button', 'input.joystick', 'access_control' } (string list)

I found dirty workaroud. Add file /usr/share/hal/fdi/policy/10osvendor/10-x11-input-elotouch.fdi


Reproducible: Always

Steps to Reproduce:
1. have hardware with Tlo Touchmonitor
2. run xorg 1.5.3
3. touch finger on screen
Actual Results:  
mouse cursor is not moving

Expected Results:  
moving mouse cursor
Comment 1 Jiri Lisicky 2008-12-03 06:19:28 EST
Created attachment 325518 [details]
logs before workaroud
Comment 2 Jiri Lisicky 2008-12-03 06:22:06 EST
Created attachment 325519 [details]
workaround

/usr/share/hal/fdi/policy/10osvendor/10-x11-input-elotouch.fdi
Comment 3 Jiri Lisicky 2008-12-03 06:23:18 EST
Created attachment 325520 [details]
Xorg log after workaround
Comment 4 Peter Hutterer 2008-12-09 20:52:13 EST
please get http://people.freedesktop.org/~whot/evtest.c, compile it with gcc -o evtest evtest.c and then run it against the device file using ./evtest /dev/input/eventX (where X is the number of the device). Then attach the initial output here. I'd like to see what capabilities the device reports.
Comment 5 Jiri Lisicky 2008-12-17 07:09:25 EST
(In reply to comment #4)

$ ./evtest /dev/input/event3
Input driver version is 1.0.0
Input device ID: bus 0x3 vendor 0x4e7 product 0x20 version 0x100
Input device name: "Elo TouchSystems, Inc. Elo TouchSystems 2700 IntelliTouch(r) USB Touchmonitor Interface"
Supported events:
  Event type 0 (Sync)
  Event type 1 (Key)
    Event code 272 (LeftBtn)
  Event type 3 (Absolute)
    Event code 0 (X)
      Value    188
      Min        0
      Max     4095
    Event code 1 (Y)
      Value   2965
      Min        0
      Max     4095
    Event code 40 (Misc)
      Value      0
      Min        0
      Max      256
  Event type 4 (Misc)
    Event code 4 (ScanCode)
Grab succeeded, ungrabbing.
Comment 6 Peter Hutterer 2008-12-17 18:51:29 EST
Please try the packages from http://koji.fedoraproject.org/scratch/whot/task_1002708/ and let me know how it goes. Note that you need to restart X after restarting HAL. If it doesn't work, please attach the output from lshal again.
Comment 7 Jiri Lisicky 2008-12-19 10:44:44 EST
I removed my workaroud, update hal and hal-libs and it works! Great.
Thank you.
Comment 8 Matěj Cepl 2008-12-19 18:59:49 EST
THanks for letting us know.
Comment 9 Peter Hutterer 2008-12-21 19:38:31 EST
Bug reported upstream at https://bugs.freedesktop.org/show_bug.cgi?id=19224.
Comment 10 Fedora Update System 2008-12-22 17:20:59 EST
hal-0.5.12-14.20081027git.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/hal-0.5.12-14.20081027git.fc10
Comment 11 Fedora Update System 2009-01-14 22:07:33 EST
hal-0.5.12-14.20081027git.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.