Bug 474348 - Anaconda prompts for network configuration on Dell PE1950
Anaconda prompts for network configuration on Dell PE1950
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-03 07:57 EST by Vadim Grinco
Modified: 2008-12-03 12:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-03 10:29:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vadim Grinco 2008-12-03 07:57:10 EST
Description of problem:
It is not possible to non-interactively kick F8{8,9} on a Dell PE1950. It always prompts for network settings.

How reproducible:
Generate a non-interactive kickstart file and kick F{8,9} from it.

Steps to Reproduce:
1. Generate a non interactive kickstart
2. Run installation with "ks=path_to_your_ks.cfg ksdevice=link"
3. Watch...
  
Actual results:
A prompt to configure networking:

+-------------------------------------------------------+
|[55C|
| Sending request for IP information for eth0...[8C|
|[55C|
+-------------------------------------------------------+

[1K +-------------+ Configure TCP/IP +-------------+
[1K |[46C|
[1K | [*] Enable IPv4 support[22C|
[1K |[8C(*) Dynamic IP configuration (DHCP)   |
[1K |[8C( ) Manual configuration[14C|
[1K |[46C|
[1K | [*] Enable IPv6 support[22C|
[1K |[8C(*) Automatic neighbor discovery[6C|
[1K |[8C( ) Dynamic IP configuration (DHCPv6) |
[1K |[8C( ) Manual configuration[14C|
[1K |[46C|
[1K |[8C+----+[15C+------+[9C|
[1K |[8C| OK |[15C| Back |[9C|
[1K |[8C+----+[15C+------+[9C|
[1K |[46C|
[1K |[46C|
[1K +----------------------------------------------+


Expected results:
Successfull installation

Additional info:
1) Tried passing noipv6 to kernel - just unselected "Enable IPv6 support" checkbox. Result is the same.

2) Adding "network --bootproto=dhcp --device=eth1" (previous message to prompt was "Sending request for IP information for eth0" so I tried eth1 because the server has two nics) produced the same result
Comment 1 Chris Lumens 2008-12-03 09:54:40 EST
F8 and F9 saw a ton of network-related work, which continued into F10.  Would it be possible for you to test F10 and see if you are still getting these same problems?
Comment 2 Vadim Grinco 2008-12-03 10:06:04 EST
//#1
Chris,

F10 works fine.

But it should better be fixed in F{8,9} as well. I can not add the 1950s to RHTS at far it is not fixed...
Comment 3 Chris Lumens 2008-12-03 10:29:32 EST
We don't really release anaconda updates for prior releases, as that would require making entirely new boot media, CDs, and DVDs.  And that's something the mirrors really don't want to deal with.
Comment 4 Vadim Grinco 2008-12-03 12:10:56 EST
Okay. Just marking the system as unusable with F{8,9}
Thanks.

Note You need to log in before you can comment on or make changes to this bug.