Bug 474369 - low-latency doesn't install on RHEL4 due to dependency on python 2.4 (RHEL4 has 2.3).
low-latency doesn't install on RHEL4 due to dependency on python 2.4 (RHEL4 h...
Status: CLOSED ERRATA
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: grid (Show other bugs)
1.1
All Linux
urgent Severity urgent
: 1.1
: ---
Assigned To: Robert Rati
Jeff Needle
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-03 10:12 EST by Jeff Needle
Modified: 2009-02-04 11:04 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-04 11:04:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Needle 2008-12-03 10:12:47 EST
[root@north-01]# yum install low-latency
Setting up Install Process
Setting up repositories
MRG Candidate             100% |=========================| 1.3 kB    00:00
grid-devel                100% |=========================|  951 B    00:00
AS                        100% |=========================|  951 B    00:00
MRG                       100% |=========================| 1.3 kB    00:00
rhts                      100% |=========================|  951 B    00:00
Reading repository metadata in from local files
primary.xml.gz            100% |=========================|  26 kB    00:00
MRG Candid: ################################################## 116/116
Added 16 new packages, deleted 16 old in 0.19 seconds
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for low-latency to pack into transaction set.
low-latency-1.0-1.el4.noa 100% |=========================| 2.6 kB    00:00
---> Package low-latency.noarch 0:1.0-1.el4 set to be updated
--> Running transaction check
--> Processing Dependency: python-qpid for package: low-latency
--> Processing Dependency: condor-job-hooks-common for package: low-latency
--> Processing Dependency: condor-job-hooks for package: low-latency
--> Processing Dependency: python >= 2.4 for package: low-latency
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for python-qpid to pack into transaction set.
python-qpid-0.3.719419-1. 100% |=========================|  16 kB    00:00
---> Package python-qpid.noarch 0:0.3.719419-1.el4 set to be updated
---> Downloading header for condor-job-hooks-common to pack into transaction set.
condor-job-hooks-common-1 100% |=========================| 2.1 kB    00:00
---> Package condor-job-hooks-common.noarch 0:1.0-2.el4 set to be updated
---> Downloading header for condor-job-hooks to pack into transaction set.
condor-job-hooks-1.0-2.el 100% |=========================| 2.9 kB    00:00
---> Package condor-job-hooks.noarch 0:1.0-2.el4 set to be updated
--> Running transaction check
--> Processing Dependency: python >= 2.4 for package: condor-job-hooks
--> Processing Dependency: amqp >= 1.0.712864 for package: python-qpid
--> Processing Dependency: python >= 2.4 for package: low-latency
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for amqp to pack into transaction set.
amqp-1.0.719419-1.el4.noa 100% |=========================| 3.9 kB    00:00
---> Package amqp.noarch 0:1.0.719419-1.el4 set to be updated
--> Running transaction check
--> Processing Dependency: python >= 2.4 for package: condor-job-hooks
--> Processing Dependency: python >= 2.4 for package: low-latency
--> Finished Dependency Resolution
Error: Missing Dependency: python >= 2.4 is needed by package low-latency
Error: Missing Dependency: python >= 2.4 is needed by package condor-job-hooks
You have new mail in /var/spool/mail/root
[root@north-01]# rpm -q python
python-2.3.4-14.7.el4
Comment 1 Robert Rati 2008-12-04 16:27:45 EST
Errant dep requirement in the spec file.  Changed to python >= 2.3.  Fixed in the following versions:

condor-job-hooks-1.0-3
condor-low-latency-1.0-4
Comment 4 errata-xmlrpc 2009-02-04 11:04:22 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0036.html

Note You need to log in before you can comment on or make changes to this bug.