Bug 47438 - printconf doesn't see entries added to printcap.local
printconf doesn't see entries added to printcap.local
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: printconf (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Crutcher Dunnavant
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-05 10:59 EDT by Lisa Rojas
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-05 10:59:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lisa Rojas 2001-07-05 10:59:42 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.7 [en]C-CCK-MCD {LabCorp}  (Win95; U)

Description of problem:
I manually added some printers to princap.local.  The printers and spoolers work just fine; output is normal.
If I run printconf the newly added printer isn't shown.

How reproducible:
Always

Steps to Reproduce:
1.add printer to printcap.local
2.restart lpd 
3.run printconf notice printer isn't there

	

Actual Results:  Printer isn't seen in printconf.

Expected Results:  Expect to be able to edit manually added printers with printconf.  This could be a problem for newly minted admins
who have to support hand massaged changes and are afraid of printcap. 

Additional info:
Comment 1 Crutcher Dunnavant 2001-07-30 15:49:55 EDT
The printcap.local file exists so that the user, who is more
knowledgeable/flexible than my tool, can make specific changes to complex for my
tool to understand.

So how does the tool edit things it cannot understand? I cannot do this.
Comment 2 Lisa Rojas 2001-08-16 09:44:45 EDT
I just wanted to add that I'm very disappointed in RedHat's decision in this case.  What's the point of a 
tool which doesn't at least acknowledge the existance of all that its intended to support?  So what happens when
I pass my system to a newbie admin who has never touched anything like a printcap?  Shouldn't your tool
 at least tell them that printer X exists, but was manually added and cannot be edited? What happens if the
new admin tries to add a printer called X through printconf.  Will it at least error then?  Or are you expecting the
people who WOULD benefit most from this tool (newbies) to have the experience necessary to realize where
the conflict is? 

I can see the point of not editing the printers through printconf, but for a "printer configuration tool" to refuse 
to acknowledge the existance of printers says very distressing things.  I request that this decision be re-evaluated.

Note You need to log in before you can comment on or make changes to this bug.