Bug 474386 - Regression in arping (iputils-21.el4)
Regression in arping (iputils-21.el4)
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: iputils (Show other bugs)
4.7
All Linux
low Severity medium
: rc
: ---
Assigned To: Jiri Skala
BaseOS QE
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-03 11:17 EST by Chris Heath
Modified: 2014-11-09 17:31 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-18 16:15:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Heath 2008-12-03 11:17:14 EST
Description of problem:
  arping timeout parameter -w no longer works as documented in man page.

Version-Release number of selected component (if applicable):
  iputils-21.el4  (RHEL 4.7)
  (worked fine in iputils-19.EL4.5)  (RHEL 4.6)

How reproducible:
  Always

Steps to Reproduce:
  arping -f -w 5 -I eth0 1.2.3.4
 
Actual results:
  Runs forever
  strace shows it is sending one ARP every second

Expected results:
  Runs for 5 seconds then exits

Additional info:
  I didn't see info about this change in the changelog.  Did the new timeout patch sneak in accidentally?  My suggestion would be to remove the new patch (iputils-20020927-arping_timeout.patch) and reinstate the old one (iputils-20020927-12-arping.patch)
Comment 1 Jiri Skala 2008-12-08 05:31:32 EST
Hi,
may I have an output of described arping?
Comment 2 Chris Heath 2008-12-08 10:52:57 EST
[root@test ~]# rpm -q iputils; arping -f -w 5 -I eth0 1.2.3.4
iputils-20020927-21.el4
ARPING 1.2.3.4 from 192.168.111.134 eth0
   (After a Ctrl-C)
Sent 22 probes (22 broadcast(s))
Received 0 response(s)
[root@test ~]# rpm -U --force iputils-20020927-19.EL4.5.i386.rpm
[root@test ~]# rpm -q iputils; arping -f -w 5 -I eth0 1.2.3.4
iputils-20020927-19.EL4.5
ARPING 1.2.3.4 from 192.168.111.134 eth0
Sent 6 probes (6 broadcast(s))
Received 0 response(s)
Comment 3 RHEL Product and Program Management 2008-12-10 10:52:02 EST
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.
Comment 9 errata-xmlrpc 2009-05-18 16:15:48 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0977.html

Note You need to log in before you can comment on or make changes to this bug.