Bug 474393 - [RHEL4.6] ethtool/mii-tool returns wrong values about link status
[RHEL4.6] ethtool/mii-tool returns wrong values about link status
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.7
All Linux
low Severity low
: rc
: ---
Assigned To: Neil Horman
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-03 11:53 EST by Flavio Leitner
Modified: 2010-10-23 02:20 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-01 15:56:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Flavio Leitner 2008-12-03 11:53:43 EST
Description of problem:

Both ethtool and mii-tool returns wrong values about link status when the
interface is down (ifconfig ethX down).

The problem is that there is no reliable tool which would report physical 
state on network cards regardless if they are up or down.

Steps to Reproduce:
1. Put the interface down  (ifconfig ethX down)
2. Try to check if the link is detected or not.
Comment 2 Neil Horman 2010-04-01 15:56:46 EDT
this is working as designed.  when an interface is downed we shut off the hardware.  It doesn't make sense to keep hardware running just so it can support the reading of state information that is only relevant if the device were powered on.  If you really want to determine link state when the device is on:
ifconfig ethX up; ethtool ethX; ifconfig ethX down

Note You need to log in before you can comment on or make changes to this bug.