Bug 474397 - pulseaudio using obsolete group id
pulseaudio using obsolete group id
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-03 12:17 EST by Daniel Qarras
Modified: 2008-12-09 12:27 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-09 12:27:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Qarras 2008-12-03 12:17:07 EST
Description of problem:
During firstboot I created a user "testuser" that ended up in to group "testuser" with gid 500. This is of course silly and as root I changed the user to group "users" with gid 100. Otherwise everything works perfectly, but for some reason pulseaudio still creates its temp dirs under /tmp for the users with gid 500.

I tried grepping under /etc/pulse etc but didn't find any obvious configuration where does this 500 come from?

FWIW, it also raises complaints from sectool as there's no more group with gid 500.

Version-Release number of selected component (if applicable):
pulseaudio-0.9.13-6.fc10.i386
Comment 1 Lennart Poettering 2008-12-08 14:45:52 EST
(In reply to comment #0)
> Description of problem:
> During firstboot I created a user "testuser" that ended up in to group
> "testuser" with gid 500. This is of course silly ...

Is it?

> ... and as root I changed the user
> to group "users" with gid 100. Otherwise everything works perfectly, but for
> some reason pulseaudio still creates its temp dirs under /tmp for the users
> with gid 500.

You need to logout/login again. Check with the "id" command with which uid/gid parameters your shell/session is running. Note that you need to edit both he groups file and the shadow files.

> where does this 500 come from?

From the getgid(2) system call. The same data the "id" outputs.

This is unrelated to PulseAudio. It most likely a configuration error on your side or just a misunderstanding how unix user ids work.

Closing.
Comment 2 Daniel Qarras 2008-12-08 15:19:41 EST
Now come on, now need for that attitude, I have logged out and rebooted the computer dozens of times, I noticed the behavior right after installation and waited for weeks if an update would appear to fix this and as that did not happened, I opened the bug.

"id" does not output 500 but 100.
Comment 3 Daniel Qarras 2008-12-08 15:27:43 EST
root@localhost:~# uptime
 22:24:23 up 1 min,  1 user,  load average: 2.07, 0.88, 0.32
root@localhost:~# rpm -q pulseaudio
pulseaudio-0.9.13-6.fc10.i386
root@localhost:~# id testuser
uid=500(testuser) gid=100(users) groups=100(users)
root@localhost:~# ls -ld /tmp/pulse*
drwx------ 2 testuser 500 4.0K 2008-12-08 22:23 /tmp/pulse-PKdhtXMmr18n/
root@localhost:~#
Comment 4 Lennart Poettering 2008-12-08 18:01:22 EST
Are you sure that PA is run from exactly the the same environment as you ran "id" as?

Please do this:

pulseaudio -k ; rm -rf /tmp/pulse* ; pulseaudio -vvv

Paste the part about the used state/runtime directories here which will be shown then.

And also try to do a "readlink ~/.pulse/*:runtime" which should show you the actual runtime directory used. Also use do a "stat /proc/`pidof pulseaudio`" to figure out the uid/gid the PA process is running as.
Comment 5 Daniel Qarras 2008-12-09 12:27:18 EST
Ok, mea culpa, I did "find / -gid 500" and noticed that ~/.gvfs, ~/.esd_auth, /tmp/.esd-500 were owned by group 500. I removed all those dirs, all tmp files etc, rebooted and now everything seems to be ok.

Closing as luser error.

Note You need to log in before you can comment on or make changes to this bug.