Bug 474427 - Disk detected but cannot be used with F10 on Sony Vaio BZ11XN
Disk detected but cannot be used with F10 on Sony Vaio BZ11XN
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-03 14:31 EST by Gilbert Fernandes
Modified: 2009-05-10 13:46 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-10 13:46:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The error anaconda gives me (15.97 KB, text/plain)
2009-05-09 08:46 EDT, Julian Aloofi
no flags Details
Julian's /var/log/messages (714.31 KB, text/plain)
2009-05-09 08:48 EDT, Julian Aloofi
no flags Details

  None (edit)
Description Gilbert Fernandes 2008-12-03 14:31:18 EST
Description of problem:
When F10 is booted on the Sony Vaio BZ11XN everything seems to work except the hard-disk. It is seen but there seems to be a lot of errors in the /var/log/messages. Searched the BIOS for any option but there is nothing there about the hard-disk mode or anything.

Version-Release number of selected component (if applicable):
Fedora 10. I tried both i386 (the non-amd64) and Amd64 versions.

How reproducible:
Sony Vaio BZ11XN + F10

dmesg :
ata1.00: error: { ABRT }
ata1.00: configured for UDMA/100
sd 0:0:0:0: [sda] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE,SUGGEST_OK
sd 0:0:0:0: [sda] Sense Key : Aborted Command [current] [descriptor]
Descriptor sense data with sense descriptors (in hex):
72 0b 00 00 00 00 00 0c 00 0a 80 00 00 00 00 00
17 49 ef 28
sd 0:0:0:0: [sda] Add. Sense: No additional sense information
end_request: I/O error, dev sda, sector 390721320
ata1: EH complete
sd 0:0:0:0: [sda] 390721968 512-byte hardware sectors (200050 MB)
sd 0:0:0:0: [sda] Write Protect is off
sd 0:0:0:0: [sda] Mode Sense: 00 3a 00 00
ata1.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x0
ata1.00: BMDMA stat 0x5
ata1.00: cmd 25/00:10:30:ef:49/00:00:17:00:00/e0 tag 0 dma 8192 in
res 51/04:10:30:ef:49/04:00:17:00:00/e0 Emask 0x1 (device error)
ata1.00: status: { DRDY ERR }
ata1.00: error: { ABRT }
ata1.00: configured for UDMA/100
ata1: EH complete
ata1.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x0
ata1.00: BMDMA stat 0x5
ata1.00: cmd 25/00:10:30:ef:49/00:00:17:00:00/e0 tag 0 dma 8192 in
res 51/04:10:30:ef:49/04:00:17:00:00/e0 Emask 0x1 (device error)
ata1.00: status: { DRDY ERR }
ata1.00: error: { ABRT }
ata1.00: configured for UDMA/100
ata1: EH complete
ata1.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x0
ata1.00: BMDMA stat 0x5
ata1.00: cmd 25/00:10:30:ef:49/00:00:17:00:00/e0 tag 0 dma 8192 in
res 51/04:10:30:ef:49/04:00:17:00:00/e0 Emask 0x1 (device error)
ata1.00: status: { DRDY ERR }
ata1.00: error: { ABRT }
ata1.00: configured for UDMA/100
ata1: EH complete
ata1.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x0
ata1.00: BMDMA stat 0x5
ata1.00: cmd 25/00:10:30:ef:49/00:00:17:00:00/e0 tag 0 dma 8192 in
res 51/04:10:30:ef:49/04:00:17:00:00/e0 Emask 0x1 (device error)
ata1.00: status: { DRDY ERR }
ata1.00: error: { ABRT }
ata1.00: configured for UDMA/100
ata1: EH complete
ata1.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x0
ata1.00: BMDMA stat 0x5
ata1.00: cmd 25/00:10:30:ef:49/00:00:17:00:00/e0 tag 0 dma 8192 in
res 51/04:10:30:ef:49/04:00:17:00:00/e0 Emask 0x1 (device error)
ata1.00: status: { DRDY ERR }
ata1.00: error: { ABRT }
ata1.00: configured for UDMA/100
ata1: EH complete
ata1.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x0
ata1.00: BMDMA stat 0x5
ata1.00: cmd 25/00:10:30:ef:49/00:00:17:00:00/e0 tag 0 dma 8192 in
res 51/04:10:30:ef:49/04:00:17:00:00/e0 Emask 0x1 (device error)
ata1.00: status: { DRDY ERR }
ata1.00: error: { ABRT }
ata1.00: configured for UDMA/100
sd 0:0:0:0: [sda] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE,SUGGEST_OK
sd 0:0:0:0: [sda] Sense Key : Aborted Command [current] [descriptor]
Descriptor sense data with sense descriptors (in hex):
72 0b 00 00 00 00 00 0c 00 0a 80 00 00 00 00 00
17 49 ef 30
sd 0:0:0:0: [sda] Add. Sense: No additional sense information
end_request: I/O error, dev sda, sector 390721328
ata1: EH complete
sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
ata1.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x0
ata1.00: BMDMA stat 0x5
ata1.00: cmd 25/00:08:30:ef:49/00:00:17:00:00/e0 tag 0 dma 4096 in
res 51/04:08:30:ef:49/04:00:17:00:00/e0 Emask 0x1 (device error)
ata1.00: status: { DRDY ERR }
ata1.00: error: { ABRT }
ata1.00: configured for UDMA/100
ata1: EH complete
ata1.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x0
ata1.00: BMDMA stat 0x5
ata1.00: cmd 25/00:08:30:ef:49/00:00:17:00:00/e0 tag 0 dma 4096 in
res 51/04:08:30:ef:49/04:00:17:00:00/e0 Emask 0x1 (device error)
ata1.00: status: { DRDY ERR }
ata1.00: error: { ABRT }
ata1.00: configured for UDMA/100
ata1: EH complete
ata1.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x0
ata1.00: BMDMA stat 0x5
ata1.00: cmd 25/00:08:30:ef:49/00:00:17:00:00/e0 tag 0 dma 4096 in
res 51/04:08:30:ef:49/04:00:17:00:00/e0 Emask 0x1 (device error)
ata1.00: status: { DRDY ERR }
ata1.00: error: { ABRT }
ata1.00: configured for UDMA/100
ata1: EH complete
ata1.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x0
ata1.00: BMDMA stat 0x5
ata1.00: cmd 25/00:08:30:ef:49/00:00:17:00:00/e0 tag 0 dma 4096 in
res 51/04:08:30:ef:49/04:00:17:00:00/e0 Emask 0x1 (device error)
ata1.00: status: { DRDY ERR }
ata1.00: error: { ABRT }
ata1.00: configured for UDMA/100
ata1: EH complete
ata1.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x0
ata1.00: BMDMA stat 0x5
ata1.00: cmd 25/00:08:30:ef:49/00:00:17:00:00/e0 tag 0 dma 4096 in
res 51/04:08:30:ef:49/04:00:17:00:00/e0 Emask 0x1 (device error)
ata1.00: status: { DRDY ERR }
ata1.00: error: { ABRT }
ata1.00: configured for UDMA/100
ata1: EH complete
ata1.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x0
ata1.00: BMDMA stat 0x5
ata1.00: cmd 25/00:08:30:ef:49/00:00:17:00:00/e0 tag 0 dma 4096 in
res 51/04:08:30:ef:49/04:00:17:00:00/e0 Emask 0x1 (device error)
ata1.00: status: { DRDY ERR }
ata1.00: error: { ABRT }
ata1.00: configured for UDMA/100
sd 0:0:0:0: [sda] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE,SUGGEST_OK
sd 0:0:0:0: [sda] Sense Key : Aborted Command [current] [descriptor]
Descriptor sense data with sense descriptors (in hex):
72 0b 00 00 00 00 00 0c 00 0a 80 00 00 00 00 00
17 49 ef 30
sd 0:0:0:0: [sda] Add. Sense: No additional sense information
end_request: I/O error, dev sda, sector 390721328
ata1: EH complete
sd 0:0:0:0: [sda] 390721968 512-byte hardware sectors (200050 MB)
ata1.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x0
ata1.00: BMDMA stat 0x5
ata1.00: cmd 25/00:08:d0:ee:49/00:00:17:00:00/e0 tag 0 dma 4096 in
res 51/04:08:d0:ee:49/04:00:17:00:00/e0 Emask 0x1 (device error)
ata1.00: status: { DRDY ERR }
ata1.00: error: { ABRT }
ata1.00: configured for UDMA/100
ata1: EH complete

[...] 

lspci :

00:00.0 Host bridge: Intel Corporation Cantiga Memory Controller Hub (rev 07)
00:02.0 VGA compatible controller: Intel Corporation Cantiga Integrated Graphics Controller (rev 07)
00:02.1 Display controller: Intel Corporation Cantiga Integrated Graphics Controller (rev 07)
00:19.0 Ethernet controller: Intel Corporation 82567LM Gigabit Network Connection (rev 03)
00:1a.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 03)
00:1a.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 03)
00:1a.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 03)
00:1c.2 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 3 (rev 03)
00:1c.3 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 4 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 03)
00:1d.3 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 93)
00:1f.0 ISA bridge: Intel Corporation ICH9M-E LPC Interface Controller (rev 03)
00:1f.2 IDE interface: Intel Corporation ICH9M/M-E 2 port SATA IDE Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 03)
00:1f.5 IDE interface: Intel Corporation ICH9M/M-E 2 port SATA IDE Controller (rev 03)
01:07.0 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev ba)
01:07.1 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 IEEE 1394 Controller (rev 04)
01:07.2 SD Host controller: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 21)
01:07.4 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter (rev 11)
04:00.0 Network controller: Intel Corporation Device 4232

The kernel sees the hard-disk but can't use it in any way :

sd 0:0:0:0: [sda] 390721968 512-byte hardware sectors (200050 MB)
sd 0:0:0:0: [sda] Write Protect is off
sd 0:0:0:0: [sda] 390721968 512-byte hardware sectors (200050 MB)
sd 0:0:0:0: [sda] Write Protect is off
sd 0:0:0:0: [sda] Mode Sense: 00 3a 00 00
sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
sd 0:0:0:0: [sda] 390721968 512-byte hardware sectors (200050 MB)
sd 0:0:0:0: [sda] Write Protect is off
sd 0:0:0:0: [sda] Mode Sense: 00 3a 00 00
sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA

It keeps doing errors so can't install to hard-disk.
Disk is fine (laptop is new, disk ok under vista)
Comment 1 Julian Aloofi 2009-05-09 08:12:36 EDT
Same error hereon a Toshiba A210-1BX (PSAELE). I think it's somehow related to Windows' Suspend-to-RAM.
I had Fedora 10 and Windows Vista installed in Dual-Boot. When I wanted to shut down Windows about a week ago, I accidently pressed Suspend-to-RAM and not Shutdown.
I didn't want to resume from standby just to shut it down, so I made a reset. When I wanted to start Fedora then, I got similar errors. When I try to install Fedora (10 and 11-Preview) it boots the live CD but I can't access the disk and when I try to install it offers me to reconfigure my disk and delete all data.
I'm seriously thinking about doing that, Windows CHDSK didn't report any mistakes, Palimpsest sees the disk but tells me that it has no paritions. (In fact it has two, the Windows RE partition with 1,5 GB and the Windows NTFS partition itself). openSUSE fails to find a hard disk.
A fsck is impossible because even the Gparted live CD doesn't see my hard disk(fdisk -l only lists my DVD drive).
Even after I used my Toshiba Recovery CD and reisntalled the whole Windows OS it doesn't work.
Before this error occured I've been using Fedora for about a year(since Fedora 9 on this machine). The Fedora 9 CD didn't work either.
Comment 2 Julian Aloofi 2009-05-09 08:46:37 EDT
Created attachment 343210 [details]
The error anaconda gives me

OK, I tried to let the Anaconda live installer from Fedora 11 reinitialize my disk. It provided this error. I will now try it with Palimpsest, I'm currently on a live system.
Comment 3 Julian Aloofi 2009-05-09 08:48:39 EDT
Created attachment 343211 [details]
Julian's /var/log/messages

By the way, here's my /var/log/messages, it's pretty similar to Gilbert's.
Comment 4 Julian Aloofi 2009-05-09 08:59:38 EDT
OK, Palimpsest fails to re-partition the disk and also fails to create a new partition layout including a new MBR.
Here is what it tells me:

org.freedesktop.DeviceKit.Disks.Error.Failed: Error creating partition table: helper exited with exit code 1: In part_create_partition_table: device_file=/dev/sda, scheme=0
got it
got disk
Error: Input/output error during read on /dev/sda
Error: Input/output error during write on /dev/sda
ped_disk_commit_to_dev() failed
BLKRRPART ioctl failed for /dev/sda: Input/output error

Seems like I'm unable to install any Linux distro on this PC now, Fedora, openSUSE and Debian failed. I can't just delete everything and create a new layout, because GParted and Parted don't see my disk and Palimpsest fails to do anything. I can't delete it from Windows because it can't delete it's active partiton. And when I restore my PC to default settings with my Recovery CD it doesn't change anything (it repartitions the disk and reinstalls Windows).
That is strange, and it doesn't look like a hardware error to me, because Windows works flawlessly. system-config-lvm doesn't see me hard drive either. But the kernel recognizes the disk.
Comment 5 Gilbert Fernandes 2009-05-09 10:49:38 EDT
Hello dear Julian.

I have done no progress on my side. When I bought the laptop I thought it would work on Linux because someone has made a web page where he explains he has been able to install Ubuntu on his laptop after Fedora 10 failed :
freshfoo.com/articles/linux_on_vaio_bz11.html

So far, I have been unable to access the disk from the following : Fedora 10, Fedora 11 beta, Fedora 11. Ubuntu 8 and the latest version 9. I tried OpenBSD, NetBSD too on their current and latest stable versions. None seem to be able to see the disk, and when they do (Linux does) they are unable to access it.

The machine was pre-loaded with Vista Business Pro. I have tried to to a downgrade to XP then try again : no success. I have tried to boot several Linux-based CD tools in order to dd if=/dev/zero the hard-disk but none can give me access to the disk in order to wipe it.

I have not activated anything in the BIOS regarding security: there is no hard-disk password, no BIOS password, nothing. The machine boots fine under Windows Vista, and I have tried various disk-checking tools, and the SMART counters are OK: absolutely no error whatsoever.

I have tried to install Fedora (current version then each time going back on version). Same problem. I also tried Ubuntu just in case and because there's a web page on Internet that says this model works with Ubuntu : no sucess.

The last resort I can think of is this: I have a small cable with power supply that allows me to plug 2 1/4 inches disks as a IDE disk on a big PC. If the hard-disk from the Sony Vaio has an IDE connector, I should be able to plug it on my main big PC (which runs a NetBSD-current for development) and wipe the hard-disk. The best would be a low-level format from the manufacturer's tool but it does not boot my big PC in either floppy disk format of CD format and the tool refuses to work under WINE.

It seems like there is a problem talking to the hard-disk controler from the Linux kernel to the hardware device. The same problem appears when I boot NetBSD or OpenBSD or Ubuntu (thus, different open-source operating systems). Since the disk works fine under Vista, this gives us three possibilities:

- hard disk is defective
- hard disk has some kind of "Vista only "protection (Teacherous Computing)
- Linux kernel does not have the driver to talk to the controler

The hard disk does not seem defective: works on Vista, and I can do surface and file tests with no problem there. Both from Vista and XP.

Vista-only : I opened a ticket with the Sony support and they told me there is no protection whatsoever of this kind. They told me that if a password is set on the hard disk, it is written on a non-reachable part by operating systems, but when the system is booted, the BIOS gets the password, the disks "unlocks" and then it's transparent: no operating sytem sees that hard-disk has a password, it only happens on boot.

So the logical conclusion leaves us with two last possibilites :

- the controler reports itself as a known controler but with an hidden revision that makes it fail
- the controler is unsupported right now

Which I cannot answer. On NetBSD and OpenBSD, the controler reports itself as something that _should_ be supported but fails.

On Linux, the controler kind is identified, and it fails when commands are sent to the drive. So something must be wrong in the way the kernel talks to the controler, or it requires a set of initializations through some commands we do not have (which would be weird: the hard disk works fine from Vista, and there is absolutely no driver required there)

Now, I have one last try to do : up to know, I have used the DVD for reinstall created from the Sony Recovery Tool which _might_ be a Windows Vista/XP with a special hard-disk driver (who knows ?)

So tonight I will try to boot that machine with a standard, off the shelf Windows XP SP2 CD and see if I can install a standard XP on the laptop.

If it fails, it means there is very probably something that has been added to Vista/XP by Sony.
Comment 6 Julian Aloofi 2009-05-09 12:14:46 EDT
I don't think the controler is unsupported, neither do I think that the control reports itself as a known one. I've been running Fedora for about a year on this machine and never encountered any problems with any distro, and I also tested openSUSE, Debian and FreeBSD back when my harddisk worked. The only thing I did was hard-reseting my PC while it was about to suspend to RAM. Since then it didn't work anymore. This doesn't leave any of the possibilities you mentioned above. It's really mysterious, just to be sure I also made a RAM check with MemTest86+. No errors, nothing. My last idea is to try it with openSolaris, and then our last option is Debian GNU/Hurd. I hope one of this will work, but unfortunately I don't have the time to check it now. I will make a test with openSolaris 2008.11 and Solaris Express Build 110 which I have lieing around somewhere here. I will tell you tomorrow whether it worked.
Comment 7 Julian Aloofi 2009-05-10 07:56:53 EDT
I installed openSolaris successfully on my machine. It booted and installed GRUB and so on and worked (except from the network drivers, but that's not important). Unfortunately nothing changed from Fedora's point of view. Both Fedora 10 and 11-Preview still give me the same error messages even with openSolaris installed. I then wiped it off my hard drive and installed Windows again with my recovery CD. Nothing changed (again).
I can't think about any reason why this should fail.
Let's sum up:
-repartitioning the hard disk doesn't work, neither with GNU/Linux nor with BSD
-repartitioning the whole disk with Solaris' ZFS doesn't help
-repartitioning the whole disk with NTFS doesn't work
-GNU/Linux and BSD can't access the disk in any way
-rewriting the MBR doesn't help

I can't understand that. Windows and Solaris run without any problems, but Linux and BSD don't. The problem looks like an hardware error, but it isn't.
I will check all possible options in my BIOS now. If I get it working I'll tell you. If not... well see you on bugzilla.microsoft.com then ;)
Comment 8 Julian Aloofi 2009-05-10 08:15:29 EDT
I got it working (yeeeeha!).
The error was in my BIOS, although I never changed any value there except of enabling processor assisted virtualization.
The screen in BIOS said something like "Built in HDD1    Locked".
I was able to enter a "User-Password" there and just set it to nothing (just pressed Enter two times).
Then it said "Built in HDD1     Clear".
I'm using Phoenix BIOS and I'll add a screenshot later, I'm right now installing Fedora to my hard drive. Now the only question is: Why did Linux and BSD fail, but Solaris didn't? But that's not really important to me.
Comment 9 Julian Aloofi 2009-05-10 08:59:15 EDT
Hmm, my camera does not work anymore (What's happening here !?) so I can't show you a screenshot.
You find the point (at least in a Phoenix BIOS) "Built-in HDD1 Password" under Security. There you can set it to nothing (just press Enter when it asks for a password). Then your HDD will be "Clear".
I hope it works for you, good luck
Comment 10 Gilbert Fernandes 2009-05-10 13:46:07 EDT
No, no success on my side.

I have no password set in my bios. No password set for Bios, nor hard-disk or anything.

I have been able to boot the machine using a CD-Rom of Windows date 2000 : the windows XP standard CD from 2000. XP without SP1 or SP2.

Detects the hard-disk, is able to create partitions and install with no problem at all. If a 9 years old Windows XP CD can boot and install I doubt it is an hardware or special driver problem.

I'm giving up. Reinstalled the machine under Vista and gonna offer it to my sister. And get myself one of those very small PCs so I can have Linux and a BSD for development and fun and have something light in my bag.

It's been a few monthes, two Fedora and two Ubuntu releases and none are able to install probably because of some weird hard-disk controller but I have no idea. Disk is detected but Linux nor BSD can write anything to it, either partitions or data.

You can close if required this bug, I will not have this machine with me tomorrow and I will buy with more care the hardware ;)

Note You need to log in before you can comment on or make changes to this bug.