Bug 474451 - [Intel 5.4 FEAT] Request to Support Intel Modular Server in scsi_dh
[Intel 5.4 FEAT] Request to Support Intel Modular Server in scsi_dh
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: device-mapper-multipath (Show other bugs)
5.4
other Linux
high Severity high
: beta
: 5.4
Assigned To: Ben Marzinski
Cluster QE
:
Depends On:
Blocks: 452016 483784 502000
  Show dependency treegraph
 
Reported: 2008-12-03 16:37 EST by joseph.r.gruher
Modified: 2014-06-23 10:50 EDT (History)
27 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 488325 (view as bug list)
Environment:
Last Closed: 2009-09-02 07:46:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch-multipath-tools (25.96 KB, patch)
2008-12-03 16:38 EST, joseph.r.gruher
no flags Details | Diff
scsi_dh-patch (1.21 KB, patch)
2008-12-03 16:38 EST, joseph.r.gruher
no flags Details | Diff

  None (edit)
Description joseph.r.gruher 2008-12-03 16:37:23 EST
We would like to add a patch to RHEL5.3 to support the dual storage controllers in the Intel Modular Server being used with the new scsi_dh framework.  This will allow users to setup multipath on the system without loading patches and having to rebuild scsi_dh.

The patch has two parts:

1) Change in the scsi-dh framework to accept Intel devices.  This is a single line code change to add Intel the Multiflex device name to the supported devices list.  This code is in attachment "scsi_dh-patch".

2) User-space tool to give priority of a path depending on the preferred bit of the controller.  This tool is based on mpath_prio_alua.  For correct failover/failback operations we need the correct priority of the path, this is done by this second tool.  This code is in attachment "patch-multipath-tools".
Comment 1 joseph.r.gruher 2008-12-03 16:38:10 EST
Created attachment 325601 [details]
patch-multipath-tools
Comment 2 joseph.r.gruher 2008-12-03 16:38:37 EST
Created attachment 325602 [details]
scsi_dh-patch
Comment 3 John Villalovos 2009-01-19 14:45:29 EST
Joseph,

It is to late for RHEL 5.3.  But we need code submitted by 29-Jan-2009 for acceptance into RHEL 5.4.

Are the attached patches the latest versions?
Comment 4 joseph.r.gruher 2009-01-20 15:01:02 EST
John,
Yes, attached patches are still the latest and greatest versions, no known issues at this time.

Thanks,
Joe
Comment 5 Mike Christie 2009-01-30 14:42:40 EST
Ben, I am going to take the kernel patch in comment #2 and push upstream and then put it in RHEL. I have a bugzilla for the kernel stuff already.

You can use this bz for all the multipath tools fun :)
Comment 6 Mike Christie 2009-01-30 14:45:13 EST
(In reply to comment #1)
> Created an attachment (id=325601) [details]
> patch-multipath-tools

Promise/Intel developers,

What is up with this patch? It has IBM copyrights in the header, but then prints out a intel copyright in the print version.

Can the default path_priority/pp_alua callout be used instead of adding your own or can the default one be used?
Comment 7 Mike Christie 2009-01-30 14:45:59 EST
(In reply to comment #6)
> Can the default path_priority/pp_alua callout be used instead of adding your
> own or can the default one be used?

I meant to write modified to support whatever extra you need?
Comment 8 joseph.r.gruher 2009-01-31 17:35:37 EST
With regard to the question about copyright Promise tells us this is a minor change from the original pp_alua code so we must sustain copyright information in compliance with GPL requirements.

With regard to the question about modifying pp_alua this is the response from Promise:
We already tested with calling pp_alua, but got a problem which did not get exact priority from device.  So it failed to get exact path.
Comment 9 Mike Christie 2009-02-01 20:25:46 EST
(In reply to comment #8)
> 
> With regard to the question about modifying pp_alua this is the response from
> Promise:
> We already tested with calling pp_alua, but got a problem which did not get
> exact priority from device.  So it failed to get exact path.


Ok. I am adding some more info since Ben does multipath tools, but in the mail Ilgu sent there was some more detail which would help him know what is going on.

Ilgu from Promise also said:

       We will check and try to find minimize patch size for pp_intel.



Intel/Promise guys if you send mail about multipath tools could you make sure to  cc Benjamin Marzinski <bmarzins@redhat.com>. I do not do any work with multipath tools. I have no idea what is going on :) He will be able to help you guys with those type of issues.
Comment 10 joseph.r.gruher 2009-02-17 17:08:17 EST
Note: This BZ corresponds to IT 267306.
Comment 12 Keve Gabbert 2009-05-04 19:24:07 EDT
what's the status on this BZ?
Is it ever going to get moved from NEW to ASSIGNED?
Comment 13 Ronald Pacheco 2009-05-05 08:50:09 EDT
This is on the list of BZs approved for RHEL 5.4.
Comment 14 Ben Marzinski 2009-05-15 19:13:25 EDT
Patch applied.
Comment 16 Chris Ward 2009-07-03 14:14:58 EDT
~~ Attention - RHEL 5.4 Beta Released! ~~

RHEL 5.4 Beta has been released! There should be a fix present in the Beta release that addresses this particular request. Please test and report back results here, at your earliest convenience. RHEL 5.4 General Availability release is just around the corner!

If you encounter any issues while testing Beta, please describe the issues you have encountered and set the bug into NEED_INFO. If you encounter new issues, please clone this bug to open a new issue and request it be reviewed for inclusion in RHEL 5.4 or a later update, if it is not of urgent severity.

Please do not flip the bug status to VERIFIED. Only post your verification results, and if available, update Verified field with the appropriate value.

Questions can be posted to this bug or your customer or partner representative.
Comment 17 Chris Ward 2009-07-10 15:07:03 EDT
~~ Attention Partners - RHEL 5.4 Snapshot 1 Released! ~~

RHEL 5.4 Snapshot 1 has been released on partners.redhat.com. If you have already reported your test results, you can safely ignore this request. Otherwise, please notice that there should be a fix available now that addresses this particular request. Please test and report back your results here, at your earliest convenience. The RHEL 5.4 exception freeze is quickly approaching.

If you encounter any issues while testing Beta, please describe the issues you have encountered and set the bug into NEED_INFO. If you encounter new issues, please clone this bug to open a new issue and request it be reviewed for inclusion in RHEL 5.4 or a later update, if it is not of urgent severity.

Do not flip the bug status to VERIFIED. Instead, please set your Partner ID in the Verified field above if you have successfully verified the resolution of this issue. 

Further questions can be directed to your Red Hat Partner Manager or other appropriate customer representative.
Comment 18 Chris Ward 2009-07-21 10:36:37 EDT
Keve - Intel, what's the testing status of this feature? It should be included in the latest snapshots.
Comment 19 Chris Ward 2009-07-28 09:11:14 EDT
Intel, Ping?
Comment 20 joseph.r.gruher 2009-07-28 17:03:32 EDT
Testing is in progress.
Comment 22 Chris Ward 2009-08-04 04:26:24 EDT
Thanks Intel. Please update us with test results or test status as soon as possible.
Comment 23 ilgu hong 2009-08-04 17:18:29 EDT
Hi,all

We tested RHEL 5.4 alpa, beta, and snapshot 1 and we found that this version support our device in multipath tools and scsi_dh_alua.


we did FO/FB test and we did not find "scsi id issue" which we found in RHEL 5.3 version.

So RHEL 5.4 work fine with clearbay.

Thanks.
Comment 24 Chris Ward 2009-08-11 03:01:59 EDT
Intel, any update on testing?
Comment 25 joseph.r.gruher 2009-08-11 12:33:58 EDT
Chris, comment #23 reports the results of our testing, we consider this verified and closed from our perspective.  Thanks!
Comment 26 errata-xmlrpc 2009-09-02 07:46:58 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1377.html
Comment 29 Keve Gabbert 2014-06-23 10:50:59 EDT
closed

Note You need to log in before you can comment on or make changes to this bug.