Bug 474518 - Evolution shows bogus IMAP folders in folder list.
Evolution shows bogus IMAP folders in folder list.
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-04 04:21 EST by Steven Bakker
Modified: 2008-12-04 13:25 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-04 13:25:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screen shot showing the empty folder names. (51.24 KB, image/png)
2008-12-04 04:21 EST, Steven Bakker
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 337082 None None None Never

  None (edit)
Description Steven Bakker 2008-12-04 04:21:28 EST
Created attachment 325657 [details]
Screen shot showing the empty folder names.

Description of problem:

Evolution shows bogus (IMAP) folders in the folder hierarchy with empty names.

Version-Release number of selected component (if applicable):

2.24.2

How reproducible:

Not sure. They just showed up today. I attached a screenshot.

Steps to Reproduce:
1. Start evolution.
2.
3.

Actual results:

Bogus folders in the hierarchy.

Expected results:

No bogus folders.

Additional info:

When I select one the bogus folders, evo gives no error message and shows no messages (obviously). The bogus folders do not exist in the Maildir store on the IMAP server.

If I go into the IMAP subscriptions and carefully uncheck and check the folders in the hierarchy again, the bogus folders disappear. As mentioned in another bug, I cannot deselect/select too quickly, or Evolution will crash.

I tried to edit my preferences to uncheck "only show subscribed folders", but that crashes evolution as well :-( (I'll file a separate bug for that).
Comment 1 Milan Crha 2008-12-04 05:34:35 EST
The first issue, empty folders, seems to be this [1] upstream bug. Can I close this as an upstream?

About the crash I commented in bug #474520.

[1] http://bugzilla.gnome.org/show_bug.cgi?id=337082
Comment 2 Steven Bakker 2008-12-04 07:26:45 EST
Yes, this seems to be the exact same thing as the upstream bug. AFAIAC you can close this bug. (And thanks for the comment on #474520.)

Cheers,
Steven
Comment 3 Milan Crha 2008-12-04 13:25:18 EST
Thanks for the reply, closing as upstream then.

Note You need to log in before you can comment on or make changes to this bug.