Bug 474541 - Duplicate recipient filter fails on virtual alias expansion
Duplicate recipient filter fails on virtual alias expansion
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: postfix (Show other bugs)
5.2
x86_64 Linux
high Severity medium
: rc
: ---
Assigned To: Jaroslav Škarvada
qe-baseos-daemons
:
Depends On:
Blocks: 743405 807971
  Show dependency treegraph
 
Reported: 2008-12-04 06:40 EST by Eric Janz
Modified: 2013-01-08 02:26 EST (History)
4 users (show)

See Also:
Fixed In Version: postfix-2.3.3-5.el5
Doc Type: Bug Fix
Doc Text:
Prior to this update, the "aggresive" recipient duplicate elimination was broken. This could lead to reception of multiple copies of e-mails for users that were specified in multiple virtual aliases. Now if the enable_original_recipient configuration option is set to "no" the recipient duplicate elimination will work correctly and users will not receive multiple copies of e-mails.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-08 02:26:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Janz 2008-12-04 06:40:50 EST
Description of problem:

After upgrading from:

Red Hat Enterprise Linux AS release 4 (Nahant Update 2)
postfix-2.1.5-4.2.RHEL4
2.6.9-34.0.1.ELsmp #1 SMP Wed May 17 17:05:24 EDT 2006 i686 i686 i386 GNU/Linux 

To:
Red Hat Enterprise Linux Server release 5.2 (Tikanga)
postfix-2.3.3-2.1
2.6.18-92.el5 #1 SMP Tue Apr 29 13:16:15 EDT 2008 x86_64 x86_64 x86_64 GNU/Linux

Postfix's duplicate recipient filter fails.

Due to the duplicate recipient failure, if for example:

alias1: user1 user2
alias2: user2

when we send an email to alias1 with cc to alias2, user2 receives the email twice. Before the upgrade user2 only received that email once.

Version-Release number of selected component (if applicable):

postfix-2.3.3-2.1

How reproducible:


Steps to Reproduce:
1. Create aliases for user1 and user2:
alias1: user1 user2
alias2: user2
2.
Send email to alias1 with cc to alias2
3.
Receive emails

Actual results:
User2 receives the mail twice

Expected results:
User2 receives the mail once

Additional info:

I searched about this failure and found following references that let me think that this problem was introduced in postfix 2.3 and solved in 2.3.10

http://archives.neohapsis.com/archives/postfix/2007-10/1016.html

"[...] This option is not effective in Postfix 2.3.0-2.3.9 and Postfix
2.4.0-2.4.1 (design conflict with DSN support). It is fixed in Postfix
2.3.10+ and 2.4.2+:

    20070520

        Bugfix (problem introduced Postfix 2.3): when DSN support
        was introduced it broke "agressive" recipient duplicate
        elimination with "enable_original_recipient = no". File:
        cleanup/cleanup_out_recipient.c. [...]"

http://www.archivum.info/postfix-users@postfix.org/2008-06/msg00261.html
http://diymacserver.com/index.php?s=20070520&submit=Search

Best Regards,
Eric Janz
Comment 1 Miroslav Lichvar 2008-12-10 10:36:00 EST
Just to be sure, the aliases are specified in virtual alias table? And is the enable_original_recipient option disabled?
Comment 2 Eric Janz 2008-12-10 11:25:37 EST
Yes,

we are using in main.cf
virtual_alias_maps = mysql:/etc/postfix/mysql_virtual_alias_maps.cf

# cat /etc/postfix/mysql_virtual_alias_maps.cf
user = blablabla
password = blablablapassword
hosts = localhost
dbname = postfix
table = alias
select_field = goto
where_field = address

and SELECT * FROM `postfix`.`alias` where address like 'user%';

returns:

address              goto
------              -----
user1@mydomain.com  user4@mydomain.com,user1@mydomain.com
user4@mydomain.com  user4@mydomain.com


I tried with enable_original_recipient set to NO and the result is the same as when I dont set it (default is YES, AFAIK)


In our old system this does not happen with the same setup although the enable_original_recipient is not explicitly disabled.


Best Regards,
Eric Janz
Comment 3 Miroslav Lichvar 2008-12-11 11:14:07 EST
That's odd, with postfix-2.1.5-4.2.RHEL4 I'm getting duplicates unless the option is disabled.

Can you please try this package to see if it's better? It includes the 20070520 patch.

http://people.redhat.com/mlichvar/tmp/postfix-474541/
Comment 4 Eric Janz 2008-12-15 04:32:41 EST
Hi Miroslav,

it works fine. With your package and the option enable_original_recipient = no the duplicates have disappeared.

Thanks a lot,
Best Regards,
Eric Janz
Comment 5 RHEL Product and Program Management 2009-03-26 12:49:37 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 6 Eric Janz 2009-03-30 05:05:56 EDT
Can you please review this issue as soon as possible. We are now using Miroslav's postfix package and can not update to any newer version until this problem is fixed.

Best Regards,
Eric Janz
Comment 7 RHEL Product and Program Management 2009-11-06 13:45:10 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 9 RHEL Product and Program Management 2010-08-09 14:19:41 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 10 RHEL Product and Program Management 2011-01-11 15:19:43 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 11 RHEL Product and Program Management 2011-01-11 18:22:58 EST
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.
Comment 12 RHEL Product and Program Management 2011-05-31 09:24:43 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 13 RHEL Product and Program Management 2011-09-22 20:14:32 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 17 RHEL Product and Program Management 2012-04-02 06:29:59 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 22 Jaroslav Škarvada 2012-06-28 04:13:10 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Prior to this update, the "aggresive" recipient duplicate elimination was broken. This could lead to reception of multiple copies of e-mails for users that were specified in multiple virtual aliases. Now if the enable_original_recipient configuration option is set to "no" the recipient duplicate elimination will work correctly and users will not receive multiple copies of e-mails.
Comment 25 errata-xmlrpc 2013-01-08 02:26:54 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0054.html

Note You need to log in before you can comment on or make changes to this bug.