Bug 474555 - 520 -> 530 upgrade: rhn-upgrade dependency error
520 -> 530 upgrade: rhn-upgrade dependency error
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Upgrades (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Milan Zazrivec
Jeff Browning
:
Depends On:
Blocks: 456986
  Show dependency treegraph
 
Reported: 2008-12-04 08:01 EST by Milan Zazrivec
Modified: 2009-08-31 05:34 EDT (History)
2 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-27 13:37:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/rhn/rhn-installation.log (1.58 KB, text/plain)
2008-12-04 08:14 EST, Milan Zazrivec
no flags Details

  None (edit)
Description Milan Zazrivec 2008-12-04 08:01:31 EST
Description of problem:
When upgrading Satellite 5.2.0 on RHEL-4 to Satellite-5.3.0-RHEL4-re20081128.0
embedded db variant, following dependency error pops up:

# ./install.pl --disconnected --upgrade
ERROR: RPM dependency error.  The message was:
Dependencies should have already been resolved, but they are not.
Unresolved rpm dependencies:

...
Package rhn-upgrade  5.2.0-23.el4 requires perl(Sniglets::SatInstall)
...

# rpm -q --whatprovides 'perl(Sniglets::SatInstall)'
rhn-sniglets-5.2.0-16.el4
# rpm -qp --provides Satellite/spacewalk-sniglets-0.3.7-2.el4.noarch.rpm |grep SatInstall
#

Version-Release number of selected component (if applicable):
rhn-upgrade-5.2.0-23
spacewalk-web-0.3.7-2
Comment 1 Milan Zazrivec 2008-12-04 08:14:38 EST
Created attachment 325675 [details]
/var/log/rhn/rhn-installation.log
Comment 2 Clifford Perry 2008-12-04 11:11:05 EST
- rhn-upgrade should not be on ISO - not sure if that was issue. 

Sounds like 'rpm -e rhn-upgrade' would work around the issue short term. 

The perl scripts packaged within rhn-upgrade may need to be re-written to not say

use Sniglets::SatInstall

or the spacewalk-sniglets package has a clear provides. 

Do not know path of resolution here :) 

Milan - can you figure this one out? 

Thanks,
Cliff
Comment 3 Milan Zazrivec 2008-12-04 11:24:01 EST
(In reply to comment #2)
> - rhn-upgrade should not be on ISO - not sure if that was issue. 

rhn-upgrade package is not included in the Satellite ISO, but it needs to
be installed prior to the upgrade (usually from a satellite channel) so that
we can actually start the upgrade (otherwise the installer will complain
and bail on us).

> The perl scripts packaged within rhn-upgrade may need to be re-written to not
> say
> 
> use Sniglets::SatInstall
> 
> or the spacewalk-sniglets package has a clear provides. 
> 
> Do not know path of resolution here :) 
> 
> Milan - can you figure this one out? 

What happened here is that Sniglets::SatInstall module was removed from spacewalk
git after Spacewalk 0.1 was released, since it was not being used anywhere
in Spacewalk. We still need one simple routine from this module to be able to run
rhn-load-config.pl contained in rhn-upgrade. The routine (split_dsn) is simple
enough to be included directly into rhn-load-config.pl
Comment 4 Milan Zazrivec 2008-12-05 09:07:49 EST
Sending        satellite-upgrade/rhn-load-config.pl
Sending        satellite-upgrade/rhn-upgrade.spec
Sending        satellite-upgrade/version
Transmitting file data ...
Committed revision 179499.
Comment 5 Milan Zazrivec 2008-12-05 09:41:39 EST
Fix contained in rhn-upgrade-5.3.0-1 build.
Comment 6 Milan Zazrivec 2008-12-16 10:56:43 EST
rhn-upgrade-5.3.0-2 actually
Comment 7 Jeff Browning 2009-03-31 12:45:17 EDT
This is still a problem when trying to yum install the rhn-upgrade package on a RHEL5 box running Sat 520.

[root@rlx-0-06 iso]# yum install rhn-upgrade
Loaded plugins: rhnplugin, security
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package rhn-upgrade.noarch 0:5.3.0.5-1.el5sat set to be updated
--> Processing Dependency: perl(Spacewalk::Setup) for package: rhn-upgrade
--> Finished Dependency Resolution
rhn-upgrade-5.3.0.5-1.el5sat.noarch from redhat-rhn-satellite-5.2-server-i386-5 has depsolving problems
  --> Missing Dependency: perl(Spacewalk::Setup) is needed by package rhn-upgrade-5.3.0.5-1.el5sat.noarch (redhat-rhn-satellite-5.2-server-i386-5)
Error: Missing Dependency: perl(Spacewalk::Setup) is needed by package rhn-upgrade-5.3.0.5-1.el5sat.noarch (redhat-rhn-satellite-5.2-server-i386-5)
Comment 8 Milan Zazrivec 2009-04-01 07:58:24 EDT
spacewalk-web changes required for this to work:

RHN::SatInstall::satcon_deploy() restored in
e1c35fe888d405217ce8ee4096c9b449ee3573e9

RHN::SatInstall::generate_satcon_dict() restored in
966b9e7a545130fde46fb324a9fb1fa460551ec0

RHN::SatInstall::generate_server_pem() restored in
7714864d4a100931c0071695f659e2b2608aa6ae
Comment 9 Milan Zazrivec 2009-04-01 08:51:07 EDT
rhn-upgrade fixes in satellite.git, SATELLITE-5.3:
81925b494f7ace335c8a7c3a2eddd8b844358842

new version tagged: rhn-upgrade-5.3.0.6-1-sat
Comment 10 Milan Zazrivec 2009-04-01 08:55:06 EDT
This can be moved into ON_QA as soon as both new spacewalk-web is built
and rhn-upgrade-5.3.0.6-1-sat will be pushed into webqa.
Comment 11 Milan Zazrivec 2009-04-09 09:06:50 EDT
rhn-upgrade-5.3.0.6-1 is in webqa.
Comment 12 Jeff Browning 2009-05-12 16:46:55 EDT
Verified
Comment 13 Miroslav Suchý 2009-08-26 10:06:12 EDT
verified in stage on xen15

* Installing RHN packages.
Warning: more packages were installed by yum than expected:
        mtools
        syslinux
        tcsh
* Now running setup.

no errors in /var/log/rhn/rhn-installation.log
Comment 14 Brandon Perkins 2009-08-27 13:37:45 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1235.html

Note You need to log in before you can comment on or make changes to this bug.