Bug 474609 - rpmrebuild : Unowned directories
rpmrebuild : Unowned directories
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: rpmrebuild (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Anderson Silva
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-04 11:53 EST by Michael Schwendt
Modified: 2009-01-16 18:46 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-27 05:33:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2008-12-04 11:53:18 EST
One or more directories are not included within this
package and/or its sub-packages:

=> rpmrebuild-2.2.2-1.fc10.noarch (rawhide-development-i386)
/usr/lib/rpmrebuild/locale
/usr/lib/rpmrebuild/locale/fr_FR.UTF-8
/usr/lib/rpmrebuild/locale/en
/usr/lib/rpmrebuild/locale/fr_FR

[...]

Further information:

https://fedoraproject.org/wiki/Packaging/ReviewGuidelines

MUST: A package must own all directories that it creates. If it does not
create a directory that it uses, then it should require a package which
does create that directory.

https://fedoraproject.org/wiki/Packaging/Guidelines#FileAndDirectoryOwnership
https://fedoraproject.org/wiki/Packaging/UnownedDirectories
Comment 1 Anderson Silva 2008-12-04 12:29:51 EST
Hi Thanks for recording this bug, I've fixed the spec for devel, but when I try to build it it dies with the following error:

$ cvs -d :pserver:anonymous@cvs.fedoraproject.org:/cvs/pkgs checkout -r rpmrebuild-2_2_2-2_fc11 rpms/rpmrebuild/devel
cvs checkout: Updating rpms/rpmrebuild/devel
U rpms/rpmrebuild/devel/rpmrebuild.spec
$ cvs -d :pserver:anonymous@cvs.fedoraproject.org:/cvs/pkgs checkout common
cvs checkout: Updating common
U common/Makefile
U common/Makefile.common
U common/branches
U common/cvs-import.sh
$ make srpm
make: *** No rule to make target `srpm'.  Stop.


It seems the Makefile is missing something.
Comment 2 Anderson Silva 2008-12-04 12:34:39 EST
Ok, I've resolved the issue above....

new rpm being build:

http://koji.fedoraproject.org/koji/buildinfo?buildID=73238
Comment 3 Fedora Update System 2008-12-04 12:52:35 EST
rpmrebuild-2.2.2-2.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/rpmrebuild-2.2.2-2.fc10
Comment 4 Anderson Silva 2008-12-04 13:05:33 EST
This error has been fixed, but I've tested the new rpm on Fedora 10, I've
noticed that rpmrebuild seems to be broken, my guess is because of the
introduction for RPM 4.6 in Fedora 10. I've contacted rpmrebuild upstream, and
I intend to work with them to solve this issue. I will keep this bug open and
update it when a new build is ready.
Comment 5 Fedora Update System 2009-01-09 18:29:49 EST
rpmrebuild-2.3-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/rpmrebuild-2.3-1.fc10
Comment 6 Fedora Update System 2009-01-16 18:46:20 EST
rpmrebuild-2.3-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.