Bug 474616 - python-libgmail-docs : Unowned directories
python-libgmail-docs : Unowned directories
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: python-libgmail-docs (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Nikolay Vladimirov
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-04 12:03 EST by Michael Schwendt
Modified: 2009-01-26 20:53 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-16 18:43:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2008-12-04 12:03:21 EST
One or more directories are not included within this
package and/or its sub-packages:

=> python-libgmail-docs-0.3-6.fc9.noarch (rawhide-development-i386)
/usr/share/doc/python-libgmail-0.1.8

[...]

Further information:

https://fedoraproject.org/wiki/Packaging/ReviewGuidelines

MUST: A package must own all directories that it creates. If it does not
create a directory that it uses, then it should require a package which
does create that directory.

https://fedoraproject.org/wiki/Packaging/Guidelines#FileAndDirectoryOwnership
https://fedoraproject.org/wiki/Packaging/UnownedDirectories
Comment 1 Nikolay Vladimirov 2009-01-02 12:11:12 EST
I took the package after being orphaned and due to the lack of updates I didn't really look at it. The problem was that the package installs the docs in python-libgmail's doc folder and due to version changes now the docs just sit in a folder for some old version. I completely restructured the package to behave as it should and as upstream intended a completely separate package with it's own dir. I'll do some more checks and push it.
Comment 2 Fedora Update System 2009-01-02 12:52:17 EST
python-libgmail-docs-0.3-7.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/python-libgmail-docs-0.3-7.fc10
Comment 3 Fedora Update System 2009-01-07 04:30:24 EST
python-libgmail-docs-0.3-7.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update python-libgmail-docs'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-0185
Comment 4 Fedora Update System 2009-01-16 18:43:28 EST
python-libgmail-docs-0.3-7.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Fedora Update System 2009-01-16 20:07:28 EST
python-libgmail-docs-0.3-7.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/python-libgmail-docs-0.3-7.fc9
Comment 6 Fedora Update System 2009-01-26 20:53:49 EST
python-libgmail-docs-0.3-7.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.