Bug 474618 - gnome-terminal sometime leaves empty begining of the line
gnome-terminal sometime leaves empty begining of the line
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-terminal (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Behdad Esfahbod
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-04 12:13 EST by Zdenek Kabelac
Modified: 2008-12-05 15:01 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-05 15:01:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
gnome-terminal (vte) missing symbols (37.49 KB, image/png)
2008-12-04 14:37 EST, Yanko Kaneti
no flags Details
typescript (29.09 KB, application/octet-stream)
2008-12-04 15:15 EST, Yanko Kaneti
no flags Details

  None (edit)
Description Zdenek Kabelac 2008-12-04 12:13:10 EST
Description of problem:

I've started to notice that I'm now missing some text written on the begining of the line:

i.e.
make -C tools
make[1]: Entering directory `/misc/tools'
       : Nothing to be done for `all'.
       : Leaving directory `/misc/tools'
        daemons

instead of the text written in xterm:

make[1]: Entering directory `/misc/tools'
make[1]: Nothing to be done for `all'.
make[1]: Leaving directory `/misc/tools'
make -C daemons


Usually could be noticed while running make - I'm not really sure if there are any control command printed or what other reason could be for this behavior.


Version-Release number of selected component (if applicable):
gnome-terminal-2.24.2-2.fc11.x86_64

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Yanko Kaneti 2008-12-04 14:21:37 EST
I can confirm this, but it appears to be an issue with the new vte (0.19.1-1). Cannot reproduce with vte downgraded to 0.17.4-1.fc10. 
Running on modeset radeon r5xx if that matters...
Comment 2 Yanko Kaneti 2008-12-04 14:37:35 EST
Created attachment 325730 [details]
gnome-terminal (vte) missing symbols

And its not only at the beginning of the line here. See attachment.
Comment 3 Behdad Esfahbod 2008-12-04 14:49:36 EST
Ouch, not good.  Does it happen regularly?  If yes, can one of you record it inside script(1) and see if replaying that reproduces?

Thanks
Comment 4 Yanko Kaneti 2008-12-04 15:15:49 EST
Created attachment 325742 [details]
typescript

Here is one that always has issues. Not always in the same places but almost everytime on the last two lines of output. In general it seems to happen almost every time there is a burst of output at big rate, regardless of what the output actually is.
Comment 5 Yanko Kaneti 2008-12-04 15:24:35 EST
Just doing  while true ; do  echo -n "#" ; done  produces a very raindrops-falling-upwards display. Pretty random.
Comment 6 Behdad Esfahbod 2008-12-05 15:01:42 EST
Fixed in rawhide.

Note You need to log in before you can comment on or make changes to this bug.