Bug 474672 - libtool : Unowned directories
libtool : Unowned directories
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libtool (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Karsten Hopp
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-04 15:08 EST by Michael Schwendt
Modified: 2009-02-18 07:24 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-18 07:24:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2008-12-04 15:08:08 EST
One or more directories are not included within this
package and/or its sub-packages:

=> libtool-ltdl-devel-2.2.6-1.fc11.i386 (rawhide-development-i386)
/usr/share/libtool
    provided by: libtool-2.2.6-1.fc11.i386
/usr/include/libltdl

Note: Due to the sub-package dependency hierarchy it may be necessary
to include directories in more than one package.

[...]

Further information:

https://fedoraproject.org/wiki/Packaging/ReviewGuidelines

MUST: A package must own all directories that it creates. If it does not
create a directory that it uses, then it should require a package which
does create that directory.

https://fedoraproject.org/wiki/Packaging/Guidelines#FileAndDirectoryOwnership
https://fedoraproject.org/wiki/Packaging/UnownedDirectories
Comment 1 Karsten Hopp 2008-12-09 07:58:29 EST
fixed by Ignacio Vazquez-Abrams in 2.2.6-5
Comment 2 Michael Schwendt 2008-12-12 16:12:18 EST
Still reproducible:

$ ./dircheck-remote.py -r rawhide -n ^libtool
Target distribution:
  rawhide
Reading repository metadata...
11700 packages to examine...

=> libtool-2.2.6-5.fc11.src.rpm
=> libtool-ltdl-devel-2.2.6-5.fc11.i386 (rawhide)
/usr/share/libtool
    provided by: libtool-2.2.6-5.fc11.i386

Note You need to log in before you can comment on or make changes to this bug.