Bug 474741 - Some windows aren't properly drawn
Some windows aren't properly drawn
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: compiz (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-04 23:25 EST by Cameron Cross
Modified: 2018-04-11 08:23 EDT (History)
5 users (show)

See Also:
Fixed In Version: 0.7.6-5.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-18 14:54:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenc=shot of ccsm not drawn properly (515.50 KB, image/jpeg)
2008-12-04 23:25 EST, Cameron Cross
no flags Details
xorg.conf (417 bytes, text/plain)
2008-12-07 18:34 EST, Cameron Cross
no flags Details
patch for compiz.spec to include the mentioned patch (1.76 KB, patch)
2009-03-06 16:20 EST, Christian Krause
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 269904 None None None Never

  None (edit)
Description Cameron Cross 2008-12-04 23:25:09 EST
Created attachment 325795 [details]
screenc=shot of ccsm not drawn properly

Description of problem:
Some windows dont properly redraw themselves after they are changed. Most noticeable is ccsm. After click  button to change to a different screen the window doesn't redraw unless you click the window. Also if you mouse over the window some part pop up. Happens with firefox occasionally

Version-Release number of selected component (if applicable):


How reproducible:
Fairly consistently

Steps to Reproduce:
1.open ccsm
2.change to a different sub menu
3.mouse over the area or click the window to make it draw properly
  
Actual results:
Screen is not drawn until you click or mouse over, 

Expected results:
Screen is drawn properly

Additional info:Screen shots attached. im using the nvidia driver but this doesn't occur when using metacity.
Comment 1 Matěj Cepl 2008-12-05 11:34:44 EST
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf, if available) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Cameron Cross 2008-12-07 18:34:50 EST
Created attachment 326059 [details]
xorg.conf

I am using the nvidia driver
Comment 3 Matěj Cepl 2008-12-21 18:43:21 EST
Thanks for the report. We are sorry that we cannot help you with your problem, but we are not able to support binary-only drivers. If you would be able to reproduce this issue using only open source software, please, reopen this bug with the additional information, but in meantime I have no choice than to close this bug as CANTFIX (because we really cannot fix it).

For users who are experiencing problems installing, configuring, or using the unsupported 3rd party proprietary "nvidia" video driver, Nvidia provides indirect customer support via an online web based support forum.  Nvidia monitors these web forums for commonly reported problems and passes them on to Nvidia engineers for investigation.  Once they've isolated a particular problem, it is often fixed in a future video driver update.

The NVNews Nvidia Linux driver forum is located at:

    http://www.nvnews.net/vbulletin/forumdisplay.php?s=&forumid=14

Once you have reported this issue in the Nvidia web forums, others who may have experienced the particular problem may be able to assist.  If there is a real bug occuring, Nvidia will be able to determine this, and will likely resolve the issue in a future driver update for the operating system releases that they officially support.

While Red Hat does not support the proprietary nvidia driver, users requiring technical support may also find the various X.Org, XFree86, and Red Hat mailing lists helpful in finding assistance:

X.Org mailing lists:
    http://www.freedesktop.org/XOrg/XorgMailingLists

XFree86 mailing lists:
    http://www.xfree86.org/sos/lists.html

Red Hat mailing lists:
    https://listman.redhat.com/mailman/listinfo
Comment 4 Danny Baumann 2009-03-06 08:35:51 EST
(In reply to comment #3)
> Thanks for the report. We are sorry that we cannot help you with your problem,
> but we are not able to support binary-only drivers. If you would be able to
> reproduce this issue using only open source software, please, reopen this bug
> with the additional information, but in meantime I have no choice than to close
> this bug as CANTFIX (because we really cannot fix it).
>
> For users who are experiencing problems installing, configuring, or using the
> unsupported 3rd party proprietary "nvidia" video driver, Nvidia provides
> indirect customer support via an online web based support forum.  Nvidia
> monitors these web forums for commonly reported problems and passes them on to
> Nvidia engineers for investigation.  Once they've isolated a particular
> problem, it is often fixed in a future video driver update.
> 

Sorry, but this is completely wrong. While the Nvidia driver certainly has a fair share of issues, this issue is _neither_ a problem in the driver nor a problem in compiz. It's a problem of the way the DAMAGE extension of X.org works and thus _is_ fixable in the free software stack.

You can read about the statement from Nvidia here:
http://www.nvnews.net/vbulletin/showthread.php?t=120829&highlight=damage

and this mailing list thread has some background information:
http://lists.freedesktop.org/archives/xorg/2008-August/037995.html

Basically, the problem is that the X server sends damage events when rendering commands are _sent_ to the driver, not when they are _executed_. This leads to situations where compiz processes the damage events earlier than they are executed. Obviously, the occurence of that scenario highly depends on timing; and the fact that the problem currently only occurs on Nvidia hardware and drivers doesn't mean that it isn't present for other drivers as well; it just means that there are circumstances which make it not appear for other drivers (one of those being those drivers always using indirect rendering).

As Aaron Plattner commented in the first linked posting, it's possible to workaround that problem in compiz; a patch doing so can be found at
http://people.freedesktop.org/~aplattner/patches/049-damage-report-non-empty.patch

This patch unfortunately is not upstreamable as-is due to it just being a workaround for a infrastructure limitation; but it should be fine for a distro patch (and FWIW, Ubuntu compiz packages carry that patch since quite some time).
Comment 5 Christian Krause 2009-03-06 15:59:04 EST
I was suffering from this problem, too. Some programs were nearly unusable due t
o the frequency the problem occured (especially xterm and thunderbird).

I'm using a patched compiz since a couple of weeks (private build) and the
problem was gone completely.

Since it would be great to get this officially fixed, I've just created a
scratch build in koji using the mentioned patch:

https://koji.fedoraproject.org/koji/taskinfo?taskID=1227602

It would be great if the compiz package maintainers could consider
including the patch for Fedora, too.

Thanks in advance!
Comment 6 Christian Krause 2009-03-06 16:20:38 EST
Created attachment 334352 [details]
patch for compiz.spec to include the mentioned patch 

Just attaching the patch for compiz.spec.

Please note that the new build requirement is needed to workaround a problem with pkgconfig introduced a month ago: https://bugzilla.redhat.com/show_bug.cgi?id=224148 - otherwise compiz won't build.
Comment 7 Danny Baumann 2009-03-09 12:41:51 EDT
A different workaround, which has been implemented upstream in the workarounds plugin (part of compiz-fusion-plugins-main), can be found here:

http://cgit.compiz-fusion.org/fusion/plugins/workarounds/commit/?id=46960f12a9d213e5f0e841557e2ed2f7ea18cc79

As the latest upstream release has already passed by, it might be a good idea to include that workaround as a distro patch until the next release cycle.
Comment 8 Fedora Update System 2009-03-14 13:13:14 EDT
compiz-fusion-0.7.8-3.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/compiz-fusion-0.7.8-3.fc10
Comment 9 Fedora Update System 2009-03-14 13:18:30 EDT
compiz-fusion-0.7.6-5.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/compiz-fusion-0.7.6-5.fc9
Comment 10 leigh scott 2009-03-15 06:18:06 EDT
(In reply to comment #7)
> A different workaround, which has been implemented upstream in the workarounds
> plugin (part of compiz-fusion-plugins-main), can be found here:
> 
> http://cgit.compiz-fusion.org/fusion/plugins/workarounds/commit/?id=46960f12a9d213e5f0e841557e2ed2f7ea18cc79
> 
> As the latest upstream release has already passed by, it might be a good idea
> to include that workaround as a distro patch until the next release cycle. 


The problem still occurs even with the fix, I am using the latest  compiz-plugins-main snapshot.
Comment 11 Adel Gadllah 2009-03-15 06:53:43 EDT
(In reply to comment #10)
> (In reply to comment #7)
> > A different workaround, which has been implemented upstream in the workarounds
> > plugin (part of compiz-fusion-plugins-main), can be found here:
> > 
> > http://cgit.compiz-fusion.org/fusion/plugins/workarounds/commit/?id=46960f12a9d213e5f0e841557e2ed2f7ea18cc79
> > 
> > As the latest upstream release has already passed by, it might be a good idea
> > to include that workaround as a distro patch until the next release cycle. 
> 
> 
> The problem still occurs even with the fix, I am using the latest 
> compiz-plugins-main snapshot.  

You have to enable the fix.

Enable the workarounds plugin:

gconftool-2 -s /apps/compiz/general/allscreens/options/active_plugins --type=list --list-type=string `gconftool-2 -g /apps/compiz/general/allscreens/options/active_plugins | sed 's/\]//'`,workarounds]

And then the specific workaround:

gconftool-2 -s /apps/compiz/plugins/workarounds/allscreens/options/force_glx_sync --type=boolean true
Comment 12 leigh scott 2009-03-15 08:31:24 EDT
Thanks Adel that fixed it.
Comment 13 Christian Krause 2009-03-16 04:37:09 EDT
(In reply to comment #8)
> compiz-fusion-0.7.8-3.fc10 has been submitted as an update for Fedora 10.
> http://admin.fedoraproject.org/updates/compiz-fusion-0.7.8-3.fc10  

Works fine for me. Thanks! From my side this bug can be closed.
Comment 14 Fedora Update System 2009-03-16 15:42:31 EDT
compiz-fusion-0.7.6-5.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update compiz-fusion'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2009-2714
Comment 15 Fedora Update System 2009-03-16 15:48:22 EDT
compiz-fusion-0.7.8-3.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update compiz-fusion'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-2751
Comment 16 Fedora Update System 2009-03-18 14:54:04 EDT
compiz-fusion-0.7.8-3.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 17 Fedora Update System 2009-03-18 15:15:45 EDT
compiz-fusion-0.7.6-5.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.