Bug 474757 - postinstall scriptlet fails for dmraid 1.0.0.rc13 19
postinstall scriptlet fails for dmraid 1.0.0.rc13 19
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: dmraid (Show other bugs)
5.3
All Linux
high Severity high
: rc
: ---
Assigned To: Heinz Mauelshagen
Cluster QE
:
: 475191 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-05 03:28 EST by Alexander Todorov
Modified: 2010-10-23 02:22 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 15:47:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Todorov 2008-12-05 03:28:27 EST
Description of problem:
During installation we have in the install.log:

Installing dmraid-1.0.0.rc13-19.el5.ia64
error: %post(dmraid-1.0.0.rc13-19.el5.ia64) scriptlet failed, exit status 1



Version-Release number of selected component (if applicable):
dmraid-1.0.0.rc13-19.el5

How reproducible:
Always/all arches

Steps to Reproduce:
1. Perform @everything install
2.
3.
  
Actual results:
postinstall scriptlet failed
Comment 2 Alexander Todorov 2008-12-05 03:34:51 EST
postinstall scriptlet (using /bin/sh):
# Add crontab entry for logwatch dmeventd service
[ -f logwatch/dmeventd_cronjob.txt ] &&
crontab -l 2>/dev/null|cat - logwatch/dmeventd_cronjob.txt|crontab -

/usr/bin/crontab is provided by vixie-cron which is installed after dmraid package. dmraid doesn't require vixie-cron to be installed.
Comment 3 Heinz Mauelshagen 2008-12-05 07:59:55 EST
Fixed missing requirement.
Waiting for flags to be set to checkin+build.
Comment 5 Heinz Mauelshagen 2008-12-05 09:52:36 EST
Fix checked in, new package dmraid-1.0.0.rc13-20.el5 built.
Comment 7 Heinz Mauelshagen 2008-12-08 08:41:38 EST
*** Bug 475191 has been marked as a duplicate of this bug. ***
Comment 10 Brock Organ 2008-12-18 23:25:55 EST
verified fixed in dmraid-1.0.0.rc13-33.el5 ...

Earlier error:

> Installing dmraid-1.0.0.rc13-19.el5.x86_64
> error: %post(dmraid-1.0.0.rc13-19.el5.x86_64) scriptlet failed, exit status 1

is no longer present:

> Installing kpartx-0.4.7-23.el5.x86_64
> Installing dmraid-1.0.0.rc13-33.el5.x86_64
> Installing openmotif-2.3.1-2.el5.x86_64
Comment 13 errata-xmlrpc 2009-01-20 15:47:40 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-0078.html

Note You need to log in before you can comment on or make changes to this bug.