Bug 474759 - Error: Missing Dependency: nash = 6.0.71-1.fc11 is needed by package mkinitrd-6.0.71-1.fc11.i386 (rawhide)
Error: Missing Dependency: nash = 6.0.71-1.fc11 is needed by package mkinitrd...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
rawhide
All Linux
low Severity urgent
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-05 03:32 EST by Γριφεγ Γ.
Modified: 2009-02-17 07:39 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-17 07:39:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Γριφεγ Γ. 2008-12-05 03:32:43 EST
Description of problem:

[root@localhost ~]# nice yum install nash
Loaded plugins: refresh-packagekit
Setting up Install Process
Parsing package install arguments
Package matching nash-6.0.71-1.fc11.i386 already installed. Checking for update.
Nothing to do
[root@localhost ~]# nice yum install mkinitrd
Loaded plugins: refresh-packagekit
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package mkinitrd.i386 0:6.0.71-1.fc11 set to be updated
--> Processing Dependency: nash = 6.0.71-1.fc11 for package: mkinitrd
--> Processing Dependency: plymouth >= 0.6.0-0.2008.09.10.1 for package: mkinitrd
--> Running transaction check
---> Package plymouth.i386 0:0.6.0-1.fc11 set to be updated
--> Processing Dependency: libply.so.2 for package: plymouth
--> Processing Dependency: libplybootsplash.so.2 for package: plymouth
--> Processing Dependency: plymouth-scripts for package: plymouth
---> Package mkinitrd.i386 0:6.0.71-1.fc11 set to be updated
--> Processing Dependency: nash = 6.0.71-1.fc11 for package: mkinitrd
--> Running transaction check
---> Package plymouth-scripts.i386 0:0.6.0-1.fc11 set to be updated
---> Package mkinitrd.i386 0:6.0.71-1.fc11 set to be updated
--> Processing Dependency: nash = 6.0.71-1.fc11 for package: mkinitrd
---> Package plymouth-libs.i386 0:0.6.0-1.fc11 set to be updated
--> Finished Dependency Resolution
mkinitrd-6.0.71-1.fc11.i386 from rawhide has depsolving problems
  --> Missing Dependency: nash = 6.0.71-1.fc11 is needed by package mkinitrd-6.0.71-1.fc11.i386 (rawhide)
Error: Missing Dependency: nash = 6.0.71-1.fc11 is needed by package mkinitrd-6.0.71-1.fc11.i386 (rawhide)
[root@localhost ~]# 



Version-Release number of selected component (if applicable):
Comment 1 Γριφεγ Γ. 2008-12-05 11:35:57 EST
Okay, this was apparently caused by nash-6.0.71-2.fc10 which I had installed, being considered newer than nash-6.0.71-1.fc11 which was required. But where did the -2.fc10 package come from? Is this a rogue mirror trying to get a backdoor into my initrd?
Comment 2 Hans de Goede 2009-02-17 07:39:10 EST
(In reply to comment #1)
> Okay, this was apparently caused by nash-6.0.71-2.fc10 which I had installed,
> being considered newer than nash-6.0.71-1.fc11 which was required. But where
> did the -2.fc10 package come from? Is this a rogue mirror trying to get a
> backdoor into my initrd?

Nope, that is the F-10 gold version apparently we've had a window where the F-10 version was newer then rawhide, our bad. This is long fixed now, closing.

Note You need to log in before you can comment on or make changes to this bug.