Bug 474778 - /dev/ttyUSB* devices do not inherit ownership of logged-in user
/dev/ttyUSB* devices do not inherit ownership of logged-in user
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-05 06:45 EST by Mark Watts
Modified: 2009-09-14 08:06 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-14 06:55:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark Watts 2008-12-05 06:45:21 EST
Description of problem:

When plugging in a USB-Serial dongle, /dev/ttyUSBx is created as:
root:uucp instead of $USER:uucp

Version-Release number of selected component (if applicable):

Any.

How reproducible:

Always

Steps to Reproduce:
1. Plug in USB-Serial dongle.
2.
3.
  
Actual results:
Ownership of /dev/ttyUSBx is root:uucp

Expected results:
Ownership should be that of the logged-in user.

Additional info:

The following rules added to /etc/security/console.perms.d/ fix this:

<usb>=/dev/ttyUSB*
<console>  0660 <usb>        0660 root.usb
Comment 1 John Beale 2008-12-05 21:39:04 EST
I like that something need to be done by root to set access for users to non-standard USB device. However, something needs to be done to allow easy access for users that need it and block those that don't (like a group access set by root).
Comment 2 Tomas Mraz 2008-12-08 03:49:09 EST
pam_console is deprecated. This has to be handled by HAL+consolekit.
Comment 3 Mark Watts 2008-12-08 04:05:44 EST
I'n not fussed how this is achieved in the long run; the pam_console stuff *works* right now, so thats how I'm solving my immediate problem.

I'm not sure I'd class a USB<->Serial converter as "non-standard" - I shouldn't need to fiddle as root to use one to configure Network devices (Cisco et al) or even potentially connect such things as a serial digitising tablet.
Comment 4 Scott Glaser 2009-09-09 08:28:17 EDT
Have you tried with the latest hal package in Fedora 10, Fedora 11 or tried Rawhide? In either case, can you let us know whether the issue is still happening, and give the current version of the HAL packages you're using?

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 5 Mark Watts 2009-09-14 06:55:02 EDT
Latest Fedora 10 seems to have fixed this.
Plugging in a usb-serial converter and running minicom as non-root works as expected.
Comment 6 Scott Glaser 2009-09-14 08:06:02 EDT
Based on the information provided in comment 5 I am marking this bug as closed. Should you again experienced these issues in the future please file a new bug against the actual component. Thanks for the rapid response.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.