Bug 474799 - X will not start with new xorg-x11-drv-nouveau package
X will not start with new xorg-x11-drv-nouveau package
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
10
All Linux
high Severity medium
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-05 07:51 EST by Josef Bacik
Modified: 2009-08-24 09:55 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-24 09:55:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log.old, its the last log from when I tried to use nouveau. (8.16 KB, text/plain)
2008-12-05 07:51 EST, Josef Bacik
no flags Details
xorg.conf (639 bytes, text/plain)
2008-12-05 07:52 EST, Josef Bacik
no flags Details

  None (edit)
Description Josef Bacik 2008-12-05 07:51:08 EST
Created attachment 325839 [details]
Xorg.0.log.old, its the last log from when I tried to use nouveau.

Description of problem:
I updated my box last night and all of a sudden X will just sit there and restart over and over again.  The only thing X related was the new nouveau driver.  I'm attaching my xorg log files.  I had to switch to the NV driver, which is working fine.

Version-Release number of selected component (if applicable):
xorg-x11-drv-nouveau-0.0.11-1.20081119git65b956f.fc10.x86_64

How reproducible:
Everytime
  
Actual results:
X restarts over and over again.

Expected results:
X doesn't restart

Additional info:

05:00.0 VGA compatible controller: nVidia Corporation NV37GL [Quadro PCI-E Series] (rev a2)

05:00.0 0300: 10de:00fd (rev a2)
Comment 1 Josef Bacik 2008-12-05 07:52:16 EST
Created attachment 325840 [details]
xorg.conf

this is my xorg.conf.  I've just commented out the nouveau part and put NV in, so its the same config that was being used with nouveau.
Comment 2 Alex Kanavin 2008-12-09 05:09:00 EST
Same problem here, I reported it in bug 466796, comments 6 to 8 (see them for the config file and xorg log when things fail with the new nouveau snapshot).
Comment 4 Ben Skeggs 2009-05-04 00:05:01 EDT
Are you able to test the latest nouveau updates and report back?  If it's still not working, can you post your /var/run/nv*.log file here?
Comment 5 Alex Kanavin 2009-05-06 05:28:01 EDT
The latest F10 nouveau works good here.
Comment 6 Matěj Cepl 2009-05-06 10:14:15 EDT
Josef? Does it work for you? (and how is btrfsck doing? :))
Comment 7 Josef Bacik 2009-05-06 11:14:33 EDT
I won't have access to the box until tomorrow, so I will test then.  btrfsck is not yet fixed :).
Comment 8 Ben Skeggs 2009-08-23 20:25:08 EDT
Any update?
Comment 9 Josef Bacik 2009-08-24 09:55:59 EDT
works fine for me now, closing.

Note You need to log in before you can comment on or make changes to this bug.