Bug 474813 - [RFE] customize EC2E routed CMD
[RFE] customize EC2E routed CMD
Status: CLOSED ERRATA
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: grid (Show other bugs)
1.0
All Linux
low Severity low
: 1.1.1
: ---
Assigned To: Robert Rati
Jeff Needle
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-05 08:55 EST by Matthew Farrellee
Modified: 2009-04-21 12:19 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-21 12:19:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Farrellee 2008-12-05 08:55:20 EST
When a job is routed for EC2E a second job is submitted that looks like a duplicate when viewed with condor_q, any likely other tools. This is primarily because the CMD, a.k.a the executable, is identical. However, the CMD is only a label for EC2 jobs, and could be changed to anything. I'd suggest: "EC2: <route name>: <original cmd>"
Comment 1 Robert Rati 2009-02-05 12:26:53 EST
The routed job's Cmd is now:
"EC2: <route name>: <original cmd>"

However, condor_q will still just show <original cmd> in all likelihood.

Fixed in:
condor-ec2-enhanced-hooks-1.0-11
Comment 3 Jan Sarenik 2009-03-11 12:49:32 EDT
Works as expected. In condor_history it is for example:
Cmd = "EC2: Amazon Small: /mnt/sharedfs/testmonkey/jasan.sh"

While as Robert writes above, running jobs still show <original_cmd>.
Comment 5 errata-xmlrpc 2009-04-21 12:19:29 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-0434.html

Note You need to log in before you can comment on or make changes to this bug.