Bug 474823 - repoquery prints warning messages to stdout instead of stderr
repoquery prints warning messages to stdout instead of stderr
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: yum-utils (Show other bugs)
5.3
All Linux
low Severity low
: ---
: ---
Assigned To: James Antill
James Antill
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-05 09:45 EST by David Kovalsky
Modified: 2014-03-31 19:44 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-10 15:54:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Kovalsky 2008-12-05 09:45:37 EST
repoquery prints warning messages about config file structure to stdout, not stderr. 

[root@kovy ~]# rpm -qf `which repoquery`
yum-utils-1.1.16-13.el5


[root@kovy ~]# repoquery --whatrequires '*libwrap*' 2>/dev/null
Repository 'nightly' is missing name in configuration, using id
Repository 'nightly-VT' is missing name in configuration, using id
                   ^
                   +-- belongs to stderr

openldap-servers-0:2.3.43-3.el5.x86_64
cyrus-imapd-utils-0:2.3.7-2.el5.x86_64
cyrus-imapd-0:2.3.7-2.el5.x86_64
audit-0:1.7.7-5.el5.x86_64
openhpi-subagent-0:2.10.2-1.el5.x86_64
vsftpd-0:2.0.5-12.el5.x86_64
openssh-server-0:4.3p2-29.el5.x86_64
exim-0:4.63-3.el5.x86_64
net-snmp-perl-1:5.3.2.2-5.el5.x86_64
xinetd-2:2.3.14-10.el5.x86_64
quota-1:3.13-1.2.5.el5.x86_64
tcp_wrappers-0:7.6-40.6.el5.x86_64
stunnel-0:4.15-2.el5.1.x86_64
nfs-utils-1:1.0.9-40.el5.x86_64
openhpi-0:2.10.2-1.el5.x86_64
openhpi-0:2.10.2-1.el5.i386
php-snmp-0:5.1.6-23.el5.x86_64
net-snmp-1:5.3.2.2-5.el5.x86_64
sendmail-0:8.13.8-2.el5.x86_64
tcp_wrappers-0:7.6-40.6.el5.i386
conman-0:0.1.9.2-8.el5.x86_64
tftp-server-0:0.42-3.1.x86_64
Comment 1 seth vidal 2008-12-05 11:20:20 EST
fixed in upstream, but fix your repos configs anyway.

http://yum.baseurl.org/gitweb?p=yum-utils.git;a=commit;h=eb181bca43ef24830cc0fc2c28490161b696f313
Comment 2 James Antill 2008-12-05 11:27:34 EST
This is easy to add to 5.4, even if we don't rebase.
Comment 3 RHEL Product and Program Management 2009-03-26 12:51:20 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 4 RHEL Product and Program Management 2013-05-01 02:43:21 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 5 James Antill 2013-12-10 15:54:27 EST
 Given the age of this and that it's a mostly cosmetic problem I'm going to close this now, as we are very late in RHEL-5. At least the early versions of RHEL-6 yum/yum-utils could be rebuilt on RHEL-5, so if any customer really needs this then that is a viable path.

Note You need to log in before you can comment on or make changes to this bug.