Bug 474856 - CPUScaling Fails in HTS 5.3-3.
CPUScaling Fails in HTS 5.3-3.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests) (Show other bugs)
5.3
All Linux
low Severity high
: ---
: ---
Assigned To: Greg Nichols
Lawrence Lim
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-05 11:44 EST by Ryan Armstrong
Modified: 2014-03-25 20:55 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-23 14:25:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of CPUScaling test failure. (1.94 KB, application/octet-stream)
2008-12-05 11:47 EST, Ryan Armstrong
no flags Details
cpuscaling.py patch for traceback (1.08 KB, patch)
2008-12-10 10:53 EST, Greg Nichols
no flags Details | Diff
cupscaling output.log for hts-5.3-12 (2.24 KB, text/x-log)
2009-01-02 01:08 EST, Yan Tian
no flags Details
cpuscaling.py patch for traceback on R12 (793 bytes, patch)
2009-01-06 11:37 EST, Greg Nichols
no flags Details | Diff
5.3-12 results (3.28 KB, application/octet-stream)
2009-01-13 09:59 EST, Gregg Shick
no flags Details
5.3-12 results adding cpu device manually (2.37 KB, application/octet-stream)
2009-01-13 10:01 EST, Gregg Shick
no flags Details
cupscaling output.log {2} for hts-5.3-12 (2.47 KB, text/x-log)
2009-01-19 03:21 EST, Yan Tian
no flags Details

  None (edit)
Description Ryan Armstrong 2008-12-05 11:44:56 EST
Description of problem: When adding the test manually, the test kit outputs the following message with a warning about an unknown device:

/var/hts
loaded results /var/hts/results.xml
OS Version: Red Hat Enterprise Linux Server release 5.3 Beta (Tikanga)
Kernel RPM: kernel-xen-2.6.18-123.el5
HTS version 5.3, release 3
OS Version: Red Hat Enterprise Linux Server release 5.3 Beta (Tikanga)
Kernel RPM: kernel-xen-2.6.18-123.el5
HTS version 5.3, release 3
Warning: unknown device: cpu 
Added test
saved test plan to /var/hts/results.xml

CPUscaling fails upon runnning the test.


Version-Release number of selected component (if applicable):HTS 5.3-3


How reproducible:


Steps to Reproduce:
1.  Manually add the CPUScaling test via the command <hts plan --add --test=cpuscaling --device=cpu>
2.  Note the warning about the unknown device.
3.  Run the test.
  
Actual results:  CPUScaling fails.  Output log of test has been attached.


Expected results:  CPUScaling should be added to the test plan without a warning, and should pass.


Additional info:
Comment 1 Ryan Armstrong 2008-12-05 11:47:41 EST
Created attachment 325876 [details]
Output of CPUScaling test failure.
Comment 2 Rob Landry 2008-12-05 11:56:27 EST
We should fix the traceback, however the error was caused by the scheduling of a test to a non-existent device.  Specifically no cpu number was provided, from the log it looks like the test should be scheduled for cpu0-7 (each with their own plan line).  I would also be curious why it didn't auto schedule on it's own, that should be caused by a failure of the system, kernel or HAL to identify itself, pickup a capability or report it, in all cases something should be fixed.
Comment 3 Greg Nichols 2008-12-10 10:53:59 EST
Created attachment 326522 [details]
cpuscaling.py patch for traceback
Comment 4 Mark Coskey 2008-12-15 18:03:09 EST
The invalid path sys/devices/system/cpu/cpucpu/ is also seen on the HTS-5.3-9.
Comment 5 Rob Landry 2008-12-16 10:11:30 EST
Can we get a copy of the plan output; as well the lshal output for the system?

From earlier, it appeared the test was scheduled incorrectly via the --add command to a non-existant cpu (eg. "cpu" does not exist, "cpu0", "cpu1"... "cpu7" are the correct devices the test should be scheduled against individually) which caused a traceback.  The traceback should be resolved, but the newer test suit would not address making "cpu" a valid device.

Most likely the need to schedule the test manually was cause by lshal not reporting the capabilities of the system correctly which would most likely come from either a kernel, hal or BIOS bug.  To verify this a quick look @ 'lshal | grep throttle' should reveal the case, if all throttle lines are reported as false then hts won't schedule the cpuscaling test as the system is reporting as it is not capable and a new bug should be opened.

Adding Ron and David to the cc: list so they are aware.
Comment 6 Yan Tian 2009-01-02 01:08:14 EST
Created attachment 328056 [details]
cupscaling output.log for hts-5.3-12
Comment 7 Yan Tian 2009-01-02 01:09:07 EST
Verified following things in hts-5.3-12:
- cpuscaling test was scheduled to separated with different device name(0,1,...).

- "hts run -t cpuscaling -v 0" passed without error

- "hts plan -a -t cpuscaling -v cpu" output:
...
Warning: unknown device: cpu
Added test
saved test plan to /var/hts/result.xml

- "hts run -t cpuscaling -v cpu" still failed, attached the output.log.

Re-opened this bug.
Comment 8 Greg Nichols 2009-01-06 11:37:02 EST
Created attachment 328293 [details]
cpuscaling.py patch for traceback on R12

Additional changes on the R12 baseline for tracebacks occuring when invalid --device options are used to add the cpuscaling test.
Comment 11 Gregg Shick 2009-01-13 09:59:05 EST
Created attachment 328865 [details]
5.3-12 results

Adding in cpuscaling results from 5.3-12.  

The cpuscaling test does not get added automatically during plan creation.

Running "hts plan --enable --test cpuscaling --device cpu" to add test to testplan.
Comment 12 Gregg Shick 2009-01-13 09:59:51 EST
Correction, the attachment added in comment 11 was adding the test to the plan without specifying a device.
Comment 13 Gregg Shick 2009-01-13 10:01:18 EST
Created attachment 328866 [details]
5.3-12 results adding cpu device manually

Log file for failing cpuscaling when adding --device cpu.
Comment 14 Greg Nichols 2009-01-13 10:49:13 EST
(In reply to comment #11)

> Running "hts plan --enable --test cpuscaling --device cpu" to add test to
> testplan.

The correct command to add the test for cpu0 would be:

hts plan --add --test cpuscaling --device 0
Comment 15 Yan Tian 2009-01-19 03:21:06 EST
Created attachment 329317 [details]
cupscaling output.log {2} for hts-5.3-12

Re-tested this bug as following steps:

- cpuscaling test was scheduled to separated with different device name(0,1)

- "hts run -t cpuscaling -v 0" passed without error

- "hts plan -a -t cpuscaling -v 2" output:
...
Added test
saved test plan to /var/hts/result.xml

- "hts run -t cpuscaling -v 2" still failed, attached the output.log.
Comment 16 Gregg Shick 2009-02-04 16:08:08 EST
Greg

So will I have to schedule a cpuscaling run for each core manually?
Comment 17 Gregg Shick 2009-02-04 18:57:49 EST
Greg

So will I have to schedule a cpuscaling run for each core manually?
Comment 18 Greg Nichols 2009-02-17 11:31:55 EST
Changing state back to POST - the patch is not yet committed.
Comment 19 Rob Landry 2009-07-16 13:54:34 EDT
Hey Gregg, 

Is this sorted, are we able to close this or is there something still pending here that we need to review?
Comment 20 Gregg Shick 2009-07-16 14:00:52 EDT
I think the original issue was in regards to not understanding the proper command to add the scaling test manually for proper execution.  Let me confirm on 5.4 with the latest kit if cpuscaling is automatically being scheduled or not.
Comment 21 Greg Nichols 2009-12-21 15:07:52 EST
The attached patch fixes a traceback that happens with the test is manually added incorrectly.
Comment 22 Greg Nichols 2010-01-12 11:45:19 EST
comitted patch fixing traceback.

Note You need to log in before you can comment on or make changes to this bug.