Bug 474869 - exim : Missing sub-package dependencies
exim : Missing sub-package dependencies
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: exim (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: David Woodhouse
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-05 12:19 EST by Michael Schwendt
Modified: 2009-05-23 04:15 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-23 04:15:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2008-12-05 12:19:46 EST
Turns out that fixing the unowned directories
in exim-mysql and exim-pgsql would need fixed Requires
in those two packages:

=> exim-mysql-4.69-8.fc11.i386 (rawhide-development-i386)
/usr/lib/exim
    provided by: exim-4.69-8.fc11.i386
/usr/lib/exim/4.69-8.fc11
    provided by: exim-4.69-8.fc11.i386
/usr/lib/exim/4.69-8.fc11/lookups
    provided by: exim-4.69-8.fc11.i386

=> exim-pgsql-4.69-8.fc11.i386 (rawhide-development-i386)
/usr/lib/exim
    provided by: exim-4.69-8.fc11.i386
/usr/lib/exim/4.69-8.fc11
    provided by: exim-4.69-8.fc11.i386
/usr/lib/exim/4.69-8.fc11/lookups
    provided by: exim-4.69-8.fc11.i386


In other words, both exim-mysql and exim-pgsql should

  Requires: exim

It doesn't become clear why they don't.
Comment 1 Michael Schwendt 2008-12-05 12:22:34 EST
> %files mysql
> %{_libdir}/exim/%{version}-%{release}/lookups/mysql.so

> %files pgsql
> %{_libdir}/exim/%{version}-%{release}/lookups/pgsql.so

> %files greylist
> %config %{_sysconfdir}/exim/exim-greylist.conf.inc

%defattr is missing here, btw.
Comment 2 Michael Schwendt 2009-05-23 04:15:26 EDT
Fix committed to devel (F12).

Note You need to log in before you can comment on or make changes to this bug.