Bug 474889 - error in script for yum
error in script for yum
Status: CLOSED DUPLICATE of bug 473239
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
10
i686 Linux
low Severity high
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-05 14:43 EST by alauschke
Modified: 2014-01-21 18:07 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-05 15:01:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description alauschke 2008-12-05 14:43:20 EST
Description of problem:
Using the latest version of yum on F10, I get several errors, and finally:

AttributeError: 'list' object has no attribute 'replace'

Version-Release number of selected component (if applicable):


How reproducible:
Take a new F10 after preupgrade and run yum update as root.

I cannot say that this is related to the fact that I used preupgrade. I cannot say that this is related to the fact that it was the attempt to use yum update after I upgraded to F10. I am new to Fedora, so I'd rather be a bit more detailed, without implying that preupgrade or the fact that it was the first yum update after preupgrade caused this. But, I've had a lot of issues with preupgrade including the F8->F9 preupgrade, so I wanted to mention it.

Steps to Reproduce:
1.
2.
3.
  
Actual results:
[root@localhost ~]# yum update
Loaded plugins: fastestmirror, fedorakmod, kernel-module, refresh-packagekit
Loading mirror speeds from cached hostfile
* livna: rpm.livna.org
* fedora: chi-10g-1-mirror.fastsoft.net
* rpmfusion-free-updates: mirror.liberty.edu
* rpmfusion-nonfree-updates: mirror.liberty.edu
* rpmfusion-free: mirror.liberty.edu
* rpmfusion-nonfree: mirror.liberty.edu
* updates: chi-10g-1-mirror.fastsoft.net
Setting up Update Process
Resolving Dependencies
Traceback (most recent call last):
File "/usr/bin/yum", line 29, in <module>
yummain.user_main(sys.argv[1:], exit_code=True)
File "/usr/share/yum-cli/yummain.py", line 229, in user_main
errcode = main(args)
File "/usr/share/yum-cli/yummain.py", line 145, in main
(result, resultmsgs) = base.buildTransaction()
File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 646, in buildTransaction
self.plugins.run('preresolve')
File "/usr/lib/python2.5/site-packages/yum/plugins.py", line 176, in run
func(conduitcls(self, self.base, conf, **kwargs))
File "/usr/lib/yum-plugins/kernel-module.py", line 60, in preresolve_hook
instpkgs = conduit.getRpmDB().returnPackages()
File "/usr/lib/python2.5/site-packages/yum/rpmsack.py", line 297, in returnPackages
self._makePackageObject(hdr, idx)
File "/usr/lib/python2.5/site-packages/yum/rpmsack.py", line 430, in _makePackageObject
po = RPMInstalledPackage(hdr, index, self)
File "/usr/lib/python2.5/site-packages/yum/rpmsack.py", line 37, in __init__
YumInstalledPackage.__init__(self, rpmhdr)
File "/usr/lib/python2.5/site-packages/yum/packages.py", line 1205, in __init__
YumHeaderPackage.__init__(self, fakerepo, hdr)
File "/usr/lib/python2.5/site-packages/yum/packages.py", line 981, in __init__
self.summary = misc.share_data(self.hdr['summary'].replace('\n', ''))
AttributeError: 'list' object has no attribute 'replace'


Expected results:

a successful processing of yum update without error messages! (:-))

Additional info:

a very senior programmer at RedHat gave me the following workaround that caused it to go through:

change line 981 in 

/usr/lib/python2.5/site-packages/yum/packages.py 

to 

import string
self.summary = misc.share_data(string.join(self.hdr['summary']).replace('\n', ''))

and it worked (note the two important elements here: import string on a separate line above, and string.join(...) wrapping the self.hdr statement).

Then I still had issues:

[root@localhost ~]# yum update
Loaded plugins: fastestmirror, fedorakmod, kernel-module, refresh-packagekit
Loading mirror speeds from cached hostfile
* livna: rpm.livna.org
* fedora: chi-10g-1-mirror.fastsoft.net
* rpmfusion-free-updates: mirror.liberty.edu
* rpmfusion-nonfree-updates: mirror.liberty.edu
* rpmfusion-free: mirror.liberty.edu
* rpmfusion-nonfree: mirror.liberty.edu
* updates: chi-10g-1-mirror.fastsoft.net
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package kdegraphics-libs.i386 7:4.1.3-2.fc10 set to be updated
---> Package exiv2-libs.i386 0:0.17.1-1.fc10 set to be updated
---> Package kdegraphics.i386 7:4.1.3-2.fc10 set to be updated
--> Processing Dependency: libexiv2.so.2 for package: libkexiv2
--> Finished Dependency Resolution
libkexiv2-0.1.7-1.fc9.i386 from installed has depsolving problems
--> Missing Dependency: libexiv2.so.2 is needed by package libkexiv2-0.1.7-1.fc9.i386 (installed)
Error: Missing Dependency: libexiv2.so.2 is needed by package libkexiv2-0.1.7-1.fc9.i386 (installed)

but 

# rpm -e libkexiv2 --nodeps

took care of it.
Comment 1 James Antill 2008-12-05 15:01:56 EST

*** This bug has been marked as a duplicate of bug 473239 ***
Comment 2 James Antill 2008-12-05 15:04:15 EST
For libkexiv2 you want to log that as a seperate bug against that pkg, and you probably want to run "package-cleanup --problems"

Note You need to log in before you can comment on or make changes to this bug.