Bug 474905 - QMF Plugins hang when deleting ManagementAgent
QMF Plugins hang when deleting ManagementAgent
Status: CLOSED ERRATA
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: grid (Show other bugs)
1.0
All Linux
medium Severity high
: 1.1
: ---
Assigned To: Matthew Farrellee
Jeff Needle
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-05 16:18 EST by Matthew Farrellee
Modified: 2009-02-04 11:05 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-04 11:05:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Farrellee 2008-12-05 16:18:36 EST
The QMF Plugins hang on shutdown when they are deleting the ManagementAgent::Singleton.

The current workaround for this is a QMF_DELETE_ON_SHUTDOWN option, which defaults to false.

This is primarily seen on RHEL4 systems.

Reproduce by running the condor_master connected to a qpidd broker:

env _CONDOR_MASTER.DAEMON_LIST=MASTER _CONDOR_MASTER_INSTANCE_LOCK=none _CONDOR_MASTER.DEBUG=D_FULLDEBUG _CONDOR_QMF_DELETE_ON_SHUTDOWN=TRUE QMF_DEBUG_LEVEL=5 _CONDOR_MASTER.PLUGINS=/usr/lib[64?]/condor/plugins/MgmtMasterPlugin-plugin.so _CONDOR_QMF_BROKER=north-15 condor_master -t -f

kill the condor_master, and see:

MgmtMasterPlugin: shutting down...
...deleting ManagementAgent
QMF Agent connection has been lost

Success looks like:

All daemons are gone.  Exiting.
MgmtMasterPlugin: shutting down...
...deleting ManagementAgent
QMF Agent connection has been lost
...deleted ManagementAgent
**** condor_master (condor_MASTER) pid <PID> EXITING WITH STATUS 0

This failure does not happen consistently!
Comment 1 Matthew Farrellee 2008-12-08 14:53:11 EST
This appears to be resolved in 7.2.0-0.8 with the qpid-boost fix
Comment 3 Jeff Needle 2008-12-18 08:30:41 EST
I wasn't able to reliably reproduce this before, but haven't seen it with recent builds, so moving to VERIFIED.
Comment 5 errata-xmlrpc 2009-02-04 11:05:49 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0036.html

Note You need to log in before you can comment on or make changes to this bug.