Bug 474931 - We should probably stop encouraging edits to the global condor_config file
We should probably stop encouraging edits to the global condor_config file
Status: CLOSED ERRATA
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: grid (Show other bugs)
1.0
All Linux
medium Severity medium
: 1.1
: ---
Assigned To: Matthew Farrellee
Jeff Needle
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-05 17:05 EST by Jeff Needle
Modified: 2009-02-04 11:05 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-04 11:05:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Needle 2008-12-05 17:05:24 EST
We try to discourage users from changing /etc/condor/condor_config and instead make changes to ~condor/condor_config.local or .overrides.  But we don't really strongly discourage it.  For instance, we tell them in the header of the file:

##  The file is divided into four main parts:
##  Part 1:  Settings you MUST customize
##  Part 2:  Settings you may want to customize
##  Part 3:  Settings that control the policy of when condor will
##           start and stop jobs on your machines
##  Part 4:  Settings you should probably leave alone (unless you
##  know what you're doing)

That sends a rather different message.

We should decide how much we want to discourage edits to the global file and find a solution ranging from clearer wording in the header to chmod'ing it so it's not writeable all the way up to possibly setting the immutable bit (chattr +i), although I don't know if the latter is standard practice.
Comment 1 Matthew Farrellee 2008-12-08 23:37:17 EST
Below is the change found in 7.2.0-0.9


diff --git a/src/condor_examples/condor_config.generic b/src/condor_examples/con
index 83055cf..8be9ef7 100644
--- a/src/condor_examples/condor_config.generic
+++ b/src/condor_examples/condor_config.generic
@@ -1,15 +1,35 @@
 ######################################################################
+######################################################################
+##                                                                  ##
+##  N O T I C E:                                                    ##
+##                                                                  ##
+##       Customization of this file should be done via the          ##
+##       LOCAL_CONFIG_FILE.                                         ##
+##                                                                  ##
+######################################################################
+######################################################################
+
+
+######################################################################
 ##
 ##  condor_config
 ##
 ##  This is the global configuration file for condor.  Any settings
-##  made here may potentially be overridden in the local configuration
-##  file.  KEEP THAT IN MIND!  To double-check that a variable is
-##  getting set from the configuration file that you expect, use
-##  condor_config_val -v <variable name>
+##  found here * * s h o u l d   b e   c u s t o m i z e d   i n
+##  t h e   l o c a l   c o n f i g u r a t i o n   f i l e. * *
+##
+##  The local configuration file is specified by LOCAL_CONFIG_FILE
+##  below.
+##
+##  For a basic configuration, you may only want to start by
+##  customizing CONDOR_ADMIN.
+##
+##  Note: To double-check where a configuration variable is set from
+##  you can use condor_config_val -v <variable name>,
+##  e.g. condor_config_val -v CONDOR_ADMIN.
 ##
 ##  The file is divided into four main parts:
-##  Part 1:  Settings you MUST customize 
+##  Part 1:  Settings you likely want to customize 
 ##  Part 2:  Settings you may want to customize
 ##  Part 3:  Settings that control the policy of when condor will
 ##           start and stop jobs on your machines
@@ -47,7 +67,7 @@
 ##  #        #    #  #   #      #              #
 ##  #        #    #  #    #     #            #####
 ##
-##  Part 1:  Settings you must customize:
+##  Part 1:  Settings you likely want to customize:
 ######################################################################
 ######################################################################
Comment 3 Jeff Needle 2008-12-18 08:44:07 EST
We've at least moved away from the word MUST, but the way we have things configured, we probably want to move to words that completely discourage editing /etc/condor/condor_config in favor of the local files.  This is good enough for 1.1, I guess.  Why are we suggesting setting CONDOR_ADMIN in this file and not in ~condor/condor_config.local or .overrides?
Comment 4 Matthew Farrellee 2008-12-18 08:52:05 EST
"Any settings found here should be customized in the local configuration file. ...you may want to start by customizing CONDOR_ADMIN [in that local configuration file]."

"in that local configuration file" seems maybe excessive
Comment 5 Jeff Needle 2008-12-18 09:05:32 EST
OK, I didn't read it that way, but I'll buy that.  I read it as "The only thing you need to customize in this file {that you are obviously in right now with an editor because you are reading this} is CONDOR_ADMIN.

Moving to VERIFIED.
Comment 7 errata-xmlrpc 2009-02-04 11:05:51 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0036.html

Note You need to log in before you can comment on or make changes to this bug.