Bug 475011 - rawstudio is missing a library
rawstudio is missing a library
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: rawstudio (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Gianluca Sforna
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-06 12:20 EST by Linuxguy123
Modified: 2008-12-06 13:34 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-06 13:34:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Linuxguy123 2008-12-06 12:20:40 EST
Description of problem:

rawstudio won't start because its missing a library file, libexiv2.so

Version-Release number of selected component (if applicable):

$ rawstudio
rawstudio: error while loading shared libraries: libexiv2.so.0: cannot
open shared object file: No such file or directory

$yum list rawstudio
Loaded plugins: downloadonly, kmdl, priorities, refresh-packagekit
0 packages excluded due to repository priority protections
Available Packages
rawstudio.i386                                                           1.1.1-1.fc10                                                           fedora

$ yum list exiv*
Loaded plugins: downloadonly, kmdl, priorities, refresh-packagekit
0 packages excluded due to repository priority protections
Installed Packages
exiv2.i386
0.17.1-1.fc10
installed
exiv2-devel.i386
0.17.1-1.fc10
installed
exiv2-libs.i386
0.17.1-1.fc10
installed

How reproducible:

Every time.

Steps to Reproduce:
1.  Install F10.
2. yum install rawstudio
3. $rawstudio
  
Actual results:
rawstudio: error while loading shared libraries: libexiv2.so.0: cannot
open shared object file: No such file or directory


Expected results:
It should run.

Additional info:
This problem seems to be fixed by renaming /usr/lib/libexiv2.so to libexiv2.so.0 .
Comment 1 Linuxguy123 2008-12-06 13:34:35 EST
MY BAD.

I forgot I had downloaded rawstudio source and built it myself.  I uninstalled my version, installed the F10 version and everything works fine. 

Sorry for the confusion and wasted bandwidth.

Note You need to log in before you can comment on or make changes to this bug.