This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 475045 - mkiss does not work with ptmx pseudo-terminals
mkiss does not work with ptmx pseudo-terminals
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: ax25-tools (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Sindre Pedersen Bjørdal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-06 19:40 EST by Thomas Sailer
Modified: 2008-12-21 03:39 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-19 06:33:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
make mkiss work with Unix98 style ptmx (1.08 KB, patch)
2008-12-06 19:42 EST, Thomas Sailer
no flags Details | Diff

  None (edit)
Description Thomas Sailer 2008-12-06 19:40:31 EST
Description of problem:
The standard usage of the mkiss KISS multiplexer is to attach the multipexed side to a real serial interface and the demultiplexed streams to pty/tty pairs:
mkiss -s 19200 /dev/ttyS0 /dev/ptyp0 /dev/ptyp1

Now Fedora does not support BSD style pseudo-terminals anymore, only Unix98 style pseudoterminals are supported. Running mkiss with:
mkiss -s 19200 /dev/ttyS0 /dev/ptmx /dev/ptmx
creates the slave devices /dev/pts/1 and /dev/pts/2, they are however not usable (opening them returns EIO on both the slave and the master side), because they are not unlocked. unlockpt needs to be called on the master filedescriptor.

I used the attached patch to work around the problem

Version-Release number of selected component (if applicable):
ax25-tools-0.0.8-2.fc9.i386

How reproducible:
always

Steps to Reproduce:
see above
Comment 1 Thomas Sailer 2008-12-06 19:42:25 EST
Created attachment 326025 [details]
make mkiss work with Unix98 style ptmx
Comment 2 Fedora Update System 2008-12-11 02:19:53 EST
ax25-tools-0.0.8-3.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/ax25-tools-0.0.8-3.fc10
Comment 3 Fedora Update System 2008-12-11 02:45:30 EST
ax25-tools-0.0.8-3.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/ax25-tools-0.0.8-3.fc9
Comment 4 Robert 'Bob' Jensen 2008-12-11 04:45:37 EST
Please test the packages in updates-testing
Comment 5 Fedora Update System 2008-12-13 09:56:55 EST
ax25-tools-0.0.8-3.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update ax25-tools'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-11204
Comment 6 Fedora Update System 2008-12-13 09:58:02 EST
ax25-tools-0.0.8-3.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ax25-tools'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2008-11209
Comment 7 Fedora Update System 2008-12-21 03:23:24 EST
ax25-tools-0.0.8-3.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2008-12-21 03:39:12 EST
ax25-tools-0.0.8-3.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.