Bug 475046 - Installer hangs PK if new package installed while "Run new app?" open
Installer hangs PK if new package installed while "Run new app?" open
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-packagekit (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
: 467133 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-06 20:07 EST by Patrick Walton
Modified: 2009-01-14 08:48 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-14 08:48:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
what's in git (2.48 KB, patch)
2008-12-07 12:48 EST, Richard Hughes
no flags Details | Diff

  None (edit)
Description Patrick Walton 2008-12-06 20:07:39 EST
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.4) Gecko/2008111217 Fedora/3.0.4-1.fc10 Firefox/3.0.4

"Add/Remove Software" causes PackageKit to hang if a new package is installed while the "Run New Application" dialog box is open. The "Run New Application" dialog box is not modal, so a user can get back to the installer and install a new app. This causes PK to hang on "Waiting for other tasks". Additionally, the "Run New Application" dialog freezes up.

Reproducible: Always

Steps to Reproduce:
1. Install a package that will trigger the "Run new application?" dialog box (e.g. wine).
2. When the "Run New Application?" dialog box appears, activate the "Add/Remove Software" window and install something else (e.g. nethack).

Actual Results:  
A hang occurs. Closing the "Waiting for other tasks" window does not resolve the hang. The buttons on the "Run New Application" window are frozen; the only thing that can be done is to close that window via the title bar (which still results in a hang).

Expected Results:  
The package should install as expected. The "Run New Application" dialog box to continue working even during installation of other software.
Comment 1 Richard Hughes 2008-12-07 12:48:05 EST
Created attachment 326048 [details]
what's in git

I've applied the following patch upstream.
Comment 2 Richard Hughes 2009-01-14 08:44:17 EST
*** Bug 467133 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.