Bug 475064 - gnome-terminal-2.24.2-2.fc10 captures alt-1, alt-2 and so on
gnome-terminal-2.24.2-2.fc10 captures alt-1, alt-2 and so on
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-terminal (Show other bugs)
10
All Linux
low Severity high
: ---
: ---
Assigned To: Behdad Esfahbod
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-07 02:54 EST by Leszek Matok
Modified: 2009-01-14 22:02 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-14 22:02:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 562834 None None None Never

  None (edit)
Description Leszek Matok 2008-12-07 02:54:24 EST
The new gnome-terminal-2.24.2-2.fc10 includes a new tab-switching.patch (version in gnome-terminal-2.24.1-2.fc10 was much smaller and only added labels to gconf keys). It looks like now it adds shortcuts which aren't there by default (at all - were they removed and replaced by some other mechanism?).

The problem is that now I can't disable alt-number combinations to switch tabs!

There's NO WAY to disable it using the UI. After inspecting the SRPM I figure out it can be done with gconf magic, but it's not like an ordinary user can ever come up with this workaround...

Please, please fix it for people who need to pass shortcuts like alt-2 to console apps. You don't expect people to switch to using esc 2, do you?

As this is a regression caused by Fedora-specific patch, I've even added high priority to the bug. Please fix!

Oh, and to work around the issue, I've simply downgraded to 2.24.1-2.fc10, which works like expected.
Comment 1 Ignacio Vazquez-Abrams 2008-12-07 03:03:59 EST
This behavior has been in gnome-terminal since at least FC5 (see bug 467972 and bug 468121). How is it only a problem now?
Comment 2 Leszek Matok 2008-12-07 03:45:15 EST
I've never had to deal with it. It was always optional and disabled. I haven't visited the shortcut settings window for years now (and this is an upgraded system).

For F10's gnome-terminal, there's no option in the UI to set "switch to tab" shortcut at all. It will be a problem for people from mentioned bugs, but isn't a problem for me. It became a problem when my own settings were changed to the opposite with no way to go back.

It's a problem because:
- it suddenly changed my shortcuts by itself in a stable release (actually, I've installed from updates-testing yesterday, but it got pushed to stable),
- it overrides my own settings,
- it can't even be disabled!

Even if you really want to break my work flow and system, please do it in Rawhide for the next release, not as an update to a released version!

BTW, looking at the bugs you've mentioned, it looks like other people's gnome-terminals were not broken for them in 2.24.1-2, just as it isn't broken for me.

And whatever happened to the "upstream everything" mantra?
Comment 3 Lauri Nurmi 2008-12-13 11:04:13 EST
I can confirm the that latest update 2.24.2-2.fc10 prevents me from switching windows in irssi, and there's nothing I can do about it through the GUI.

I have been using Fedora since FC1 (and RH Linux since 4.2), and while it has been necessary to manually disable gnome-terminal's own Alt-number shortcuts initially, never before have they suddenly become automatically re-enabled.  And let me repeat: This time there is nothing I can do about it through GUI.

This bug should have the Regression keyword set.
Comment 4 Leszek Matok 2008-12-22 16:06:37 EST
It's not just irssi.

I use marks in joe (which then can be accessed with alt-1, alt-2 and so on).

I had a remote machine which didn't accept F1-F10, but f.e. mc allows me to easily emulate this with alt-1...alt-0.

And don't forget alt-number in any shell, the easiest way to echo 1000 "A"s :)
Comment 5 Leszek Matok 2009-01-01 16:43:30 EST
...and it can't be changed using gconf-editor/gconftool-2, either. Seems that it's hardcoded now.

There's this patch in the bug referenced by Lauri (GNOME bug #564283), it does much more besides adding gconf schema which is ignored anyhow. After rebuilding the srpm with this patch, everything is back to normal. Curiously, at least the Polish translation (for the GUI editor part) is still in place, guess the .po's are untouched from 2.22.

BTW. in current srpm, the patch is named "tab-switching.patch", it was hard to find in my big source dir. Should be "gnome-terminal-something", right?

Matthias, could you please comment (or even better: act)?
Comment 6 Fedora Update System 2009-01-01 20:04:51 EST
gnome-terminal-2.24.2-3.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/gnome-terminal-2.24.2-3.fc10
Comment 7 Fedora Update System 2009-01-07 04:11:56 EST
gnome-terminal-2.24.2-3.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gnome-terminal'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-0055
Comment 8 Fedora Update System 2009-01-14 22:02:03 EST
gnome-terminal-2.24.2-3.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.