Bug 475076 - Netbeans not launching external browser firefox
Netbeans not launching external browser firefox
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: netbeans (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Victor G. Vasilyev
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-07 09:23 EST by Richard Chan
Modified: 2008-12-09 09:40 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-09 09:40:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Chan 2008-12-07 09:23:45 EST
Description of problem:
Netbeans is not launching an external browser(firefox) in response to
Help->Start Page or Help->Register menu items.

Version-Release number of selected component (if applicable):
netbeans-platform8-6.1-5.fc10.noarch
netbeans-resolver-6.1-5.fc10.noarch
netbeans-platform8-harness-6.1-5.fc10.noarch
netbeans-java2-6.1-9.fc10.noarch
netbeans-6.1-9.fc10.noarch
netbeans-svnclientadapter-6.1-3.fc10.noarch
netbeans-apisupport1-6.1-9.fc10.noarch
netbeans-javaparser-6.1-2.fc10.noarch
netbeans-ide9-6.1-9.fc10.noarch

How reproducible:
Always

Steps to Reproduce:
1. Start netbeans
2. Select menu item: Help->Register
3.
  
In preferences, the browser setting is /usr/bin/firefox -remote "openURL({URL})"

Actual results:
Nothing happens

Expected results:
netbeans will open external browser window to the registration page.


Additional info:
Comment 1 Richard Chan 2008-12-07 09:30:06 EST
The following menu items works - though - 
Help->Online Docs and Support

successfully creates a new tab (existing firefox process) to 
http://www.netbeans.org/kb/index.html

Ignore the comment about Help->Start Page in the original bug report.
Comment 2 Victor G. Vasilyev 2008-12-07 19:34:00 EST
Hello Richard,

Please, use the link https://inventory.sun.com/RegistrationWeb/nb/default/en_US/register-login.jsp
in your browser as a workaround to obtain info about registration of your NetBeans IDE.

It seems the release netbeans-6.1-9.fc10 (where Bug #467546 has been fixed) doesn't resolve the problem "Help->Register" described by you :-(
I'll investigate the issue with start of browser more carefully...
Comment 3 Victor G. Vasilyev 2008-12-09 04:56:04 EST
Richard,

I can't repeat the bug. A click on the menu item Help/Register always opens the registration page in the Mozilla Firefox (3.0.2-1.fc10) for me.

Could you please, provide more details about a configuration where the bug occurs.
Is it possible to open the registration page manually via Mozilla Firefox on your Fedora box?
Comment 4 Richard Chan 2008-12-09 08:30:36 EST
Problem solved. Sorry.

My userid had a bad https url handler in gconf-editor. This was a legacy issue from my Fedora 8 desktop as I had a 32-bit parallel install of firefox which no longer worked under Fedora 10.

When I reset all the different mime handlers using gconf-editor back to the default 'firefix %s' Netbeans was able to launch everything.
Comment 5 Victor G. Vasilyev 2008-12-09 09:40:26 EST
It is a good news that a cause of the issue is not the NetBeans software.
 
No problem. It was occasion to double check my solution in this complex area (launch of the linux native applications from inside Java).

I'll close this with the resolution NOTABUG, but, please, feel free to reopen it if you will find something wrong.

Note You need to log in before you can comment on or make changes to this bug.