Bug 475088 - selinux prevents awstats from running
selinux prevents awstats from running
Status: CLOSED DUPLICATE of bug 474504
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-07 11:53 EST by William Lovaton
Modified: 2008-12-07 12:03 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-07 12:03:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description William Lovaton 2008-12-07 11:53:16 EST
Description of problem:
I installed awstats to get nice stats from my web server but SELinux is denying access to some objects

Version-Release number of selected component (if applicable):
selinux-policy-targeted-3.5.13-26.fc10.noarch
libselinux-2.0.73-1.fc10.i386
libselinux-python-2.0.73-1.fc10.i386
libselinux-utils-2.0.73-1.fc10.i386
selinux-policy-3.5.13-26.fc10.noarch

awstats-6.8-2.fc10.noarch


I get the following raw messages:

node=xps420 type=AVC msg=audit(1228593661.223:118): avc: denied { read } for pid=8362 comm="awstats_updatea" path="inotify" dev=inotifyfs ino=1 scontext=system_u:system_r:awstats_t:s0-s0:c0.c1023 tcontext=system_u:object_r:inotifyfs_t:s0 tclass=dir

node=xps420 type=SYSCALL msg=audit(1228593661.223:118): arch=40000003 syscall=11 success=yes exit=0 a0=9b9fcf0 a1=9b9f9a8 a2=9b9e9b0 a3=0 items=0 ppid=8358 pid=8362 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=14 comm="awstats_updatea" exe="/usr/bin/perl" subj=system_u:system_r:awstats_t:s0-s0:c0.c1023 key=(null) 


AND


node=xps420 type=AVC msg=audit(1228665662.18:50): avc: denied { read } for pid=4305 comm="awstats_updatea" path="inotify" dev=inotifyfs ino=1 scontext=system_u:system_r:awstats_t:s0-s0:c0.c1023 tcontext=system_u:object_r:inotifyfs_t:s0 tclass=dir

node=xps420 type=SYSCALL msg=audit(1228665662.18:50): arch=40000003 syscall=11 success=yes exit=0 a0=8e2ccf0 a1=8e2c9a8 a2=8e2b9b0 a3=0 items=0 ppid=4300 pid=4305 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=5 comm="awstats_updatea" exe="/usr/bin/perl" subj=system_u:system_r:awstats_t:s0-s0:c0.c1023 key=(null)
Comment 1 William Lovaton 2008-12-07 12:03:13 EST
Damn! I searched before posting but I didn't see it was already reported.

*** This bug has been marked as a duplicate of bug 474504 ***

Note You need to log in before you can comment on or make changes to this bug.