Bug 475089 - plughw fails to initialize Alesis io|2 USB soundcard for PulseAudio
plughw fails to initialize Alesis io|2 USB soundcard for PulseAudio
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
10
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-07 12:03 EST by Mark Knoop
Modified: 2009-06-29 07:14 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-29 07:14:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
excerpt from /var/log/messages (2.18 KB, text/plain)
2008-12-07 12:03 EST, Mark Knoop
no flags Details

  None (edit)
Description Mark Knoop 2008-12-07 12:03:16 EST
Created attachment 326046 [details]
excerpt from /var/log/messages

Description of problem:
Initilization fails on usb soundcard Alesis io|2 (ID 13b2:0008).

Version-Release number of selected component (if applicable):
pulseaudio-0.9.13-6.fc10.x86_64
alsa-utils-1.0.18-6.fc10.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Plug in usb soundcard.
2. Notice it does not appear in pulseaudio's list of output devices.
3. Look in the logs to find pulseaudio error messages (see attachment).

Additional info:
Soundcard worked without problems under pulseaudio in Fedora 8. Works without problems with jackd in Fedora 10. 

See attachment for excerpt from /var/log/messages for both Fedora 8 (working) and 10 (not working).
Comment 1 Lennart Poettering 2008-12-08 13:38:31 EST
Looks like an issue in ALSA. plughw cannot be configured to the sampling parameters PA wants. plughw is supposed to convert between all parameters if necessary. If that doesn't work, than it doesn't fulfill its purpose and is broken.

The requirements of PA are pretty conservative when configuring the hw parameters. Most likely this is some issue with the mmap/nommap handling inside plughw.
Comment 2 Mark Knoop 2008-12-09 04:01:41 EST
Thanks Lennart. My current workaround is to run jackd and load module-jack-sink in my default.pa. I'll try to investigate what has changed in ALSA between 1.0.16 and 1.0.18.
Comment 3 Lennart Poettering 2008-12-23 12:14:27 EST
Revisiting this I came to the conclusion that this is actually not a but in alsa-lib but a limitation of PA. I have now fixed this in PA upstream and will shortly commit a fixed version onto F10/rawhide.
Comment 4 Mark Knoop 2009-02-27 06:08:11 EST
Was this fix in the recent pulseaudio-0.9.14-1.fc10 update? If so, it didn't work, although the error message has changed slightly. I now get this from pulseaudio -v

I: alsa-util.c: PCM device plug:front:1 refused our hw parameters: No such file or directory
I: alsa-util.c: PCM device plug:surround40:1 refused our hw parameters: Invalid argument
I: (alsa-lib)pcm_params.c: Slave PCM not usable
I: (alsa-lib)pcm_params.c: Slave PCM not usable
I: alsa-util.c: PCM device plug:surround41:1 refused our hw parameters: Invalid argument
I: (alsa-lib)pcm_params.c: Slave PCM not usable
I: (alsa-lib)pcm_params.c: Slave PCM not usable
I: alsa-util.c: PCM device plug:surround50:1 refused our hw parameters: Invalid argument
I: (alsa-lib)pcm_params.c: Slave PCM not usable
I: (alsa-lib)pcm_params.c: Slave PCM not usable
I: alsa-util.c: PCM device plug:surround51:1 refused our hw parameters: Invalid argument
I: (alsa-lib)pcm_params.c: Slave PCM not usable
I: (alsa-lib)pcm_params.c: Slave PCM not usable
I: alsa-util.c: PCM device plug:surround71:1 refused our hw parameters: Invalid argument
E: alsa-util.c: Failed to set hardware parameters on plug:hw:1: No such file or directory
E: module.c: Failed to load  module "module-alsa-sink" (argument: "device_id=1 sink_name=alsa_output.usb_device_13b2_8_noserial_if0_sound_card_0_alsa_playback_0 tsched=1"): initialization failed.

Let me know what you need to debug this.
Comment 5 Chris Shoemaker 2009-06-01 16:14:39 EDT
Last report is that updated PulseAudio did not fix this bug.  Is that still true?

Lennart, is Comment #4 consistent with this bug actually being closed?

BTW, I also get lots of:
I: alsa-util.c: Failed to set hardware parameters on plug:hw:1: Invalid argument
I: alsa-util.c: Failed to set hardware parameters on plug:hw:1: Invalid argument

with usb audio and pulseaudio-0.9.15-11.fc11.x86_64.

I'd open a new bug, but it seems pretty close to this one... please advise.
Comment 6 Mark Knoop 2009-06-02 04:46:03 EDT
With current pulseaudio-0.9.14-3.fc10.x86_64, I'm still getting the errors in Comment #4. Chris, are you also using the Alesis io|2?
Comment 7 Chris Shoemaker 2009-06-02 14:17:57 EDT
No, I don't have Alesis - I have another USB soundcard, though.  It's a GWC AA1500.  In case it matters, I'm using alsa-lib-1.0.20-1.fc11.x86_64.
Comment 8 Lennart Poettering 2009-06-29 07:14:40 EDT
The version of PA in F11 now (-14) does now explain which part of the initialization exactly fails, if it fails.

Note You need to log in before you can comment on or make changes to this bug.