Bug 475108 - HP 2133's VIA Chrome9 HC IGP (rev 01) doesn't work with 1280x720 any longer
HP 2133's VIA Chrome9 HC IGP (rev 01) doesn't work with 1280x720 any longer
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-openchrome (Show other bugs)
10
All Linux
low Severity high
: ---
: ---
Assigned To: Xavier Bachelot
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-07 16:45 EST by Robert Scheck
Modified: 2009-09-04 08:35 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-04 08:35:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.log-fc10 (45.38 KB, text/plain)
2008-12-15 05:15 EST, Markus Espenhain
no flags Details
Xorg.0.log with openchrome from FC9 (83.07 KB, text/plain)
2008-12-15 07:02 EST, Markus Espenhain
no flags Details
xorg.conf (1.07 KB, text/plain)
2008-12-15 07:04 EST, Markus Espenhain
no flags Details
Video with the strange effect visible (726.83 KB, video/mp4)
2009-01-12 07:29 EST, Robert Scheck
no flags Details
Xorg.0.log when no xorg.configuration file was supplied (auto configuration) (47.96 KB, text/plain)
2009-04-02 07:38 EDT, Robert Scheck
no flags Details
Xorg.0.log when no xorg.configuration file was supplied (auto configuration) (47.94 KB, text/plain)
2009-04-02 07:42 EDT, Robert Scheck
no flags Details
Xorg.0.log with xorg.conf (so correct resolution) but strange ream-effects same as before (45.00 KB, text/plain)
2009-04-02 07:45 EDT, Robert Scheck
no flags Details
Another Xorg.0.log with xorg.conf (so correct resolution) but strange ream-effects same as before and having all xorg.conf options from comments above enabled (45.43 KB, text/plain)
2009-04-02 07:46 EDT, Robert Scheck
no flags Details

  None (edit)
Description Robert Scheck 2008-12-07 16:45:15 EST
Description of problem:
Colleague has a HP 2133 netbook which has a VIA Chrome9 HC IGP (rev 01) 
graphics card. After installing Fedora 9 with all updates, the resolution
1280x768 works - package is "xorg-x11-drv-openchrome-0.2.903-1.fc9". When
now updating to Fedora 10 and keeping the old xorg.conf, the cursor (mouse
symbol) does no longer work and the maximum working resolution is 1024x768 
independent of what is configured in xorg.conf. Even when putting another
resolution into xorg.conf, max 1024x768 instead of widescreen is used. Now
when downgrading to the .fc9 package, it works again - even in Fedora 10

What me personally confuses is, that Fedora 9 and Fedora 10 have the same
version of the opencrome xorg driver - but is there really the same binary
stuff under the head? I don't think so because of the different results. Or
did we maybe run into a GCC issue again as years ago with other xorg stuff?

My colleague is added in Cc: so that he can gather needed information or if
testing of something is needed in order to solve this issue...

Version-Release number of selected component (if applicable):
xorg-x11-drv-openchrome-0.2.903-1.fc10

How reproducible:
Everytime, just see above.

Actual results:
HP 2133's VIA Chrome9 HC IGP (rev 01) doesn't work with 1280x768 any longer;
always just 1024x768, but xorg openchrome driver from Fedora 9 makes all the
stuff working on Fedora 10.

Expected results:
Working 1280x768 resolution with Fedora 10 xorg openchrome driver same way
as on Fedora 9.

Additional info:
xorg.conf:
[...]
Section "Device"
        Identifier  "Videocard0"
        Driver      "openchrome"
        Option      "AccelMethod" "EXA"
        Option      "ExaNoComposite" "True"
        Option      "MigrationHeuristic" "greedy"
        Option      "ExaScratchSize" "8192"
        Option      "MaxDRIMem" "16384"
# Start experimental, but didn't solve it
        Option      "XaaNoImageWriteRect"
        Option      "SWCursor"
# End experimental, but didn't solve it
EndSection

Section "Screen"
        Identifier "Screen0"
        Device     "Videocard0"
        Monitor    "Monitor0"
        DefaultDepth     24
        SubSection "Display"
                Viewport   0 0
                Depth     24
                Modes      "1280x768"
        EndSubSection
EndSection
[...]

[...]
01:00.0 VGA compatible controller: VIA Technologies, Inc. Chrome9 HC IGP (rev 01) (prog-if 00 [VGA controller])
        Subsystem: Hewlett-Packard Company Unknown device 3030
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
        Status: Cap+ 66MHz+ UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 64 (500ns min)
        Interrupt: pin A routed to IRQ 11
        Region 0: Memory at c0000000 (32-bit, prefetchable) [size=256M]
        Region 1: Memory at fc000000 (32-bit, non-prefetchable) [size=16M]
        Expansion ROM at fbff0000 [disabled] [size=64K]
        Capabilities: [60] Power Management version 2
                Flags: PMEClk- DSI+ D1+ D2+ AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-
        Capabilities: [70] AGP version 3.0
                Status: RQ=256 Iso- ArqSz=0 Cal=7 SBA+ ITACoh- GART64- HTrans- 64bit- FW- AGP3+ Rate=x4,x8
                Command: RQ=1 ArqSz=0 Cal=0 SBA+ AGP- GART64- 64bit- FW- Rate=<none>
[...]
Comment 1 Xavier Bachelot 2008-12-11 17:28:49 EST
You're right, F9 and F10 are not using the same code. F9 is mostly 0.2.903 release, while F10 is closer to openchrome latest development version.
The hardware cursor bug is known, you can workaround it with the SWCursor option.
About the resolution problem, the F9 driver uses a VBE call to set the mode. This VBE call is often causing trouble, although not in your case. In the F10 driver, this has been replaced by proper modesetting, but in your case, this is not working well. Could you please provide the xorg conf and xorg log with the F10 driver, so I can both take a look myself then forward to upstream ?

Regards,
Xavier
Comment 2 Markus Espenhain 2008-12-15 05:15:15 EST
Created attachment 326927 [details]
Xorg.log-fc10

Config-file is already in comment above - Here the Xorg.log-file from the system
Comment 3 Xavier Bachelot 2008-12-15 06:22:19 EST
I don't see the Monitor section in the excerpt of the conf file. Could you please attach the full file ?

Also, from the log file, the driver is using 1280x768. What is in the logs doesn't reflect the mode that is actually set ?
Comment 4 Markus Espenhain 2008-12-15 07:02:18 EST
Created attachment 326934 [details]
Xorg.0.log with openchrome from FC9

Here the Xorg.0.log with the FC9-openchrome-driver. The Resolution is in FC9 correct by 1280x720 (16:9) and with the new openchrome by 1280x768 - Thats the problem. The resolution from the Xorg.conf-file is ignored.
Comment 5 Markus Espenhain 2008-12-15 07:04:47 EST
Created attachment 326935 [details]
xorg.conf
Comment 6 Xavier Bachelot 2008-12-21 19:11:17 EST
I'm confused. Isn't 1280x768 the correct resolution ? The HP2133 exists in 2 versions either WXGA (1280 x 768) or WSVGA (1024 x 600). 1280x720 looks weird to me.
Comment 7 Robert Scheck 2008-12-22 04:03:51 EST
We determined the sizes via a full screenshot under GNOME.
Comment 8 Robert Scheck 2008-12-25 16:49:30 EST
Xavier, ping?
Comment 9 Xavier Bachelot 2009-01-02 17:16:09 EST
Try to add the following line to the device section of your xorg conf :
Option "PanelSize"  "1280x720"

If that doesn't work, I'll provide a new build of the driver with one more patch. The driver in Rawhide already have the patch but I'm not sure it'll work because Rawhide have xserver 1.6. You can also try to rebuild the Rawhide srpm on F10.
Comment 10 Robert Scheck 2009-01-12 07:29:30 EST
Created attachment 328726 [details]
Video with the strange effect visible

Okay, I think, I've to correct myself. Looks like 1280x768 is the correct
resolution of the display. But now we've with PanelSize and 1280x768 a strange
effect...like reams of water or so. And there is a horizonal line from the top
to the bottom of the display as it would be a display error. Once switching to
an older driver or another resolution (e.g 1280x767 - one pixel less) back,
the issue is gone - maybe you should watch the video. Display is flickering,
with 1280x768 as we would have a too less refresh rate, changing resolution or
or using the older driver also makes this go away.
Comment 11 Jon Nettleton 2009-01-13 20:37:59 EST
Please provide us with your Xorg logs so we can review them.  Thanks.
Comment 12 Xavier Bachelot 2009-03-05 16:26:23 EST
Do you still have the issue with xorg-x11-drv-openchrome-0.2.903-5.fc10 ?
This package is currently in updates-testing, but will soon be in updates.

If there is still an issue, please provide your xorg log and xorg conf (although you shouldn't need an xorg conf at all).
Comment 13 Xavier Bachelot 2009-03-22 07:24:46 EDT
Markus, Robert, ping ?
Does the latest driver from F10-updates help (0.2.903-5.fc10) ?
If not, does the latest driver from F10-updates-testing help (0.2.903-6.fc10) ?
In any case, please provide the xorg log, preferably from the very latest driver, without an xorg conf.
Comment 14 Robert Scheck 2009-04-02 07:38:40 EDT
Created attachment 337780 [details]
Xorg.0.log when no xorg.configuration file was supplied (auto configuration)
Comment 15 Robert Scheck 2009-04-02 07:42:31 EDT
Created attachment 337782 [details]
Xorg.0.log when no xorg.configuration file was supplied (auto configuration)

Xorg with autoconfiguration (thus: no configuration file) uses the wrong, a lower resolution for the display. Driver was latest from updates-testing.
Comment 16 Robert Scheck 2009-04-02 07:45:25 EDT
Created attachment 337783 [details]
Xorg.0.log with xorg.conf (so correct resolution) but strange ream-effects same as before
Comment 17 Robert Scheck 2009-04-02 07:46:23 EDT
Created attachment 337784 [details]
Another Xorg.0.log with xorg.conf (so correct resolution) but strange ream-effects same as before and having all xorg.conf options from comments above enabled
Comment 18 Robert Scheck 2009-09-04 08:35:38 EDT
I'm going to close this bug report, as the issue has disappeared with a
Fedora 11 and xorg-x11-drv-openchrome-0.2.903-12.fc11 (FEDORA-2009-7851).

Instead of that, bug #516092 and bug #506978 have shown up and I'm pretty
sure bug #516092 will say "hello" pretty soon, too. Upgrading from Fedora
9 to 10 or even to 11 seems to be more a functional downgrade for HP 2133.

--- snipp ---
# Xorg configuration created by system-config-display

Section "ServerLayout"
        Identifier     "single head configuration"
        Screen      0  "Screen0" 0 0
        InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "InputDevice"

# keyboard added by rhpxl
        Identifier  "Keyboard0"
        Driver      "kbd"
        Option      "XkbModel" "pc105"
        Option      "XkbLayout" "de"
        Option      "XkbVariant" "nodeadkeys"
EndSection

Section "Monitor"
        Identifier  "Monitor0"
        ModelName   "LCD Panel 1280x800"
        HorizSync   31.5 - 50.0
        VertRefresh 56.0 - 65.0
        Option      "dpms"
EndSection

Section "Device"
        Identifier  "Videocard0"
        Driver      "openchrome"

        Option      "AccelMethod" "EXA"
        Option      "ExaNoComposite" "True"
        Option      "MigrationHeuristic" "greedy"
        Option      "ExaScratchSize" "8192"
        Option      "MaxDRIMem" "16384"

        Option      "PanelSize" "1280x768"
EndSection

Section "Screen"
        Identifier "Screen0"
        Device     "Videocard0"
        DefaultDepth     24
        SubSection "Display"
                Viewport   0 0
                Depth     24
        EndSubSection
EndSection
--- snapp ---

Note You need to log in before you can comment on or make changes to this bug.