Bug 475121 - GCC can't be installed
GCC can't be installed
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
rawhide
All Linux
low Severity urgent
: ---
: ---
Assigned To: Jakub Jelinek
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-07 19:54 EST by Γριφεγ Γ.
Modified: 2009-01-10 08:33 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-10 08:33:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Γριφεγ Γ. 2008-12-07 19:54:40 EST
Description of problem:

# yum -y install gcc
/usr/lib/python2.6/site-packages/yum/pgpmsg.py:16: DeprecationWarning: the md5 module is deprecated; use hashlib instead
  import struct, time, cStringIO, base64, types, md5, sha
/usr/lib/python2.6/site-packages/yum/pgpmsg.py:16: DeprecationWarning: the sha module is deprecated; use the hashlib module instead
  import struct, time, cStringIO, base64, types, md5, sha
/usr/lib/python2.6/site-packages/iniparse/ini.py:46: DeprecationWarning: the sets module is deprecated
  from sets import Set
rpmfusion-free-rawhide                                   | 2.7 kB     00:00     
rpmfusion-nonfree-rawhide                                | 2.7 kB     00:00     
rawhide                                                  | 2.8 kB     00:00     
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package gcc.i386 0:4.3.2-7 set to be updated
--> Processing Dependency: glibc-devel >= 2.2.90-12 for package: gcc
--> Running transaction check
---> Package glibc-devel.i386 0:2.8.90-17 set to be updated
--> Processing Dependency: glibc = 2.8.90-17 for package: glibc-devel
--> Processing Dependency: glibc-headers = 2.8.90-17 for package: glibc-devel
/usr/lib/python2.6/site-packages/yum/sqlitesack.py:45: DeprecationWarning: BaseException.message has been deprecated as of Python 2.6
  if hasattr(e, "message"):
/usr/lib/python2.6/site-packages/yum/sqlitesack.py:46: DeprecationWarning: BaseException.message has been deprecated as of Python 2.6
  raise Errors.RepoError, str(e.message)
--> Running transaction check
---> Package glibc-headers.i386 0:2.8.90-17 set to be updated
--> Processing Dependency: kernel-headers >= 2.2.1 for package: glibc-headers
--> Processing Dependency: kernel-headers for package: glibc-headers
---> Package glibc.i386 0:2.8.90-17 set to be updated
--> Processing Dependency: glibc-common = 2.8.90-17 for package: glibc
--> Running transaction check
---> Package kernel-headers.i386 0:2.6.28-0.113.rc7.git5.fc11 set to be updated
---> Package glibc.i386 0:2.8.90-17 set to be updated
--> Processing Dependency: glibc-common = 2.8.90-17 for package: glibc
--> Finished Dependency Resolution
glibc-2.8.90-17.i386 from rawhide has depsolving problems
  --> Missing Dependency: glibc-common = 2.8.90-17 is needed by package glibc-2.8.90-17.i386 (rawhide)
Error: Missing Dependency: glibc-common = 2.8.90-17 is needed by package glibc-2.8.90-17.i386 (rawhide)


Additional info:
PS I already have glibc-2.9-2 installed....................
Comment 1 Jakub Jelinek 2008-12-08 09:46:15 EST
Nothing to do with gcc.  Only that glibc in F10 is older than in rawhide, because it hasn't been updated yet.
Comment 2 Γριφεγ Γ. 2008-12-08 11:23:26 EST
It's not a bug that GCC can't be installed? Or mkinitrd?

To install mkinitrd I removed the too new nash and then reinstalled both. But I can't remove glibc, so how do I install GCC?

As far as I know, it is a bug in the gcc package that it depends on too old versions of glibc. I thought it's standard practice that when a library (or its headers) is updated, all its dependencies are recompiled.
Comment 3 Christopher Beland 2008-12-13 14:32:31 EST
I think this is actually a problem with one of the glibc packages.

% yum install glibc-devel
Loaded plugins: downloadonly, fastestmirror, refresh-packagekit
Loading mirror speeds from cached hostfile
 * rawhide-debuginfo: fedora.mirrors.tds.net
 * rpmfusion-free-rawhide-debuginfo: mirror.liberty.edu
 * rpmfusion-nonfree-rawhide: mirror.liberty.edu
 * rpmfusion-free-rawhide: mirror.liberty.edu
 * rpmfusion-nonfree-rawhide-debuginfo: mirror.liberty.edu
 * rawhide: fedora.secsup.org
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package glibc-devel.x86_64 0:2.8.90-17 set to be updated
--> Processing Dependency: glibc = 2.8.90-17 for package: glibc-devel
--> Processing Dependency: glibc-headers = 2.8.90-17 for package: glibc-devel
--> Running transaction check
---> Package glibc.i386 0:2.8.90-17 set to be updated
--> Processing Dependency: glibc-common = 2.8.90-17 for package: glibc
---> Package glibc-headers.x86_64 0:2.8.90-17 set to be updated
--> Processing Dependency: kernel-headers >= 2.2.1 for package: glibc-headers
--> Processing Dependency: kernel-headers for package: glibc-headers
--> Running transaction check
---> Package kernel-headers.x86_64 0:2.6.28-0.127.rc8.git1.fc11 set to be updated
---> Package glibc.i386 0:2.8.90-17 set to be updated
--> Processing Dependency: glibc-common = 2.8.90-17 for package: glibc
--> Finished Dependency Resolution
glibc-2.8.90-17.i386 from rawhide has depsolving problems
  --> Missing Dependency: glibc-common = 2.8.90-17 is needed by package glibc-2.8.90-17.i386 (rawhide)
Error: Missing Dependency: glibc-common = 2.8.90-17 is needed by package glibc-2.8.90-17.i386 (rawhide)

glibc-2.9-2.i686
glibc-2.9-2.x86_64
glibc-common-2.9-2.x86_64
glibc-debuginfo-2.9-2.x86_64

The version numbers are higher in what I have installed than what yum is looking for, so it seems there is some sort of dependency problem.
Comment 4 Γριφεγ Γ. 2008-12-13 21:04:01 EST
Well, it's pretty straightforward. From comment #0, in backwards order:

--> Missing Dependency: glibc-common = 2.8.90-17 is needed by package
glibc-2.8.90-17.i386 (rawhide)
(Even though yum lies here because glibc-2.8.90 is not ACTUALLY in rawhide itself, this dependency is fine)
--> Processing Dependency: glibc = 2.8.90-17 for package: glibc-devel
The problem is here.
--> Processing Dependency: glibc-devel >= 2.2.90-12 for package: gcc
Right, technically it's nothing to do with gcc. Glibc-devel is what hasn't been updated in rawhide, but glibc has been.
Comment 5 Christopher Beland 2008-12-22 15:39:19 EST
I still can't install gcc in rawhide.  It looks like the component on this bug needs to be changed to glibc?
Comment 6 Christopher Beland 2009-01-10 03:10:47 EST
I can now install gcc successfully, along with glibc-devel-2.9.90-2.x86_64.rpm and glibc-headers-2.9.90-2.x86_64.rpm.

Note You need to log in before you can comment on or make changes to this bug.