Bug 475154 - Gtk system dialogs use default language, not configured OOo UI language, e.g. print dialog
Gtk system dialogs use default language, not configured OOo UI language, e.g....
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-08 03:04 EST by Joachim Backes
Modified: 2009-01-29 18:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-29 18:10:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the options->language control menu (64.99 KB, image/jpeg)
2008-12-08 03:04 EST, Joachim Backes
no flags Details
print dialog with english and german parts (28.42 KB, image/jpeg)
2008-12-08 03:05 EST, Joachim Backes
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 97064 None None None Never

  None (edit)
Description Joachim Backes 2008-12-08 03:04:16 EST
Created attachment 326090 [details]
the options->language control menu

Description of problem:
My language in openoffice.org is German. But the print dialog for documents contains english and german tabs. I expect german-only tabs.

Version-Release number of selected component (if applicable):
openoffice.org 3.0.0-9.10.fc10.i386

How reproducible:
each time.

Steps to Reproduce:
0.Set the oo language to german
1.print some oo document
2.
3.
  
Actual results:
The print dialog has a language mix

Expected results:
the print dialog has only german tabs

Additional info:
The controls windows and the print dialog window are attached
Comment 1 Joachim Backes 2008-12-08 03:05:32 EST
Created attachment 326091 [details]
print dialog with english and german parts
Comment 2 Joachim Backes 2008-12-08 03:10:21 EST
I think it is related to the fact that my LANG env variable is set to en_US.UTF-8.
Comment 3 Caolan McNamara 2008-12-08 05:17:36 EST
You've set the OOo UI language to German, but the UI language for the rest of the Desktop remains at English. So the tab names that come from Gtk itself stay in English, while the names provided by OOo are in German. I suspect you'd see something similar in the file dialog as well.

I wonder if we can toggle something to make gtk use the selected OOo language.
Comment 4 Joachim Backes 2008-12-08 07:53:31 EST
I think, this should be possible: Why then is it allowed to switch in OO to another language than the desktop is controlled by? I cannot imagine that the UI for OO must follow the desktop language.
Comment 5 Caolan McNamara 2008-12-08 08:02:22 EST
Well, I don't think anyone has really considered the collision of the UI Language changing feature, and the separate Use System Dialog feature before.
Comment 6 Caolan McNamara 2008-12-09 06:02:46 EST
Gtk uses gettext to get translations, so it looks like that only fiddling with LC_MESSAGES, LANG or LANGUAGE can get it to follow the OOo setting. 

LANGUAGE looks the best fit as it will take bare "ll" portions of ll_XX as acceptable input.
Comment 7 Joachim Backes 2008-12-09 06:45:12 EST
I'll try that.
Comment 8 Joachim Backes 2008-12-09 07:10:25 EST
Hi Caolan,

after testing all alternatives, I think none of the proposals really solves my problem (I set the correspondent var in ~/.bashrc): in some case my dektop language is completely altered to german (which I don't want), so the gtk print controls are in german too, or some print controls remain in english language.

I think, my call 475154 may be closed as "no bug".

Please apologize for trouble.
Comment 9 Caolan McNamara 2008-12-09 07:36:10 EST
The idea is that *OOo* sets LANGUAGE locally to get the dialogs into the same language as the rest of the OOo UI without affect the global situation. So we may still be able to do what you want
Comment 10 Joachim Backes 2008-12-09 07:57:19 EST
(In reply to comment #9)
> The idea is that *OOo* sets LANGUAGE locally to get the dialogs into the same
> language as the rest of the OOo UI without affect the global situation. So we
> may still be able to do what you want

Exactly what I meant. I would be very grateful if that "idea" could be realized. 

Regards

JB
Comment 11 David Tardon 2008-12-10 04:57:17 EST
(In reply to comment #6)
> Gtk uses gettext to get translations, so it looks like that only fiddling with
> LC_MESSAGES, LANG or LANGUAGE can get it to follow the OOo setting. 
> 
> LANGUAGE looks the best fit as it will take bare "ll" portions of ll_XX as
> acceptable input.

I think LC_ALL is the right one.
Comment 12 Caolan McNamara 2008-12-10 05:08:25 EST
The catch is that OOo's Locale may not include a country key, e.g. it will be only "de" if you select German from the menus and the LC_ALL etc family need to be LANG_REGION e.g. de_DE. Changing the locale with setlocale and LC_ALL to force in the OOo UI language to get gettext to give gtk german strings would have knock on effects on other settings. While LANGUAGE is used first by getext before the LC_etc set and can be a fallback list of languages and regionless language identifiers could be used.
Comment 13 David Tardon 2008-12-10 06:19:30 EST
You're right, as always... I didn't know about the LANGUAGE variable.
Comment 14 Caolan McNamara 2008-12-10 09:00:29 EST
Lets give that a go. Will be in >= 3.0.0-9.11 if/when there is an update released for F-10 OOo.
Comment 15 Fedora Update System 2009-01-13 03:46:42 EST
openoffice.org-3.0.1-15.1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/openoffice.org-3.0.1-15.1.fc10
Comment 16 Fedora Update System 2009-01-14 21:53:40 EST
openoffice.org-3.0.1-15.1.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update openoffice.org'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-0390
Comment 17 Joachim Backes 2009-01-15 03:05:16 EST
(In reply to comment #16)
> openoffice.org-3.0.1-15.1.fc10 has been pushed to the Fedora 10 testing
> repository.  If problems still persist, please make note of it in this bug
> report.
>  If you want to test the update, you can install it with 
>  su -c 'yum --enablerepo=updates-testing update openoffice.org'.  You can
> provide feedback for this update here:
> http://admin.fedoraproject.org/updates/F10/FEDORA-2009-0390

Weird:

sudo yum --enablerepo=updates-testing update openoffice.org
Loaded plugins: fastestmirror, refresh-packagekit
Loading mirror speeds from cached hostfile
 * updates-testing: mirror.ovh.net
 * fedora: ftp.univie.ac.at
 * rpmfusion-free-updates: ftp-stud.hs-esslingen.de
 * rpmfusion-nonfree-updates: ftp-stud.hs-esslingen.de
 * rpmfusion-free: ftp-stud.hs-esslingen.de
 * rpmfusion-nonfree: ftp-stud.hs-esslingen.de
 * updates: ftp.uni-erlangen.de
updates-testing                                          | 2.3 kB     00:00     
updates-testing/primary_db                               | 356 kB     00:02     
Setting up Update Process
No Match for argument: openoffice.org
No package openoffice.org available.
No Packages marked for Update
Comment 18 Joachim Backes 2009-01-16 03:15:22 EST
Change the yum command to 
sudo yum --enablerepo=updates-testing update openoffice.org\*

The Update seems to solve my problems: all print dialogs appear now in german language.

Thanks!
Comment 19 Fedora Update System 2009-01-29 18:09:35 EST
openoffice.org-3.0.1-15.2.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.