Bug 475159 - evince adds encoding to URLs, breaking certain URLs
evince adds encoding to URLs, breaking certain URLs
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: evince (Show other bugs)
5.2
All Linux
low Severity medium
: rc
: ---
Assigned To: Denise Dumas
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-08 04:00 EST by Murray McAllister
Modified: 2015-02-12 12:42 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-02 09:20:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
PDF with URLs as per the bug (141.70 KB, application/pdf)
2008-12-08 04:07 EST, Murray McAllister
no flags Details

  None (edit)
Description Murray McAllister 2008-12-08 04:00:41 EST
Description of problem:
Clicking on hyperlinks in evince does not always work: evince seems to add encoding to the URL, breaking it.

Version-Release number of selected component (if applicable):
evince-0.6.0-8.el5

How reproducible:
Always.

Steps to Reproduce:
1. Create two hyperlinks:
<para>
    <ulink url="https://bugzilla.redhat.com/show_bug.cgi?id=472986">https://bugzilla.redhat.com/show_bug.cgi?id=472986</ulink>
 </para>
 <para>
     <ulink url="https://bugzilla.redhat.com/show_bug.cgi?id=472986"/>
 </para>

  
Actual results:
In both cases, when clicking the hyperlink in evince, Firefox opens, displaying the following URL in the address bar:

<https://bugzilla.redhat.com/show_bug.cgi%3Fid=472986

(note: %3 instead of ?)

Expected results:
<https://bugzilla.redhat.com/show_bug.cgi?id=472986>

Additional info:

* the above links work as expected in evince-2.24.1-3.fc10.i386 and acroread-8.1.2.SU1-2.el5

* see attached for testing PDF (navigate to page 9).

* the following link works correctly in evince as shipped with Red Hat Enterprise Linux 5.2 and Fedora 10:

<ulink url="https://bugzilla.redhat.com/bugzilla/enter_bug.cgi?product=Fedora&amp;version=1&amp;component=publican">https://bugzilla.redhat.com/bugzilla/enter_bug.cgi?product=Fedora&amp;version=rawhide&amp;component=publican</ulink>
Comment 1 Murray McAllister 2008-12-08 04:07:02 EST
Created attachment 326103 [details]
PDF with URLs as per the bug
Comment 2 Murray McAllister 2008-12-08 04:12:42 EST
Apologies for the way the PDF is attached. I did not want to spam everyone trying to get it right.
Comment 3 Murray McAllister 2008-12-08 05:39:39 EST
right clicking and selecting "Copy Link Address" works in all cases.
Comment 5 Murray McAllister 2009-04-15 02:57:00 EDT
Are there any updates on this?
Comment 9 RHEL Product and Program Management 2014-03-07 07:51:08 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 10 RHEL Product and Program Management 2014-06-02 09:20:45 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Note You need to log in before you can comment on or make changes to this bug.