Bug 475179 - audacious fails to load file throw command line arguments
audacious fails to load file throw command line arguments
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: audacious (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Ralf Ertzinger
Fedora Extras Quality Assurance
:
: 491228 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-08 06:30 EST by maksym
Modified: 2009-06-30 11:07 EDT (History)
7 users (show)

See Also:
Fixed In Version: 1.5.1-6.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-26 22:45:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch reorder xxx_system_init() calls to proper handle calls from handle_cmd_line_options() (508 bytes, patch)
2008-12-08 06:30 EST, maksym
no flags Details | Diff

  None (edit)
Description maksym 2008-12-08 06:30:24 EST
Created attachment 326113 [details]
patch reorder xxx_system_init() calls to proper handle calls from handle_cmd_line_options()

Description of problem:
Audacious fail to open file submitted throw command line arguments list. Instead of putting (enqueueing) file into playlist it just open FileOpenDialog. 

Version-Release number of selected component (if applicable):
audacious-1.5.1-4.fc10

How reproducible:
stable

Steps to Reproduce:
execute from shell:
    audacious /tmp/<any_existence>.mp3
  
Actual results:
open FileOpenDialog

Expected results:
put submitted file into playlist

Additional info:
That happens because of missordered calls of
handle_cmd_line_options();
and
playlist_system_init();
in audacious-1.5.1/src/audacious/main.c
As result any insertion items into playlist calls from handle_cmd_line_options fails due to not initialized playlist.
Patch attached.
Comment 1 Nicola Soranzo 2008-12-10 09:29:05 EST
This behaviour happens if the playlist was left empty the last time audacious was used. Otherwise audacious starts with the old playlist, without adding the new file.

Same problem when double clicking on an audio file.
Comment 2 JX 2008-12-12 18:23:42 EST
https://bugs.launchpad.net/ubuntu/+source/audacious/+bug/291643

005-playlist_play_clicked_file.patch is missing !!!
Comment 3 JX 2008-12-13 08:32:26 EST
please add the following patch

diff -uNr audacious-1.5.1-orig/src/audacious/main.c audacious-1.5.1/src/audacious/main.c
--- audacious-1.5.1-orig/src/audacious/main.c
+++ audacious-1.5.1/src/audacious/main.c
@@ -315,7 +315,7 @@
 }
 
 static void
-handle_cmd_line_options()
+handle_cmd_line_options(gboolean skip)
 {
     gchar **filenames = options.filenames;
 #ifdef USE_DBUS
@@ -430,7 +430,7 @@
     } /* is_running */
     else
 #endif
-    { /* !is_running */
+    if (!skip) { /* !is_running */
         if (filenames != NULL)
         {
             gint pos = 0;
@@ -715,7 +715,10 @@
 
     signal_handlers_init();
 
-    handle_cmd_line_options();
+    handle_cmd_line_options(TRUE);
+
+    plugin_system_init();
+    playlist_system_init();
 
     if (options.headless == FALSE)
     {
@@ -732,8 +735,7 @@
         ui_manager_create_menus();
     }
 
-    plugin_system_init();
-    playlist_system_init();
+    handle_cmd_line_options(FALSE);
 
 #ifdef USE_DBUS
     init_dbus();
Comment 4 Ken Dreyer 2009-01-16 13:48:30 EST
(In reply to comment #3)

I can confirm that this patch fixes the problem for me (I'm using audacious-1.5.1-5.fc10.i386).
Comment 5 Nicola Soranzo 2009-05-22 09:08:23 EDT
*** Bug 491228 has been marked as a duplicate of this bug. ***
Comment 6 Nicola Soranzo 2009-05-22 11:27:43 EDT
I think this bug is fixed upstream (which is now at version 2.0.1) since the initialization has been largely rewritten. May the package be updated to latest release?
Thanks
Comment 7 Michael Schwendt 2009-06-04 16:42:41 EDT
https://admin.fedoraproject.org/updates/F11/FEDORA-2009-4313

Not clear yet whether/when this fix may be backported to F-10.

See bug 501007 comment 4 on how to proceed with Audacious 1 or Audacious 2.
Comment 8 Fedora Update System 2009-06-05 08:10:57 EDT
audacious-plugins-1.5.1-6.fc10,audacious-1.5.1-9.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/audacious-plugins-1.5.1-6.fc10,audacious-1.5.1-9.fc10
Comment 9 Fedora Update System 2009-06-15 22:38:11 EDT
audacious-plugins-1.5.1-6.fc11, audacious-1.5.1-9.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update audacious-plugins audacious'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-6438
Comment 10 Fedora Update System 2009-06-15 22:45:42 EDT
audacious-plugins-1.5.1-6.fc10, audacious-1.5.1-9.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update audacious-plugins audacious'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-6490
Comment 11 Fedora Update System 2009-06-26 22:44:50 EDT
audacious-plugins-1.5.1-6.fc11, audacious-1.5.1-9.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2009-06-26 22:47:02 EDT
audacious-plugins-1.5.1-6.fc10, audacious-1.5.1-9.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Ken Dreyer 2009-06-30 11:07:09 EDT
audacious-1.5.1-9.fc10 works for me.

Note You need to log in before you can comment on or make changes to this bug.