Bug 475195 - yum update fails with scriplet errors - "ts_done name in te is ..., should be ..."
yum update fails with scriplet errors - "ts_done name in te is ..., should be...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-qmf (Show other bugs)
1.1
All Linux
medium Severity medium
: Next Errata
: ---
Assigned To: Justin Ross
Frantisek Reznicek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-08 08:45 EST by Jeff Needle
Modified: 2015-11-15 19:06 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-06 15:39:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Needle 2008-12-08 08:45:53 EST
When updating to the latest packages, I got scriplet failures in sesame and condor-low-latency. The latter may be due to the former failing, so I'm randomly picking management to log this against, but copying Rob.

# yum -y update
Loading "security" plugin
Skipping security plugin, no data
Setting up Update Process
Resolving Dependencies 
Skipping security plugin, no data
--> Running transaction check
---> Package rhm-docs.noarch 0:0.3.723829-3.el5 set to be updated
---> Package condor-low-latency.noarch 0:1.0-5.el5 set to be updated
---> Package sesame.x86_64 0:0.1.2935-1.el5 set to be updated
---> Package condor-job-hooks.noarch 0:1.0-4.el5 set to be updated
---> Package condor-job-hooks-common.noarch 0:1.0-4.el5 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved  

=============================================================================
 Package                 Arch       Version          Repository        Size
=============================================================================
Updating:
 condor-job-hooks        noarch     1.0-4.el5        MRG Candidate      12 k
 condor-job-hooks-common  noarch     1.0-4.el5        MRG Candidate      12 k
 condor-low-latency      noarch     1.0-5.el5        MRG Candidate      15 k
 rhm-docs                noarch     0.3.723829-3.el5  MRG Candidate     1.6 M
 sesame                  x86_64     0.1.2935-1.el5   MRG Candidate      33 k

Transaction Summary
=============================================================================
Install      0 Package(s)
Update       5 Package(s)
Remove       0 Package(s)

Total download size: 1.6 M
Downloading Packages:  
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
error: %pre(sesame-0.1.2935-1.el5.x86_64) scriptlet failed, exit status 255
error:   install: %pre scriptlet failed (2), skipping sesame-0.1.2935-1.el5
  Updating  : condor-job-hooks-common      ####################### [ 2/11]
  Updating  : condor-job-hooks             ####################### [ 3/11]
  Updating  : rhm-docs                     ####################### [ 4/11]
  Updating  : condor-low-latency           ####################### [ 5/11]
error: %post(condor-low-latency-1.0-5.el5.noarch) scriptlet failed, exit status 255
  Cleanup   : rhm-docs                     ####################### [ 6/11]
  Cleanup   : sesame                       ####################### [ 7/11]
  Cleanup   : condor-job-hooks             ####################### [ 8/11]
  Cleanup   : condor-job-hooks-common      ####################### [ 9/11]

Updated: condor-job-hooks.noarch 0:1.0-4.el5 condor-job-hooks-common.noarch 0:1.0-4.el5 condor-low-latency.noarch 0:1.0-5.el5 rhm-docs.noarch 0:0.3.723829-3.el5 sesame.x86_64 0:0.1.2935-1.el5
Complete!

From /var/log/messages:

Dec  8 07:37:51 north-11 qarshd[26623]: Running cmdline: yum -y update 
Dec  8 07:37:56 north-11 yum: Updated: sesame - 0.1.2935-1.el5.x86_64
Dec  8 07:37:56 north-11 yum: Updated: condor-job-hooks-common - 1.0-4.el5.noarch
Dec  8 07:37:56 north-11 yum: Updated: condor-job-hooks - 1.0-4.el5.noarch
Dec  8 07:37:56 north-11 yum: Updated: rhm-docs - 0.3.723829-3.el5.noarch
Dec  8 07:37:57 north-11 yum: Updated: condor-low-latency - 1.0-5.el5.noarch
Dec  8 07:37:57 north-11 yum: sesame: ts_done name in te is condor-low-latency should be sesame
Dec  8 07:37:57 north-11 yum: condor-job-hooks: ts_done name in te is condor-low-latency should be condor-job-hooks
Dec  8 07:37:58 north-11 yum: condor-job-hooks-common: ts_done name in te is sesame should be condor-job-hooks-common
Dec  8 07:37:58 north-11 xinetd[2792]: EXIT: qarsh status=0 pid=26623 duration=7(sec)
Comment 1 Justin Ross 2008-12-08 09:24:51 EST
This is pretty weird.  Here's the pre scriptlet from sesame:

%pre
getent group sesame > /dev/null || groupadd -r sesame
getent passwd sesame > /dev/null || useradd -r \
       -g sesame -d %{_localstatedir}/lib/sesame -s /sbin/nologin \
       -c "Owner of the sesame daemon" sesame
exit 0

This follows the recipe set out at https://fedoraproject.org/wiki/Packaging/UsersAndGroups, and just staring at it for a bit, I don't see any errors.

What is "ts" in ts_done, and what is "te"?
Comment 2 Jeff Needle 2008-12-09 09:20:25 EST
Since this is only happening upgrading components that haven't yet shipped, this won't affect 1.1 customers, only us, so I'm removing the 1.1 tag - bumping to 1.1.1 so we don't forget to look into it.

Note You need to log in before you can comment on or make changes to this bug.