Bug 475207 - rhns-proxy-tools should require squid
rhns-proxy-tools should require squid
Status: CLOSED DUPLICATE of bug 225190
Product: Red Hat Satellite Proxy 5
Classification: Red Hat
Component: Installer (Show other bugs)
420
All Linux
low Severity medium
: ---
: ---
Assigned To: Miroslav Suchý
Jan Hutař
:
Depends On:
Blocks: 456999
  Show dependency treegraph
 
Reported: 2008-12-08 09:53 EST by Jan Hutař
Modified: 2009-08-09 11:51 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-17 05:57:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Hutař 2008-12-08 09:53:08 EST
Description of problem:
I have seen this in 4.1 and it looks like there is no such package in the 4.2, but I have been told we are still supporting 4.1, so:
When I tried to activate my 4.1 Proxy, first event "Package Install scheduled by qa@redhat.com" failed. I have found that installation fails on %post/%pre script of rhns-proxy-tools package:

# up2date -i rhns-proxy-tools
...
Name                                    Version        Rel     
----------------------------------------------------------
rhns-proxy-tools                        4.1.0          11.rhel4          noarch
Testing package set / solving RPM inter-dependencies...
########################################
There was a fatal RPM install error. The message was:
Failed running rpm transaction
# rpm -ivh rhns-proxy-tools-4.1.0-11.rhel4.noarch.rpm
Preparing...                ########################################### [100%]
   1:rhns-proxy-tools       ########################################### [100%]

ERROR: unhandled exception occurred:
Traceback (most recent call last):
  File "/usr/bin/rhn-proxy-upgrade-services-conf", line 45, in ?
    sys.exit(mod.main() or 0)
  File "/usr/share/rhn/proxy/tools/rhn_proxy_upgrade_services_conf.py", line 283, in main
    updateSquidConf(options.version, not options.quiet)
  File "/usr/share/rhn/proxy/tools/rhn_proxy_upgrade_services_conf.py", line 216, in updateSquidConf
    shutil.copy2(sample, SQUID_DOT_CONF)
  File "/usr/lib/python2.3/shutil.py", line 82, in copy2
    copyfile(src, dst)
  File "/usr/lib/python2.3/shutil.py", line 38, in copyfile
    fdst = open(dst, 'wb')
IOError: [Errno 2] No such file or directory: '/etc/squid/squid.conf'

When I manually installed squid, installation went fine.


Version-Release number of selected component (if applicable):
rhns-proxy-tools-4.1.0-11.rhel4


How reproducible:
always


Steps to Reproduce:
1. # up2date -i rhns-proxy-management


Actual results:
%post/%pre failure


Expected results:
rhns-proxy-tools should have "Requires: squid"


Additional info:
It was normal, brand new kickstart installation, so I do not think there could be any unsatisfied dependencies.
Comment 1 Clifford Perry 2008-12-16 16:12:47 EST
Accepting to ensure that the new Proxy installation process for 5.3.0 does the right thing in getting squid installed. We are not going to go back at this stage to fix the 4.1 Proxy installation/packages. 

Cliff
Comment 2 Miroslav Suchý 2008-12-17 05:57:59 EST
Fixed in 5.1. We will backport it to old version only if customer request hotfix.
Close as DUPLICATE.

*** This bug has been marked as a duplicate of bug 225190 ***

Note You need to log in before you can comment on or make changes to this bug.