Bug 475243 - malformed BuildRequire entries (versioning has parentheses)
malformed BuildRequire entries (versioning has parentheses)
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: R2spec (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Pierre-YvesChibon
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-08 11:59 EST by R P Herrold
Modified: 2008-12-09 09:23 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-09 09:23:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description R P Herrold 2008-12-08 11:59:58 EST
Description of problem:

mal-formed versioned BR's being emitted 

Version-Release number of selected component (if applicable):

[herrold@centos-5 R-packages]$ rpm -q R2spec
R2spec-2.5.1-6orc

How reproducible:

[herrold@centos-5 R-packages]$ rpmbuild -ba  R-asypow.spec
error: line 16: Dependency tokens must begin with alpha-numeric, '_' or '/': Requires:         R (>= 2.2.0), stats

[herrold@centos-5 R-packages]$ grep -i requ R-asypow.spec
Requires:         R (>= 2.2.0), stats
Requires(post):   R
Requires(postun): R
BuildRequires:    R-devel tetex-latex R (>= 2.2.0), stats
[herrold@centos-5 R-packages]$   

Steps to Reproduce:

as above
  
Actual results:

presence of "(" and ")" in versioning

Expected results:

properly formed entries

Additional info:

Please contact me if you need further information
Comment 1 Pierre-YvesChibon 2008-12-08 12:07:11 EST
This is not a bug but a RFE :D

R2spec takes its information from the DESCRIPTION files in the sources whatever way they are written

I was thinking about it and the "(", ")" can be removed easily.

It becomes harder for libraries in BR
ie: in the example you are giving stats should be R-stats but R should remain R and if the package depends on other software they should also not be presented as R-name...

Needs probably some though

Thanks for all your feedback :)
Comment 2 Pierre-YvesChibon 2008-12-08 12:30:49 EST
https://fedorahosted.org/r2spec/browser/devel/CHANGELOG
Comment 3 Pierre-YvesChibon 2008-12-08 13:29:38 EST
Fix in devel
https://fedorahosted.org/r2spec/browser/devel/CHANGELOG
Comment 4 R P Herrold 2008-12-08 13:55:40 EST
The model I am following of course, is a traditional one:

1. get it written (you did)
2. get it into Fedora ... we did
3. get it working accurately ... we are in process
4. [optional] get it fast  ;)

13:42  orc_orc> I am about 1/2 way thru autopackaging 1600 CRAN with R2spec
                converter this morning

really as I write this 1648 overall, and I am a 1283 (ref_0.95.tar.gz)

My next step (once the first pass auto-spec is done) is an automated:
    rpmbuild -ba (specfile)
for all to identify errors in grammar in the 'spec file language .. I see some, already but will feed the next clocker, in turn, to you.

and then the step after that is to manually post process solutions for certain leaf nodes I want, to identify needed automated cleanup

My intention is to keep feeding you 'easyfix' matters ... I hope this is acceptable.

with my best regards, 

-- Russ herrold

Note You need to log in before you can comment on or make changes to this bug.