This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 475271 - Unexpected exception while deselecting luns to install against
Unexpected exception while deselecting luns to install against
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.3
x86_64 Linux
low Severity high
: rc
: ---
Assigned To: Radek Vykydal
Alexander Todorov
: OtherQA
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-08 13:32 EST by Jim Evans
Modified: 2009-09-02 05:56 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 05:56:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output collected during exception (100.38 KB, text/plain)
2008-12-08 13:32 EST, Jim Evans
no flags Details

  None (edit)
Description Jim Evans 2008-12-08 13:32:33 EST
Created attachment 326160 [details]
Output collected during exception

Description of problem:
While selecting a couple of luns during the install process I got an
unexpected exception. See attached log.

Version-Release number of selected component (if applicable):
RHEL 5u3 snapshot 4

How reproducible:
unsure

Steps to Reproduce:
1. One EVA lun on the SAN and two local luns
2. Deselect EVA and one local lun. Leave cciss0 to install to
3. Unexpected exception. Error says to report to Red Hat
  
Actual results:
installation was aborted

Expected results:
installation continued

Additional info:
HP BL685c blade server
4GB ram
2 local cciss luns
1 EXA-XL lun

Logged as high because installation fails.
Comment 1 Radek Vykydal 2008-12-09 09:18:26 EST
I think the problem here is that LV request bind to local r in 
attached traceback has fstype "physical volume (LVM)" so it
passes condition on line autopart.py:1407 which should filter in
only PVs. LV request has no attribute drive which raises the exception.
Comment 3 Chris Lumens 2008-12-09 14:55:03 EST
Do we mean something like this:

diff --git a/autopart.py b/autopart.py
index 4c752a8..04abfc0 100644
--- a/autopart.py
+++ b/autopart.py
@@ -1411,13 +1411,13 @@ def doAutoPartition(anaconda):
                                 len(partitions.autoClearPartDrives) == 0):
                                 valid = 1
                             else:
-                                if not isinstance(r, partRequests.RaidRequestSpec):
+                                if isinstance(r, partRequests.PartitionSpec):
                                     for d in r.drive:
                                         if d in partitions.autoClearPartDrives:
                                             valid = 1
                                             break
 
-                            if not isinstance(r, partRequests.RaidRequestSpec):
+                            if isinstance(r, partRequests.PartitionSpec):
                                 if not r.multidrive:
                                     valid = 0
Comment 4 Denise Dumas 2008-12-09 16:06:16 EST
To minimize risk to 5.3, and because this should be an unusual corner case, moving this to 5.4
Comment 5 Radek Vykydal 2008-12-10 03:03:37 EST
(In reply to comment #3)

Yes, the patch in comment #3 should fix it.
I'll try to figure out where the LV with "physical volume (LVM)"
fs type comes from and make a reproducer.
Comment 6 RHEL Product and Program Management 2009-02-03 18:14:01 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 7 Radek Vykydal 2009-02-24 11:49:04 EST
Should be fixed in anaconda 11.1.2.169-1.
I don't have a reproducer.
Comment 10 Chris Ward 2009-07-03 14:15:54 EDT
~~ Attention - RHEL 5.4 Beta Released! ~~

RHEL 5.4 Beta has been released! There should be a fix present in the Beta release that addresses this particular request. Please test and report back results here, at your earliest convenience. RHEL 5.4 General Availability release is just around the corner!

If you encounter any issues while testing Beta, please describe the issues you have encountered and set the bug into NEED_INFO. If you encounter new issues, please clone this bug to open a new issue and request it be reviewed for inclusion in RHEL 5.4 or a later update, if it is not of urgent severity.

Please do not flip the bug status to VERIFIED. Only post your verification results, and if available, update Verified field with the appropriate value.

Questions can be posted to this bug or your customer or partner representative.
Comment 11 Alexander Todorov 2009-07-07 08:32:57 EDT
Jim,
can you give 5.4 Beta a try and post your test results? 

Thanks!
Comment 12 Alexander Todorov 2009-07-31 08:35:50 EDT
Jim,
please provide your test results to us. We'd like to make sure this issue has been fixed and the fixes included in RHEL 5.4. Thanks.
Comment 13 Jim Evans 2009-08-03 14:47:33 EDT
Sorry it took so long but things have been busy here.

I did not see this issue when installing with RHEL 5.4 snap 3.

That said I only encountered that issue once.

jim
Comment 16 errata-xmlrpc 2009-09-02 05:56:18 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1306.html

Note You need to log in before you can comment on or make changes to this bug.