Bug 475276 - Updating libvirt breaks hypervisor autodetection until libvirtd restart
Updating libvirt breaks hypervisor autodetection until libvirtd restart
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Veillard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-08 14:01 EST by Chris Snook
Modified: 2009-01-22 08:19 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-22 08:19:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Snook 2008-12-08 14:01:36 EST
Description of problem:
Updating to libvirt-0.5.0-1.fc10.x86_64 broke hypervisor autodetection until I restarted libvirtd.  This caused all virsh commands lacking a --connect argument to fail.

Version-Release number of selected component (if applicable):
libvirt-0.5.0-1.fc10.x86_64

How reproducible:
haven't tried

Steps to Reproduce:
1. Install F10, including virtualization tools, from GA media
2. use virsh to work with a guest, observing that it works without --connect argument
3. update libvirt and related packages to 0.5.0 versions

Actual results:
virsh commands fail unless --connect argument is given, until libvirtd is restarted

Expected results:
Hypervisor autodetection continues working, perhaps due to restarting libvirtd in %post when updating the package.

Additional info:
More informative error messages from virsh would be an acceptable workaround.

[root@bernoulli ~]# virsh list                                 
libvir: Remote error : internal error unable to auto-detect URI
error: failed to connect to the hypervisor                     
[root@bernoulli ~]# service libvirtd restart
Stopping libvirtd daemon:                                  [  OK  ]
Starting libvirtd daemon:                                  [  OK  ]
[root@bernoulli ~]# virsh list
 Id Name                 State
----------------------------------
Comment 1 Daniel Berrange 2009-01-22 08:19:51 EST
Regretably, there is nothing we can do about this particular bug, since it only hits on the upgrade to 0.5.0 - any new release we made now would not be affected. As of the next 0.6.0 release though, it will be possible to restart the libvirtd daemon without killing active VMs, which means we can put a 'service libvirtd restart' in the RPM %post to deal with any such issues like this in the future.

Note You need to log in before you can comment on or make changes to this bug.