Bug 475277 - pulseaudio/firefox hang under KDE
pulseaudio/firefox hang under KDE
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: libgnome (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-08 14:05 EST by Sammy
Modified: 2009-06-07 19:37 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-07 19:37:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sammy 2008-12-08 14:05:59 EST
At least a few times a day firefox plasma stops responding to mouse
clicks while actually starting processes in the background. This has
been the most annoying aspect of the new KDE for me.

It seems like I identified the problem. When this happens usually the
sound stops working as well. So, if I kill the pulseaudio daemon the
firefox process that had started in the background immediately opens up its
window on the screen. After that I just run 'sh /etc/kde/env/pulseaudio.sh'
and recover sound as well.

This clearly demonstrates that firefox (possibly other applications as well)
is waiting or having some bad interaction with pulseaudio daemon. Is it
possible to track this down further?
Thanks
Comment 1 Rex Dieter 2008-12-08 14:14:19 EST
Never seen that.  

But interesting how you classify this a "KDE" problem/bug, when the two items you identify as trouble-makers, firefox and pulseaudio, aren't kde apps or libraries.

That said, we're still very interested in helping to resolve this, but it's unclear to me how to proceed (since the problems seem to stem from non-kde components).
Comment 2 Sammy 2008-12-17 16:51:31 EST
Apparently not KDE bug. It is reported in a number of places one of which
is:

http://jeffreystedfast.blogspot.com/2008/07/more-pulseaudio-problems.html

According to cvs/svn commits it looks like it may be fixed in F10. We are
using F9. The commit for libgnome was included in LIBGNOME_2_23_5 and
esound the next release version (2.39.3!).

Could you please reassign this to libgnome/esound developers. 
Thanks
Comment 3 Andreas Utterberg 2009-01-22 04:49:37 EST
I can still confirm this issue in Fedora 10, KDE 4 on a Dell Latitude D830. I have had serious issues with sound and pulseuadio since upgraded from Fedora 9 (No problems at all in F9). I have now changed the sound order from Pulseaudio to HDA Intel (STAC92xxx Analog) in System Settings->Sound, but still have issues with Firefox.

Its easy to reproduce, browse to http://www.idg.se/2.1085/1.205561/lyxmobil-fran-motorola and try to watch the clip, the clip starts with no sound, when starting firefox from commandline following errormessage appears in the terminal.

ALSA lib pulse.c:272:(pulse_connect) PulseAudio: Unable to connect: Connection refused

Firefox freezes and is in a noresponse state, if i do nothing after sometime ff crashes.


lspci:

00:00.0 Host bridge: Intel Corporation Mobile PM965/GM965/GL960 Memory Controller Hub (rev 0c)
00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c)
00:02.1 Display controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c)
00:1a.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #4 (rev 02)
00:1a.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #5 (rev 02)
00:1a.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #2 (rev 02)
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 1 (rev 02)
00:1c.1 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 2 (rev 02)
00:1c.3 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 4 (rev 02)
00:1c.5 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 6 (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #3 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #1 (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev f2)
00:1f.0 ISA bridge: Intel Corporation 82801HEM (ICH8M) LPC Interface Controller (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) IDE Controller (rev 02)
00:1f.2 IDE interface: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) SATA IDE Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801H (ICH8 Family) SMBus Controller (rev 02)
03:01.0 CardBus bridge: O2 Micro, Inc. Cardbus bridge (rev 21)
03:01.4 FireWire (IEEE 1394): O2 Micro, Inc. Firewire (IEEE 1394) (rev 02)
09:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5755M Gigabit Ethernet PCI Express (rev 02)
0c:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG Network Connection (rev 02)
Comment 4 Sammy 2009-01-22 08:30:06 EST
Incorporating the esd patch on F9 solved this problem for me.
In F10 this patch and gnome patch should be already in the never
versions...surprising!

Note You need to log in before you can comment on or make changes to this bug.