Bug 475302 - qpidd immediately segfaults when starting up
qpidd immediately segfaults when starting up
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: qpidc (Show other bugs)
10
x86_64 Linux
urgent Severity urgent
: ---
: ---
Assigned To: Alan Conway
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-08 15:28 EST by Luke Macken
Modified: 2016-09-19 22:39 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-07 13:39:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Luke Macken 2008-12-08 15:28:50 EST
Description of problem:

Qpidd is segfaulting within a few seconds of starting up...

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x7ffff7a15950 (LWP 1388)]
qpid::management::ObjectId::encode (this=0x6479c8, buffer=@0x7ffff7a04e20)
    at qpid/management/ManagementObject.cpp:130
130	        buffer.putLongLong(first | agent->first);
(gdb) bt
#0  qpid::management::ObjectId::encode (this=0x6479c8, buffer=@0x7ffff7a04e20)
    at qpid/management/ManagementObject.cpp:130
#1  0x00000000001c2fd1 in qmf::com::redhat::rhm::store::Store::writeProperties
    () from /usr/lib64/qpid/daemon/msgstore.so
#2  0x0000003edb75851f in qpid::management::ManagementBroker::periodicProcessing (this=0x7ffff7a16010) at qpid/management/ManagementBroker.cpp:374
#3  0x0000003edb7590fb in qpid::management::ManagementBroker::Periodic::fire (
    this=0x639930) at qpid/management/ManagementBroker.cpp:251
#4  0x0000003edb7485be in qpid::broker::Timer::run (this=0x7ffff7a16140)
    at qpid/broker/Timer.cpp:64
#5  0x0000003edbb6c9fa in runRunnable (p=0x6479c8)
    at qpid/sys/posix/Thread.cpp:35
#6  0x0000003b138073da in start_thread (arg=<value optimized out>)
    at pthread_create.c:297
#7  0x0000003b12ce627d in clone ()
    at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112


Version-Release number of selected component (if applicable):
qpidc-0.3.722557-1.fc10.x86_64
qpidd-0.3.722557-1.fc10.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Run `qpidd`
2. Wait a few seconds...
3. SIGSEGV
Comment 1 Jose Pedro Oliveira 2008-12-10 20:04:28 EST
Same here in i386 (qpidd-0.3.722557-1.fc10.i386):

----------
# /usr/sbin/qpidd -t
2008-dec-11 00:55:03 info Loaded Module: /usr/lib/qpid/daemon/msgstore.so
2008-dec-11 00:55:03 info Management enabled
2008-dec-11 00:55:03 debug ManagementBroker restored broker ID: 5e54714e-847c-4e89-a878-fac5b2f00226
2008-dec-11 00:55:03 debug ManagementBroker boot sequence: 2
2008-dec-11 00:55:03 debug ManagementBroker added package org.apache.qpid.broker
2008-dec-11 00:55:03 debug ManagementBroker added class org.apache.qpid.broker:system
2008-dec-11 00:55:03 debug ManagementBroker added class org.apache.qpid.broker:broker
2008-dec-11 00:55:03 debug ManagementBroker added class org.apache.qpid.broker:agent
2008-dec-11 00:55:03 debug ManagementBroker added class org.apache.qpid.broker:vhost
2008-dec-11 00:55:03 debug ManagementBroker added class org.apache.qpid.broker:queue
2008-dec-11 00:55:03 debug ManagementBroker added class org.apache.qpid.broker:exchange
2008-dec-11 00:55:03 debug ManagementBroker added class org.apache.qpid.broker:binding
2008-dec-11 00:55:03 debug ManagementBroker added class org.apache.qpid.broker:connection
2008-dec-11 00:55:03 debug ManagementBroker added class org.apache.qpid.broker:link
2008-dec-11 00:55:03 debug ManagementBroker added class org.apache.qpid.broker:bridge
2008-dec-11 00:55:03 debug ManagementBroker added class org.apache.qpid.broker:session
2008-dec-11 00:55:03 debug ManagementBroker added class org.apache.qpid.broker:clientConnect
2008-dec-11 00:55:03 debug ManagementBroker added class org.apache.qpid.broker:clientConnectFail
2008-dec-11 00:55:03 debug ManagementBroker added class org.apache.qpid.broker:clientDisconnect
2008-dec-11 00:55:03 debug ManagementBroker added class org.apache.qpid.broker:brokerLinkUp
2008-dec-11 00:55:03 debug ManagementBroker added class org.apache.qpid.broker:brokerLinkDown
2008-dec-11 00:55:03 debug ManagementBroker added class org.apache.qpid.broker:queueDeclare
2008-dec-11 00:55:03 debug ManagementBroker added class org.apache.qpid.broker:queueDelete
2008-dec-11 00:55:03 debug ManagementBroker added class org.apache.qpid.broker:exchangeDeclare
2008-dec-11 00:55:03 debug ManagementBroker added class org.apache.qpid.broker:exchangeDelete
2008-dec-11 00:55:03 debug ManagementBroker added class org.apache.qpid.broker:bind
2008-dec-11 00:55:03 debug ManagementBroker added class org.apache.qpid.broker:unbind
2008-dec-11 00:55:03 debug ManagementBroker added class org.apache.qpid.broker:subscribe
2008-dec-11 00:55:03 debug ManagementBroker added class org.apache.qpid.broker:unsubscribe
Segmentation fault
----------


----------
...
Core was generated by `/usr/sbin/qpidd -t'.
Program terminated with signal 11, Segmentation fault.
[New process 2505]
[New process 2509]
[New process 2507]
[New process 2506]
[New process 2508]
#0  0x0078791b in qmf::com::redhat::rhm::store::Journal::Journal () from /usr/lib/qpid/daemon/msgstore.so
(gdb)  bt
#0  0x0078791b in qmf::com::redhat::rhm::store::Journal::Journal () from /usr/lib/qpid/daemon/msgstore.so
#1  0x007052a9 in mrg::msgstore::JournalImpl::JournalImpl () from /usr/lib/qpid/daemon/msgstore.so
#2  0x00721c22 in mrg::msgstore::MessageStoreImpl::init () from /usr/lib/qpid/daemon/msgstore.so
#3  0x00723ad6 in mrg::msgstore::MessageStoreImpl::init () from /usr/lib/qpid/daemon/msgstore.so
#4  0x00700965 in qpid::broker::StorePlugin::earlyInitialize () from /usr/lib/qpid/daemon/msgstore.so
#5  0x002690fe in Broker (this=0x8b9faf0, conf=@0x8ba1e70) at qpid/broker/Broker.cpp:194
#6  0x08050b78 in QpiddBroker::execute (this=0xbff24443, options=0x8ba1db8) at posix/QpiddBroker.cpp:161
#7  0x0804d429 in main (argc=2, argv=0xbff245f4) at qpidd.cpp:77
----------
Comment 2 Jose Pedro Oliveira 2008-12-13 11:56:06 EST
Hi,

Any news regarding this problem?
If not, can someone please revert the RPMS to the previous version?
Comment 3 Jose Pedro Oliveira 2008-12-15 12:29:45 EST
Has someone notice that it is impossible to run qpidd in Fedora 10 since the last qpid update (that occurred one week ago) ?
Comment 4 Jose Pedro Oliveira 2008-12-26 11:35:21 EST
System: Fedora 10 i386

With the latest build

  # rpm -q qpidc qpidd
  qpidc-0.4.728142-1.fc10.i386
  qpidd-0.4.728142-1.fc10.i386

the qpidd daemon starts. But if rhm is installed, it crashes:

  # rpm -q rhm
  rhm-0.4.3030-1.fc10.i386

  # /usr/sbin/qpidd -t
  2008-dec-26 16:34:04 info Loaded Module: /usr/lib/qpid/daemon/msgstore.so
  2008-dec-26 16:34:04 info Management enabled
  2008-dec-26 16:34:04 debug ManagementBroker restored broker ID: 5e54714e-847c-4e89-a878-fac5b2f00226
  2008-dec-26 16:34:04 debug ManagementBroker boot sequence: 19
  2008-dec-26 16:34:04 debug ManagementBroker added package org.apache.qpid.broker
  2008-dec-26 16:34:04 debug ManagementBroker added class org.apache.qpid.broker:system
  2008-dec-26 16:34:04 debug ManagementBroker added class org.apache.qpid.broker:broker
  2008-dec-26 16:34:04 debug ManagementBroker added class org.apache.qpid.broker:agent
  2008-dec-26 16:34:04 debug ManagementBroker added class org.apache.qpid.broker:vhost
  2008-dec-26 16:34:04 debug ManagementBroker added class org.apache.qpid.broker:queue
  2008-dec-26 16:34:04 debug ManagementBroker added class org.apache.qpid.broker:exchange
  2008-dec-26 16:34:04 debug ManagementBroker added class org.apache.qpid.broker:binding
  2008-dec-26 16:34:04 debug ManagementBroker added class org.apache.qpid.broker:connection
  2008-dec-26 16:34:04 debug ManagementBroker added class org.apache.qpid.broker:link
  2008-dec-26 16:34:04 debug ManagementBroker added class org.apache.qpid.broker:bridge
  2008-dec-26 16:34:04 debug ManagementBroker added class org.apache.qpid.broker:session
  2008-dec-26 16:34:04 debug ManagementBroker added class org.apache.qpid.broker:clientConnect
  2008-dec-26 16:34:04 debug ManagementBroker added class org.apache.qpid.broker:clientConnectFail
  2008-dec-26 16:34:04 debug ManagementBroker added class org.apache.qpid.broker:clientDisconnect
  2008-dec-26 16:34:04 debug ManagementBroker added class org.apache.qpid.broker:brokerLinkUp
  2008-dec-26 16:34:04 debug ManagementBroker added class org.apache.qpid.broker:brokerLinkDown
  2008-dec-26 16:34:04 debug ManagementBroker added class org.apache.qpid.broker:queueDeclare
  2008-dec-26 16:34:04 debug ManagementBroker added class org.apache.qpid.broker:queueDelete
  2008-dec-26 16:34:04 debug ManagementBroker added class org.apache.qpid.broker:exchangeDeclare
  2008-dec-26 16:34:04 debug ManagementBroker added class org.apache.qpid.broker:exchangeDelete
  2008-dec-26 16:34:04 debug ManagementBroker added class org.apache.qpid.broker:bind
  2008-dec-26 16:34:04 debug ManagementBroker added class org.apache.qpid.broker:unbind
  2008-dec-26 16:34:04 debug ManagementBroker added class org.apache.qpid.broker:subscribe
  2008-dec-26 16:34:04 debug ManagementBroker added class org.apache.qpid.broker:unsubscribe
  2008-dec-26 16:34:04 debug Exception constructed: Invalid argument (./qpid/sys/posix/Mutex.h:116)
  2008-dec-26 16:34:04 critical Broker start-up failed: Invalid argument (./qpid/sys/posix/Mutex.h:116)

  # echo $?
  1
Comment 5 Jose Pedro Oliveira 2009-01-07 12:02:32 EST
The rhm-0.4.3030-2 update appears to have solved the problem (no access to an i386 Fedora 10 system at the moment).

 * rpm -q rhm
   rhm-0.4.3030-2.fc10.x86_64

 * /usr/sbin/qpidd -t
...
2009-jan-07 17:00:26 debug ManagementBroker added class org.apache.qpid.broker:subscribe
2009-jan-07 17:00:26 debug ManagementBroker added class org.apache.qpid.broker:unsubscribe
2009-jan-07 17:00:26 notice Journal "TplStore": Created
2009-jan-07 17:00:26 debug Journal "TplStore": Journal directory = "/root/.qpidd/rhm/tpl/"; Base file name = "tpl"
2009-jan-07 17:00:26 notice Store module initialized; dir=/root/.qpidd
2009-jan-07 17:00:26 info > Default files per journal: 8
2009-jan-07 17:00:26 info > Default journal file size: 24 (wpgs)
2009-jan-07 17:00:26 info > Default write cache page size: 32 (Kib)
2009-jan-07 17:00:26 info > Default number of write cache pages: 32
2009-jan-07 17:00:26 info > TPL files per journal: 8
2009-jan-07 17:00:26 info > TPL journal file size: 24 (wpgs)
2009-jan-07 17:00:26 info > TPL write cache page size: 4 (Kib)
2009-jan-07 17:00:26 info > TPL number of write cache pages: 64
2009-jan-07 17:00:26 info SASL enabled
2009-jan-07 17:00:26 info Listening on TCP port 5672
2009-jan-07 17:00:26 debug ManagementBroker added package com.redhat.rhm.store
2009-jan-07 17:00:26 debug ManagementBroker added class com.redhat.rhm.store:store
2009-jan-07 17:00:26 debug ManagementBroker added class com.redhat.rhm.store:journal
Comment 6 Nuno Santos 2009-01-07 13:39:18 EST
The issue was due to rhm-0.4.3030-1 having been built against an older qpidc. The rhm-0.4.3030-2 package was built against the correct/matching qpidc (and now includes specific version dependency, at least while the ABI is in flux) and does fix the problem.
Comment 7 Jose Pedro Oliveira 2009-01-07 20:17:59 EST
Nuno,

Obrigado pela explicação.

jpo

Note You need to log in before you can comment on or make changes to this bug.