Bug 475357 - QA ONLY [LTC 5.4 FEAT] Verify all MSI-X interrupt capable IO adapters with MSI-X on Power platform [201700]
QA ONLY [LTC 5.4 FEAT] Verify all MSI-X interrupt capable IO adapters with MS...
Status: CLOSED DUPLICATE of bug 492580
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.4
ppc64 All
high Severity high
: alpha
: 5.4
Assigned To: Red Hat Kernel Manager
Red Hat Kernel QE team
: FutureFeature, OtherQA
Depends On:
Blocks: 445204 483701 483784
  Show dependency treegraph
 
Reported: 2008-12-08 17:40 EST by IBM Bug Proxy
Modified: 2009-06-20 04:35 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-11 09:29:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 50346 None None None Never

  None (edit)
Description IBM Bug Proxy 2008-12-08 17:40:40 EST
=Comment: #0=================================================
Emily J. Ratliff <ratliff@austin.ibm.com> - 
1. Feature Overview:
Feature Id:	[201700]
a. Name of Feature:	Verify all MSI-X interrupt capable IO adapters with MSI-X on Power platform
b. Feature Description
By 10/2009, the MSI-X interrupt will be supported by the system firmware and the Linux kernel. All
of the MSI-X capable adapters need to be verified to make sure that they can run correctly with the
feature. Any problems found in the individual driver will be addressed through the bug process.
 
 The driver/device that are expected to be verified as MSI-X capable are:
                 cxgb3 / Red River
 		e1000e / El Paso, Coleman
                 ixgbe / Knox 
 		s2io / King
 		bnx2 / Nemo and the Combo card
 		bnx2x / Cobia (Low priority. TBD as out-of-plan)
 		lpfc / Coho, Jack
 		qla2xxx / Qlogic 4G, 8G  and the Combo card
                 ib_mthca / CISCO 4X SDR IB HSDC (Arbel)
                 mlx4_ib / Mellanox 4X DDR IB HSDC (ConnectX)

2. Feature Details:
Sponsor:	PPC
Architectures:
ppc64

Arch Specificity: Purely Common Code
Affects Kernel Modules: Yes
Delivery Mechanism: Device Driver
Category:	Device Drivers and IO
Request Type:	Other
d. Upstream Acceptance:	No Code Required
Sponsor Priority	1
f. Severity: High
IBM Confidential:	no
Code Contribution:	no
g. Component Version Target:	

3. Business Case
The MSI-X interrupt provides better performance and throughput out of the PCI-Express IO devices.

4. Primary contact at Red Hat: 
John Jarvis
jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Stephanie Glass, sglass@us.ibm.com, 512-838-9284

Technical contact(s):
Daisy Chang, daisyc@us.ibm.com
Paul Larson, plars@us.ibm.com

IBM Manager:
Wendel Voigt, wvoigt@us.ibm.com
Comment 1 John Jarvis 2008-12-09 14:19:20 EST
IBM, what is your plan for providing the necessary hardware for testing this?
Comment 2 John Jarvis 2008-12-23 15:40:56 EST
IBM is signed up to test and provide feedback.
Comment 3 RHEL Product and Program Management 2009-02-16 10:18:58 EST
Updating PM score.
Comment 4 IBM Bug Proxy 2009-03-30 09:21:56 EDT
------- Comment From shaggy@linux.vnet.ibm.com 2009-03-30 09:13 EDT-------
This bug is being worked under LTC bug 51274, RH bug 279700.
Comment 5 John Jarvis 2009-04-13 12:32:00 EDT
RH bug 279700 does not exist, what is the correct number?
Comment 6 IBM Bug Proxy 2009-04-13 13:00:33 EDT
------- Comment From sglass@us.ibm.com 2009-04-13 12:56 EDT-------
Sorry John, that is a RH Issue tracker number 279700 which goes to RH bug 492580
Comment 7 John Jarvis 2009-06-11 09:29:08 EDT

*** This bug has been marked as a duplicate of bug 492580 ***

Note You need to log in before you can comment on or make changes to this bug.