Bug 475373 - [LTC 5.4 FEAT] Include a new driver - lin_tape - for supporting the IBM Tape Library. [201707]
[LTC 5.4 FEAT] Include a new driver - lin_tape - for supporting the IBM Tape ...
Status: CLOSED DUPLICATE of bug 512194
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.5
ppc64 All
high Severity high
: alpha
: 5.5
Assigned To: Ameet Paranjape
Red Hat Kernel QE team
: FutureFeature, OtherQA
Depends On:
Blocks: 483784
  Show dependency treegraph
 
Reported: 2008-12-08 18:10 EST by IBM Bug Proxy
Modified: 2010-03-30 14:29 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-25 12:48:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 50349 None None None Never

  None (edit)
Description IBM Bug Proxy 2008-12-08 18:10:40 EST
=Comment: #0=================================================
Emily J. Ratliff <ratliff@austin.ibm.com> - 
1. Feature Overview:
Feature Id:	[201707]
a. Name of Feature:	Include a new driver - lin_tape - for supporting the IBM Tape Library.
b. Feature Description
lin_tape is a newly open sourced driver for supporting IBM's tape libraries. This driver is planned
to be submitted to kernel.org for inclusion in 3Q/08.

2. Feature Details:
Sponsor:	PPC
Architectures:
ppc64

Arch Specificity: Purely Common Code
Affects Kernel Modules: Yes
Delivery Mechanism: Device Driver
Category:	Device Drivers and IO
Request Type:	Driver - New - Open Source
d. Upstream Acceptance:	In Progress
Sponsor Priority	1
f. Severity: High
IBM Confidential:	no
Code Contribution:	IBM code
g. Component Version Target:	2.6 29

3. Business Case
IBM tape libraries used to be supported via proprietary binaries online. This is to convert the
support from proprietary to the open source distributor release model for better customer support.

4. Primary contact at Red Hat: 
John Jarvis
jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Stephanie Glass, sglass@us.ibm.com, 512-838-9284

Technical contact(s):
Daisy Chang, daisyc@us.ibm.com
Malahal Naineni, naineni@us.ibm.com

IBM Manager:
Wendel Voigt, wvoigt@us.ibm.com
Comment 1 John Jarvis 2008-12-09 14:49:39 EST
It is now Q4/2008, has this driver been submitted upstream?
Comment 2 John Jarvis 2008-12-18 15:46:14 EST
Again, has this driver been submitted upstream?  If so, please provide upstream status and a link to the commit.  Also, does this driver require installer support and if so, has an Anaconda feature request been opened?
Comment 3 IBM Bug Proxy 2008-12-18 17:10:46 EST
(In reply to comment #5)
> Again, has this driver been submitted upstream?  If so, please provide upstream
> status and a link to the commit.  Also, does this driver require installer
> support and if so, has an Anaconda feature request been opened?
>

No, it has not been submitted yet. Brett is writing the driver (actually modifying it to fit mainline) and it will at least take 3 more months to submit anything to the upstream.

I don't think it requires installer support, but I will check with Brett to make sure that it is the case!
Comment 4 John Jarvis 2008-12-18 17:16:32 EST
Please be aware that the upstream acceptance deadline for 5.4 is January 26, 2009.  I would say this feature is definitely at risk for not making 5.4.
Comment 5 John Jarvis 2008-12-23 15:39:25 EST
IBM is signed up to test and provide feedback.
Comment 6 IBM Bug Proxy 2009-01-13 19:20:26 EST
This feature is going to come too late for RHEL 5.4.  Please defer this to RHEL 5.5.

Thanks, Stephanie
Comment 7 John Jarvis 2009-02-03 14:23:51 EST
removing from 5.4 tracker, placing on 5.5
Comment 8 John Jarvis 2009-03-25 12:48:32 EDT
Closing as DEFERRED based on comment 6
Comment 9 John Jarvis 2010-02-05 15:15:54 EST

*** This bug has been marked as a duplicate of bug 512194 ***

Note You need to log in before you can comment on or make changes to this bug.